> "Cert Fication" <[EMAIL PROTECTED]> wrote:
> Has anybody set VLAN on the switch and assign specific
> IP address to those VLAN. I need to see a config
> sample for creating three vlans and routing in between
> using a cisco router.
>
> switch: 2900 XL
> router: 7513
>
> I would appreciate if you could list some hardware
> requirements as well.

The following are excerpts from the ICND instructor configurations.
For the switch, you must go into the VLAN database and add any VLANs you
require. Then give the switch an IP address in the VLAN of your choice (for
switch management only) as well as a default gateway.

CORE_SW# vlan database
CORE_SW(vlan)# vlan 2 name vlan2
CORE_SW(vlan)# vlan 3 name vlan3
CORE_SW(vlan)# vlan 4 name vlan4
CORE_SW(vlan)# exit

Then go ahead and configure the switch to support an ISL trunk to the
router, as well as TCP/IP configuration for management.

!
interface FastEthernet0/23
 description - to CORE_RO
 switchport mode trunk
 no shutdown
!
interface VLAN1
 ip address 10.1.1.2 255.255.255.0
 no ip route-cache
!
ip default-gateway 10.1.1.3

Once you have done this, configure the router for inter-VLAN routing.

!
interface FastEthernet0/0
 no shutdown
!
interface FastEthernet 0/0.1
 encapsulation isl 1
 ip address 10.1.1.3 255.255.255.0
!
interface FastEthernet 0/0.2
 encapsulation isl 2
 ip address 10.2.2.3 255.255.255.0
!
interface FastEthernet 0/0.3
 encapsulation isl 3
 ip address 10.3.3.3 255.255.255.0
!
interface FastEthernet 0/0.4
 encapsulation isl 4
 ip address 10.4.4.3 255.255.255.0


Note that it is good practice not to use VLAN1 for actual user data. You
create separate VLANs for that purpose and route between them.

The router in the config above is a 3640, but the configuration is more or
less the same regardless of router model. The only important factor is that
the router *must* support a minimum 100Mbps Ethernet interface, or else ISL
encapsulation is not supported.
--

Edward Solomon
CCNA, CCSI
Senior I/T Specialist
Networking Solutions
IBM Canada Ltd. - Learning Services
Tel.: (905) 316-3241  Fax: (905) 316-3101
E-mail: [EMAIL PROTECTED]



___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to