Kenney, yes it is pretty cool stuff to use tunnel.
As an alternative, I was wondering if it would work fine using BGP.
I know that configuration of BGP is pretty complex.
I guess it will work since it deals with different AS’s and running
different protocols(in this case, they are EIGRP and IGRP)
If I am wrong, please correct me.

jeongwoo

------Original Message------
From: "Kenny Sallee" <[EMAIL PROTECTED]>
To: Chuck Larrieu <[EMAIL PROTECTED]>, Robert Padjen
<[EMAIL PROTECTED]>, Cisco Mail List <[EMAIL PROTECTED]>
Sent: June 7, 2000 6:39:42 PM GMT
Subject: Re: EIGRP contiguous AS


Using a tunnel is a good way to route non-routeable network ranges over the
routeable internet - or a WAN.  Say you are using a provider to connect 50
sites all via point-to-point T1's.  Becasue the sun shines, they are going
to charge you $1 Mil for routeable address space.  You don't offer internet
access to the sites so you don't need them.  So you decide to use private
address space for each location.  The only routeable IPs you have are on the
serial interfaces.  In order for each location to "know" about each other
location, you create tunnel interfaces as I have below, and run eigrp over
them.  Now a packet comes into the router for destination 172.16.1.50.  The
router does a route table lookup and finds the next-hop to be 172.16.1.2 -
which is out interface tunnel 0.  The router takes the packet, throws some
IP headers on it ( the tunnel source and tunnel destination ), and shoots it
to the tunnel destination.  The destination gets it, strips off the headers,
and routes it according to it's route table.  Voila - no routeable
addresses.  Pretty cool stuff if you ask me.  May be sloppy but works.

Kenny


----- Original Message -----
From: "Chuck Larrieu" <[EMAIL PROTECTED]>
To: "Robert Padjen" <[EMAIL PROTECTED]>; "Cisco Mail List"
<[EMAIL PROTECTED]>
Sent: Tuesday, June 06, 2000 10:51 AM
Subject: RE: EIGRP contiguous AS


> Other than the general sloppiness of such an approach, Robert, what are
some
> of your concerns? I think this might be an interesting discussion from a
> design standpoint.
>
> Chuck
>
> -----Original Message-----
> From: Robert Padjen [mailto:[EMAIL PROTECTED]]
> Sent: Tuesday, June 06, 2000 10:43 AM
> To: Gerwin Boschloo; 'Chuck Larrieu'; Cisco Mail List; Kenny Sallee
> Subject: RE: EIGRP contiguous AS
>
> The idea of using a tunnel for this scares the
> heeby-jeebies out of me!!! I should have noted a
> 'supportable' network! ;) It is a clever idea however.
>
>
> --- Gerwin Boschloo <[EMAIL PROTECTED]> wrote:
> > ok ok ok ok, you are all right...I was too fast with
> > my judgement.....sorry.
> > I thought that someone tried to use EIGRP and IGRP
> > to out smart BGP for
> > Interdomain routing......sorry again!!
> >
> > Gerwin
> > -----Original Message-----
> > From: Chuck Larrieu [mailto:[EMAIL PROTECTED]]
> > Sent: Tuesday, June 06, 2000 5:50 AM
> > To: Cisco Mail List; Kenny Sallee
> > Subject: RE: EIGRP contiguous AS
> >
> >
> > Excellent!!!!!
> >
> > -----Original Message-----
> > From: [EMAIL PROTECTED]
> > [mailto:[EMAIL PROTECTED]] On Behalf Of
> > Kenny Sallee
> > Sent: Monday, June 05, 2000 1:49 PM
> > To: Gerwin Boschloo; 'Luong, David'; 'Robert
> > Padjen';
> > [EMAIL PROTECTED]
> > Subject: Re: EIGRP contiguous AS
> >
> > Sure it will work -- if you redistribute. This is
> > where you will possible
> > see routing loops.
> >
> >  You can also create a tunnel interface on both
> > EIGRP routers and share
> > EIGRP info that way.  This way they will both look
> > like they are directly
> > connected.  Here's a possible config for the tunnel:
> >
> >      (e0) r1(s0) -----(s0) r2(s1) -----(s0)r3(e0)
> >
> > r1 and r3 e0 interfaces are in the 172.16.0.0
> > address space
> > All serial interfaces are in the 192.168.0.0 address
> > space
> > r1 and r3 are running eigrp
> > r2 is running igrp with someone else
> >
> > r1:
> > int e0
> > ip address 172.16.2.1 255.255.255.0
> >
> > int tunnel 0
> > ip address 172.16.1.1 255.255.255.0
> > tunnel source <r1 ip to r2>
> > tunnel destination <r3 ip to r2>
> > .....
> > .....
> > router eigrp 100
> > network 172.16.0.0
> > no auto
> >
> > r3:
> > int tunnel 0
> > ip address 172.16.1.2 255.255.255.0
> > tunnel source <r3 ip to r2>
> > tunnel destination <r1 ip to r2>
> >
> > router eigrp 100
> > network 172.16.0.0
> > no auto
> >
> >
> > Kenny
> >
> > ----- Original Message -----
> > From: "Gerwin Boschloo" <[EMAIL PROTECTED]>
> > To: "'Luong, David'" <[EMAIL PROTECTED]>;
> > "'Robert Padjen'"
> > <[EMAIL PROTECTED]>; <[EMAIL PROTECTED]>
> > Sent: Sunday, June 04, 2000 11:16 PM
> > Subject: RE: EIGRP contiguous AS
> >
> >
> > > EIGRP and IGRP are both Interior Gateway Protocols
> > that are used inside a
> > > AS. Therefore, when you want to connect different
> > AS'es, you need an
> > > Exterior Gateway Protocol like BGP. Within BGP you
> > are routing to
> > different
> > > AS'es therefore the AS'es should be unique.
> > >
> > > Therefore: EIGRP AS 1   ----   IGRP AS 50  ----
> > EIGRP AS 1 will not
> > work.
> > >
> > > Gerwin
> > >
> > > -----Original Message-----
> > > From: Luong, David [mailto:[EMAIL PROTECTED]]
> > > Sent: Thursday, June 01, 2000 1:14 AM
> > > To: 'Robert Padjen'; [EMAIL PROTECTED]
> > > Subject: RE: EIGRP contiguous AS
> > >
> > >
> > >
> > > If I remember correct, AS numbers do not have to
> > be contiguous unless if
> > you
> > > want automatic redistributing between EIGRP and
> > IGRP.  If you have
> > different
> > > AS across boundaries then you will need to have to
> > manually redistribute..
> > ..
> > >
> > > My $0.02...
> > >
> > > David Luong, CCNA,Network+,A+,i-Net+
> > > Telecommunications Analyst
> > > Insurance Corporation of B.C.
> > > Vancouver, B.C CANADA
> > >
> > >
> > > -----Original Message-----
> > > From: Robert Padjen [
> > mailto:[EMAIL PROTECTED]
> > > <mailto:[EMAIL PROTECTED]> ]
> > > Sent: Wednesday, May 31, 2000 3:18 PM
> > > To: [EMAIL PROTECTED]
> > > Subject: EIGRP contiguous AS
> > >
> > >
> > > I have an interesting question for the group,
> > although
> > > it is not directly related to any of the current
> > > exams.
> > >
> > > Does an EIGRP AS have to be contiguous or can it
> > be on
> > > two sides of an IGRP 'AS'. I note that the use of
> > the
> > > term AS is a mis-nomer for both protocols, but...
> > >
> > > For example, does:
> > >
> > > EIGRP AS 1   ----   IGRP AS 1   ----   EIGRP AS 1
> > >
> > > pose a problem?
> > >
> > > Does:
> > >
> > > EIGRP AS 1   ----   IGRP AS 50  ----   EIGRP AS 1
> > >
> > > My belief is that it could work, but it breaks the
> > > concept of an AS and could lead to routing
> > topology
> > > table problems. Any takers?
> > >
> > > (I'll be working with my team in the lab, but
> > thought
> > > it was an interesting thought questions.)
> > >
> > > Nothing but net!
> > >
> > > =====
> > > Robert Padjen
> > >
> > > __________________________________________________
> > > Do You Yahoo!?
> > > Send instant messages & get email alerts with
> > Yahoo! Messenger.
> > > http://im.yahoo.com/ <http://im.yahoo.com/>
> > >
> > > ___________________________________
> > > UPDATED Posting Guidelines:
> > http://www.groupstudy.com/list/guide.html
> > > <http://www.groupstudy.com/list/guide.html>
> > > FAQ, list archives, and subscription info:
> > http://www.groupstudy.com
> > > <http://www.groupstudy.com>
> > > Report misconduct and Nondisclosure violations to
> > [EMAIL PROTECTED]
> > >
> > > ___________________________________
> > > UPDATED Posting Guidelines:
> > http://www.groupstudy.com/list/guide.html
> > > FAQ, list archives, and subscription info:
> > http://www.groupstudy.com
> > > Report misconduct and Nondisclosure violations to
> > [EMAIL PROTECTED]
> > >
> >
> > ___________________________________
> > UPDATED Posting Guidelines:
> > http://www.groupstudy.com/list/guide.html
> > FAQ, list archives, and subscription info:
> > http://www.groupstudy.com
> > Report misconduct and Nondisclosure violations to
> > [EMAIL PROTECTED]
> >
> > ___________________________________
> > UPDATED Posting Guidelines:
> > http://www.groupstudy.com/list/guide.html
> >
> === message truncated ===
>
>
> =====
> Robert Padjen
>
> __________________________________________________
> Do You Yahoo!?
> Yahoo! Photos -- now, 100 FREE prints!
> http://photos.yahoo.com
>
> ___________________________________
> UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
> FAQ, list archives, and subscription info: http://www.groupstudy.com
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

........................................................ 
iWon.com       http://www.iwon.com     why wouldn't you? 
........................................................

___________________________________
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to