Thanks for all the recommendation from the group. I finally figured out how
to make it work...

Originally, on R2 , there is no route to 3.3.3.3, the reason why it is
pinging is because of the default route. Same on R3.

I ran "debug ip bgp out" and got the following error:

23:48:57: BGP: 2.2.2.2 multihop open delayed 13727ms (no route)
23:49:11: BGP: 2.2.2.2 multihop open delayed 16256ms (no route)
23:49:27: BGP: 2.2.2.2 multihop open delayed 13949ms (no route)
23:49:41: BGP: 2.2.2.2 multihop open delayed 18975ms (no route)
23:50:00: BGP: 2.2.2.2 multihop open delayed 19711ms (no route)

For some reason, the BGP neighbor setup process won't take default route.
Therefore, I tried to add static route for the loopback interface and then
the bgp session finally came up. I would imagine using IGP to carry the
loopback address should work as well.

Richard

""Raul Camacho"" <[EMAIL PROTECTED]> wrote in message
98pun2$b5l$[EMAIL PROTECTED]">news:98pun2$b5l$[EMAIL PROTECTED]...
> Just replicated your scenario:
>
> Top:
>
> R1----R4----R3
>
> R1 lo0: 172.16.31.1
> R1---R4: 172.16.4.X /24
> R4---R3: 172.16.3.X /24
> R4 lo0: 172.16.144.1
>
> IP OSPF running on R1,4,3; area 0
>
> R3 BGP config:
> router bgp 65001
>  neighbor 172.16.31.1 remote-as 65001
>  neighbor 172.16.31.1 update-source Loopback0
>
> R1 BGP config:
> router bgp 65001
>  neighbor 172.16.144.1 remote-as 65001
>  neighbor 172.16.144.1 update-source Loopback0
>
> OSPF routes:
> r1#sh ip rou ospf
>      172.16.0.0/16 is variably subnetted, 6 subnets, 2 masks
> O       172.16.144.1/32 [110/75] via 172.16.4.4, 00:08:44, Serial0.2
> O       172.16.128.0/24 [110/84] via 172.16.4.4, 00:08:44, Serial0.2
> O       172.16.242.4/32 [110/65] via 172.16.4.4, 00:08:44, Serial0.2
> O       172.16.3.0/24 [110/74] via 172.16.4.4, 00:08:44, Serial0.2
>
> IBGP relationship:
> r1#b
> BGP router identifier 172.16.31.1, local AS number 65001
> BGP table version is 1, main routing table version 1
>
> Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down
> State/PfxRcd
>
> 172.16.144.1    4 65001       8       8        1    0    0 00:05:13
0
>
> ""Richard Chang"" <[EMAIL PROTECTED]> wrote in message
> 98prh1$5ab$[EMAIL PROTECTED]">news:98prh1$5ab$[EMAIL PROTECTED]...
> > 1. I did have "update-source" command...
> > 2. loopback interfaces are pinging on both routers...
> >
> > I also wish that it is true that there is no limitation for ibgp
> multihop...
> >
> > However, based on my following test, the only conclusion I came up with
is
> > that either I missed something that's really obvious or Cisco does not
> > support ibgp multihop.
> >
> > R2:
> > interface Loopback0
> >  ip address 2.2.2.2 255.255.255.0
> >  no ip directed-broadcast
> >
> > router bgp 65001
> >  no synchronization
> >  bgp confederation identifier 100
> >  neighbor 3.3.3.3 remote-as 65001
> >  neighbor 3.3.3.3 update-source Loopback0
> >
> > R2#ping 3.3.3.3
> >
> > Type escape sequence to abort.
> > Sending 5, 100-byte ICMP Echos to 3.3.3.3, timeout is 2 seconds:
> > !!!!!
> >
> > R2#show ip bgp summ
> > BGP router identifier 2.2.2.2, local AS number 65001
> > BGP table version is 1, main routing table version 1
> >
> > Neighbor        V    AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down
> > State/PfxRcd
> > 3.3.3.3         4 65001       0       0        0    0    0 never
Active
> >
> > R3:
> > interface Loopback0
> >  ip address 3.3.3.3 255.255.255.0
> >  no ip directed-broadcast
> >
> > router bgp 65001
> >  no synchronization
> >  bgp confederation identifier 100
> >  neighbor 2.2.2.2 remote-as 65001
> >  neighbor 2.2.2.2 update-source Loopback0
> >
> > R3#ping 2.2.2.2
> >
> > Type escape sequence to abort.
> > Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:
> > !!!!!
> >
> > "Raul Camacho" <[EMAIL PROTECTED]> wrote in message
> > 98pha2$fop$[EMAIL PROTECTED]">news:98pha2$fop$[EMAIL PROTECTED]...
> > > There is no requirement for IBGP neigbors to be directly connected.
> Make
> > > sure that you have the routes for all of the intermediate links and
the
> > > loopbacks in your routing table first.
> > >
> > > ""Richard Chang"" <[EMAIL PROTECTED]> wrote in message
> > > 98p8ls$chl$[EMAIL PROTECTED]">news:98p8ls$chl$[EMAIL PROTECTED]...
> > > > For EBGP, you can use the ebgp-multihop command when the neighbors
are
> > not
> > > > directly-connected. I was just wondering whether there is a similar
> > > > work-around that anyone know of for IBGP.
> > > >
> > > > Basically, I am using loopback interfaces on these two routers and
> they
> > > have
> > > > to go through another hop before hitting each other. I configured
IBGP
> > on
> > > > these two routers with those loopback addresses and found out that
the
> > BGP
> > > > session can't be formed...
> > > >
> > > > Thanks
> > > >
> > > > Richard
> > > >
> > > >
> > > > _________________________________
> > > > FAQ, list archives, and subscription info:
> > > http://www.groupstudy.com/list/cisco.html
> > > > Report misconduct and Nondisclosure violations to
[EMAIL PROTECTED]
> > > >
> > >
> > >
> > > _________________________________
> > > FAQ, list archives, and subscription info:
> > http://www.groupstudy.com/list/cisco.html
> > > Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
> > >
> >
> >
> > _________________________________
> > FAQ, list archives, and subscription info:
> http://www.groupstudy.com/list/cisco.html
> > Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
> >
>
>
> _________________________________
> FAQ, list archives, and subscription info:
http://www.groupstudy.com/list/cisco.html
> Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]
>


_________________________________
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to