Surely there are a lot of solutions; which I'd do is:

Define a different VLAN for each floor.
Connect the catalysts in each floor with trunk interfaces (802.1q)
Connect a Fast or Giga ethernet interface from a router to one of the 
switches. You must setup that interface (both on the router an on the 
switch side) as 
DOT1Q. On the router you can do it with the following config:

-- Note: VLAN 101 - Floor 1
        VLAN 102 - Floor 2
        VLAN 103 - Floor 3


interface fastethernet 0/0 (for example)
        full-duplex (Duplex full?)
        speed 100
        no ip address
interface fastethernet 0/0.101 
        encap dot1q 101
        ip address 10.100.1.254 255.255.255.0
interface fastethernet 0/0.102
        encap dot1q 102
        ip address 10.100.2.254 255.255.255.0
interface fastethernet 0/0.103
        encap dot1q 103
        ip address 10.100.3.254 255.255.255.0

If you tell us which switches are you using (cat or IOS based) I can put 
you a config for that; assuming they are IOS, it is more or less:

--- Switch on floor 1:

interface FastEthernet0/1
 switchport access vlan 101
 switchport mode access
 duplex full
 speed 100

interface FastEthernet0/2
 switchport access vlan 101
 switchport mode access
 duplex full
 speed 100


.......

! Trunk to floor 2
interface FastEthernet0/10
 switchport mode trunk
 duplex full
 speed 100

..............

Switch on floor 2:
interface FastEthernet0/1
 switchport access vlan 102
 switchport mode access
 duplex full
 speed 100

interface FastEthernet0/2
 switchport access vlan 102
 switchport mode access
 duplex full
 speed 100


.......

! Trunk to floor 1
interface FastEthernet0/10
 switchport mode trunk
 duplex full
 speed 100

! Trunk to floor 3
interface FastEthernet0/11
 switchport mode trunk
 duplex full
 speed 100


................................


Francisco Sedano
Informatica Pronet
CCIE Student :-)






"Tamhankar, Nitin" 
Enviado por: [EMAIL PROTECTED]
09/01/2003 17:40
Por favor, responda a "Tamhankar, Nitin"
 
        Para:   [EMAIL PROTECTED]
        cc: 
        Asunto: Subnet question [7:60711]

This might be a very elementary question for some of you guys but I would
appreciate the answer. 

If an office which has 3 different floors and has Cisco routers and 
catalyst
switches and windows environment. We need to configure it in such a way 
that
each floor is on its own subnet for example 

floor1   100.10.1.0
floor2   100.10.2.0
floor3   100.10.3.0

Also if a computer which has IP address in subnet 100.10.1.0 is moved from
floor 1 to floor 2, it should not communicate with the network unless its 
IP
address is changed to one in 100.10.2.0 subnet.

How it can be accomplished?

Thank you
Nitin

[GroupStudy.com removed an attachment of type application/ms-tnef]




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=60754&t=60711
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to