[ https://issues.apache.org/jira/browse/CASSANDRA-15234?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17147386#comment-17147386 ]
Michael Semb Wever edited comment on CASSANDRA-15234 at 6/28/20, 6:33 PM: -------------------------------------------------------------------------- I've added some (very minor) comments on the [commit|https://github.com/ekaterinadimitrova2/cassandra/commit/f7ed1e00db5cc5810779a3d71dc065c750ba8e6b]. Higher level comments (while testing)… - during startup warnings about legacy yaml names are logged multiple times… - {{"it is scheduled to be removed by 5.0"}} would be more precise as {{"the old name is scheduled to be removed by 5.0"}} (as opposed to the setting+ value being removed), - if I define setting to a blank value, I get a error message like: {{"Invalid yaml. Those properties [max_hint_window] are not valid"}}. This falsely tells me thtat the setting name is wrong, rather than the value. (Invalid non-blank values provide useful error messages.) - integer overflow could have a better error message, currently {{"NumberFormatException: For input string: "9223372036854775808""}} - the under/over flow protection between units is nice. {{Duration.toMilliseconds()}} apidoc also describe the overflow to MAX_VALUE. (same goes for similar default-unit methods in BitsRate and DataStorage) - awesome that you can use {{µs}} :-) was (Author: michaelsembwever): I've added some (very minor) comments on the [commit|https://github.com/ekaterinadimitrova2/cassandra/commit/f7ed1e00db5cc5810779a3d71dc065c750ba8e6b]. Higher level comments (while testing)… - during startup warnings about legacy yaml names are logged multiple times… - {{"it is scheduled to be removed by 5.0"}} would be more precise as "the old name is scheduled to be removed by 5.0" (as opposed to the setting+ value being removed), - if I define setting to a blank value, I get a error message like: {{"Invalid yaml. Those properties [max_hint_window] are not valid"}}. This falsely tells me thtat the setting name is wrong, rather than the value. (Invalid non-blank values provide useful error messages.) - integer overflow could have a better error message, currently {{"NumberFormatException: For input string: "9223372036854775808""}} - the under/over flow protection between units is nice. {{Duration.toMilliseconds()}} apidoc also describe the overflow to MAX_VALUE. (same goes for similar default-unit methods in BitsRate and DataStorage) - awesome that you can use {{µs}} :-) > Standardise config and JVM parameters > ------------------------------------- > > Key: CASSANDRA-15234 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15234 > Project: Cassandra > Issue Type: Bug > Components: Local/Config > Reporter: Benedict Elliott Smith > Assignee: Ekaterina Dimitrova > Priority: Normal > Fix For: 4.0-alpha > > Attachments: CASSANDRA-15234-3-DTests-JAVA8.txt > > > We have a bunch of inconsistent names and config patterns in the codebase, > both from the yams and JVM properties. It would be nice to standardise the > naming (such as otc_ vs internode_) as well as the provision of values with > units - while maintaining perpetual backwards compatibility with the old > parameter names, of course. > For temporal units, I would propose parsing strings with suffixes of: > {{code}} > u|micros(econds?)? > ms|millis(econds?)? > s(econds?)? > m(inutes?)? > h(ours?)? > d(ays?)? > mo(nths?)? > {{code}} > For rate units, I would propose parsing any of the standard {{B/s, KiB/s, > MiB/s, GiB/s, TiB/s}}. > Perhaps for avoiding ambiguity we could not accept bauds {{bs, Mbps}} or > powers of 1000 such as {{KB/s}}, given these are regularly used for either > their old or new definition e.g. {{KiB/s}}, or we could support them and > simply log the value in bytes/s. -- This message was sent by Atlassian Jira (v8.3.4#803005) --------------------------------------------------------------------- To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org