I think this is a quite ugly method signature. We already have a NameValuePair class. I prefer to use an array of thos objects rather than two unrelated arrays of related values. Furthermore the java doc does not help the user to understand what should be passed here.

Odi

[EMAIL PROTECTED] wrote:

+ /**
+ * Set the array of the query.
+ *
+ * @param queryName the array of the query string.
+ * @param queryValue the array of the query string.
+ * @exception URIException incomplete trailing escape pattern,
+ * unsupported character encoding or wrong array size
+ * @throws NullPointerException null query
+ * @see #encode
+ */
+ public void setQuery(String[] queryName, String[] queryValue)

--
To unsubscribe, e-mail:   <mailto:commons-dev-unsubscribe@;jakarta.apache.org>
For additional commands, e-mail: <mailto:commons-dev-help@;jakarta.apache.org>

Reply via email to