> Should IOUtils be called StreamUtils?
No, as it has readers/writers too. IOUtils is OK, though I would prefer
dividing to InputUtils, OutputUtils and CopyUtils.

> > > byteCountToDisplaySize is not File based but a simple helper to show a
> > > number in 1024 units, much like -h flag to 'du' or 'df'. Still, not
sure
> > > it fits anywhere else either and it is handy-ish.
> >
> > It's nice-to-have. Should we move to to a separate class? I'm not sad if
> > we remove it, though.
I suggest adding a FileFormatUtils (or some such name) that might also
replace HexDump.

> > > Other than that, the use of 'final' in method parameters is not
normally
> > > our communities coding style and we might want to dump that.
> > Doesn't the 'final' modifier help the JIT to improve speed?
It has no performance benefit (thats a myth). There was a time when I was
adding final in, but now I would probably take it out.

Stephen


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to