I'm glad to see this coming along…  The code, javadoc, and spec all look good.

On Mar 20, 2015, at 3:00 PM, Vladimir Kozlov <vladimir.koz...@oracle.com> wrote:
> 
>> http://cr.openjdk.java.net/~aph/unaligned.jdk.7/ 
>> <http://cr.openjdk.java.net/~aph/unaligned.jdk.7/>
> 
> My only comment for jdk change is to use bigEndian name instead of BE in 
> Unsafe.java. Someone from core libs should look on this.

Here's my take on that bit (subject of course to correction from a core-libs 
eng.).

BE (though short), as an upper-case acronym, is more correct than mixed-case 
bigEndian, according to the conventions suggested by JLS 6.1:

> Constant Names
> 
> The names of constants in interface types should be, and final variables of 
> class types may conventionally be, a sequence of one or more words, acronyms, 
> or abbreviations, all uppercase, with components separated by underscore "_" 
> characters. Constant names should be descriptive and not unnecessarily 
> abbreviated. Conventionally they may be any appropriate part of speech.
> 
> Examples of names for constants include MIN_VALUE, MAX_VALUE, MIN_RADIX, and 
> MAX_RADIX of the class Character.

So I think it's OK as-is, especially since it is a private name.

— John

Reply via email to