On Tue, 5 Jul 2022 10:56:45 GMT, Alan Bateman <al...@openjdk.org> wrote:

> > Unless you feel this is a must, I would prefer to keep the DataProviders. 
> > The benefit I see is the test code does not need to be duplicated per 
> > parameter, each test scenario can be run as an individual test so that you 
> > do not need extra plumbing to run each test scenario in the unlikely event 
> > of a failure.
> 
> Okay, but there are a few other things to mention:
> 
> One issue is the reset method is called at the end of each test. I think it 
> needs to be at the beginning of the method, moved to a finally block of a 
> try-finally, or maybe @BeforeMethod to reset before each test. The reason is 
> that one test failing will cause the tests that follow to fail too.

Good catch, added `@BeforeMethod`
> 
> The fields aren't constants so looks a bit strange (to me anyway) to be in 
> uppercase. If you rename them then I think the tests would be a bit more 
> readable.

Ah,  sometimes you see what you want.  I must have had fields on my mind when I 
did that as I completely agree with you.  

 Both of the above are addressed in the latest update to the PR.

Thank you for the feedback.

-------------

PR: https://git.openjdk.org/jdk/pull/9249

Reply via email to