On Fri, 27 Sep 2024 16:06:51 GMT, Brian Burkhalter <[email protected]> wrote:
> Improve the first sentences of the three `FileInputStream` constructors, in
> particular removing the term "connection."
Do you think, as part of this PR, we should also revisit some of the javadoc in
the `java.io.FileOutputStream` class which too has several mentions of
"connection"?
src/java.base/share/classes/java/io/FileInputStream.java line 118:
> 116: /**
> 117: * Creates a {@code FileInputStream} to read from an existing file
> 118: * named by the {@code File} object {@code file}.
Hello Brian, should be perhaps reword this as "... to read from an existing
file represented by the {@code file}." This would almost match what we state
for the constructor which takes the `FileDescriptor` instance.
-------------
PR Comment: https://git.openjdk.org/jdk/pull/21223#issuecomment-2380434852
PR Review Comment: https://git.openjdk.org/jdk/pull/21223#discussion_r1779379540