On Fri, 27 Sep 2024 16:06:51 GMT, Brian Burkhalter <[email protected]> wrote:
> Improve the first sentences of the three `FileInputStream` constructors, in
> particular removing the term "connection."
src/java.base/share/classes/java/io/FileInputStream.java line 166:
> 164: /**
> 165: * Creates a {@code FileInputStream} to read from an existing file
> 166: * represented by the {@code FileDescriptor} object {@code fdObj}.
I don't know if you meant to touch this constructor or not but I think it's
okay to use "connected" here as this is creating a FIS to read bytes from
whatever the file descriptor is connected to.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21223#discussion_r1779926706