On Sat, 28 Sep 2024 06:49:44 GMT, Jaikiran Pai <[email protected]> wrote:
>> Improve the first sentences of the three `FileInputStream` constructors, in
>> particular removing the term "connection."
>
> src/java.base/share/classes/java/io/FileInputStream.java line 118:
>
>> 116: /**
>> 117: * Creates a {@code FileInputStream} to read from an existing file
>> 118: * named by the {@code File} object {@code file}.
>
> Hello Brian, should be perhaps reword this as "... to read from an existing
> file represented by the {@code file}." This would almost match what we state
> for the constructor which takes the `FileDescriptor` instance.
Updated for the next commit.
-------------
PR Review Comment: https://git.openjdk.org/jdk/pull/21223#discussion_r1781891337