On Sun, 20 Sep 2026 12:54:15 GMT, Jaikiran Pai <[email protected]> wrote:

>> Markus KARG has updated the pull request incrementally with two additional 
>> commits since the last revision:
>> 
>>  - Protected backwards-compatible behavior of existing subclasses as 
>> proposed by Jaikiran Pai
>>  - Removed (fast/slow path) comments
>
> test/jdk/java/io/Reader/ReadAll.java line 283:
> 
>> 281:         }
>> 282: 
>> 283:         // InputStreamReader implementation: Internal decoder, empty 
>> stream but decoder has bytes
> 
> Here and a few other places in this updated test, I think it would be good to 
> replace the use of "Internal decoder" with something like "decoder belongs to 
> the Charset instance". The "empty stream but decoder has bytes" part here is 
> a bit confusing, since the stream isn't empty. For this specific comment 
> maybe something like this would be appropriate?
> 
> decoder belongs to the Charset instance, read all bytes from the stream using 
> read(), then call readAllAsString()

Same comment for one other place in this test which says "empty stream but 
decoder has bytes".

-------------

PR Review Comment: https://git.openjdk.org/jdk/pull/32264#discussion_r4056985582

Reply via email to