2013/5/17 Richard Shann <richard.sh...@virgin.net>

> On Fri, 2013-05-17 at 16:21 +0200, Éloi Rivard wrote:
> > About generate_commands,
> >
> > You said it generates ancient built-in commands. Do you mean it is the
> > old way to generate built-in commands ? What would be the new one ?
>
> I think you meant generate_source.c (it generates C source code). It was
> constructed initially by taking an array out of Denemo and using the
> array to generate new C code for those commands. It also has sets of
> commands for note names A-G and note durations 0-7 generated
> programmatically.
>
> New commands are either pure scripts, or if some C-code is needed a new
> primitive is created as outlined on irc #denemo
>

Do you mean those old built-in commands could actually be written in scheme
?


> <rshann_> I think you may have already sorted it out. You write a
> scheme_xxx function in view.c and then an INSTALL_,,, macro further down
> that references it. Note the naming convention
>
>  scheme_aaa_bbb() becomes command d-AaaBbb
>
> It is probably good to discuss a new command name before finalizing it
> as it is difficult to choose one that will be good from all perspectives
> and last under changing circumstances; and difficult to change the name
> without breaking scripts people may have written.
>
> Richard
>
>
>
>
> >
> >
> >
> > 2013/5/6 Éloi Rivard <azm...@gmail.com>
> >         Ok I have rights to write on the master branch. This is
> >         merged.
> >
> >
> >
> >         2013/5/6 Éloi Rivard <azm...@gmail.com>
> >                 I just tested creation and deletion of a branch. It
> >                 works
> >
> >
> >
> >                 2013/5/6 Richard Shann <richard.sh...@virgin.net>
> >                         On Mon, 2013-05-06 at 16:29 +0200, Éloi Rivard
> >                         wrote:
> >                         > Also, the git philosophy is to have one
> >                         branch per feature, and merge
> >                         > the branches when the feature has been
> >                         reviewed and tested by the
> >                         > upstream, as you can see in github for
> >                         example. Then the branch is
> >                         > deleted.
> >                         > It would be great if I could have the
> >                         permission to create branches,
> >                         > so you could have time to review my code
> >                         while I am working on
> >                         > something else. What do you think ?
> >
> >                         That sounds good - I believe one of the
> >                         features of git is that branches
> >                         are cheap. And it will be good to delete old
> >                         ones once they are no
> >                         longer of use as it helps to see what is what.
> >                         Do you already have permission to create
> >                         branches? If not, perhaps
> >                         Jeremiah will want to comment on this (I
> >                         suspect he is quite busy just
> >                         now though) ...
> >
> >                         Richard
> >
> >
> >                         >
> >                         >
> >                         > 2013/5/6 Éloi Rivard <azm...@gmail.com>
> >                         >         I updated the comment.
> >                         >         I would be happy to do this but I am
> >                         not sure I have the
> >                         >         rights to write on the master
> >                         branch. Have I ?
> >                         >
> >                         >
> >                         >
> >                         >         2013/5/6 Richard Shann
> >                         <richard.sh...@virgin.net>
> >                         >                 Great - I tested this as a
> >                         new user, getting your
> >                         >                 branch by git clone.
> >                         >                 Your standalone generator is
> >                         working perfectly -
> >                         >                 slightly too perfectly
> >                         >                 inasmuch as the resulting
> >                         commands.c is identical
> >                         >                 including the initial
> >                         >                 comment at the top of the
> >                         file which needs now to
> >                         >                 point to the new
> >                         >                 generate_commands.c file :)
> >                         >                 We should aim to integrate
> >                         your work as often as we
> >                         >                 can, so I suggest a
> >                         >                 merge of your branch (to the
> >                         current commit
> >                         >
> >                         62b71f3180a07cf91d4916588a014db13125ab46) now.
> >                         Are you
> >                         >                 happy (& able) to
> >                         >                 do this?
> >                         >
> >                         >                 Richard
> >                         >
> >                         >
> >                         >                 On Mon, 2013-05-06 at 11:42
> >                         +0200, Éloi Rivard wrote:
> >                         >                 > This is pushed on eloi
> >                         branch.
> >                         >                 > Yep I use color-gcc for
> >                         debugging but I forgot to
> >                         >                 reset gcc instead,
> >                         >                 > this is fixed.
> >                         >                 >
> >                         >                 >
> >                         >                 >
> >                         >                 > 2013/5/6 Richard Shann
> >                         <richard.sh...@virgin.net>
> >                         >                 >         On Sun, 2013-05-05
> >                         at 20:42 +0200, Éloi
> >                         >                 Rivard wrote:
> >                         >                 >         >
> >                         >                 >         >
> >                         >                 >         >
> >                         >                 >         > See attached
> >                         patch.
> >                         >                 utils/generate_commands
> >                         creates the very
> >                         >                 >         same code
> >                         >                 >         > than launching
> >                         denemo with
> >                         >                 -DGENERATE_SOURCE_CODE
> >                         >                 >         > I indented some
> >                         code in keyboard.c so some
> >                         >                 line have been
> >                         >                 >         changed but
> >                         >                 >         > the behavior is
> >                         the same. I also fixed
> >                         >                 some unused variable
> >                         >                 >         warnings.
> >                         >                 >
> >                         >                 >
> >                         >                 >         This looks
> >                         excellent - good work! I don't
> >                         >                 want to be acting as
> >                         >                 >         a brake
> >                         >                 >         on your
> >                         development - I will get stressed
> >                         >                 out if I think
> >                         >                 >         someone is
> >                         >                 >         waiting for me to
> >                         do something. So I think
> >                         >                 it will be good if
> >                         >                 >         you bring
> >                         >                 >         the branch eloi
> >                         that Jeremiah created for
> >                         >                 you in git
> >                         >                 >         up-to-date using
> >                         >                 >         git merge (or
> >                         whatever it is called) and
> >                         >                 commit your changes
> >                         >                 >         there (I am
> >                         >                 >         presuming Jeremiah
> >                         has given you write
> >                         >                 permission).
> >                         >                 >         I have a separate
> >                         user account which I can
> >                         >                 use to build from
> >                         >                 >         that branch
> >                         >                 >         in a clean
> >                         environment and test there.
> >                         >                 >         This would be
> >                         making proper use of git,
> >                         >                 rather than the
> >                         >                 >         old-fashioned
> >                         >                 >         patch methods...
> >                         >                 >
> >                         >                 >          One thing I
> >                         noticed in your code is
> >                         >                 something called
> >                         >                 >         color-gcc, which I
> >                         >                 >         guess is some
> >                         colorized version of gcc? - I
> >                         >                 don't have that,
> >                         >                 >         and we
> >                         >                 >         wouldn't want to
> >                         introduce more dependencies
> >                         >                 without a good
> >                         >                 >         reason...
> >                         >                 >         But that is the
> >                         sort of wrinkle easily
> >                         >                 sorted out once the
> >                         >                 >         code is in
> >                         >                 >         git.
> >                         >                 >
> >                         >                 >         Richard
> >                         >                 >
> >                         >                 >
> >                         >                 >
> >                         >                 >
> >                         >                 >
> >                         >                 > --
> >                         >                 > Éloi Rivard -
> >                         azm...@gmail.com
> >                         >                 >
> >                         >                 > « On perd plus à être
> >                         indécis qu'à se tromper. »
> >                         >                 >
> >                         >
> >                         >
> >                         >
> >                         >
> >                         >
> >                         >
> >                         >         --
> >                         >         Éloi Rivard - azm...@gmail.com
> >                         >
> >                         >         « On perd plus à être indécis qu'à
> >                         se tromper. »
> >                         >
> >                         >
> >                         >
> >                         >
> >                         > --
> >                         > Éloi Rivard - azm...@gmail.com
> >                         >
> >                         > « On perd plus à être indécis qu'à se
> >                         tromper. »
> >                         >
> >                         >
> >                         >
> >
> >
> >
> >
> >
> >
> >                 --
> >                 Éloi Rivard - azm...@gmail.com
> >
> >                 « On perd plus à être indécis qu'à se tromper. »
> >
> >
> >
> >
> >         --
> >         Éloi Rivard - azm...@gmail.com
> >
> >         « On perd plus à être indécis qu'à se tromper. »
> >
> >
> >
> >
> > --
> > Éloi Rivard - azm...@gmail.com
> >
> > « On perd plus à être indécis qu'à se tromper. »
> >
>
>
>


-- 
Éloi Rivard - azm...@gmail.com

« On perd plus à être indécis qu'à se tromper. »
_______________________________________________
Denemo-devel mailing list
Denemo-devel@gnu.org
https://lists.gnu.org/mailman/listinfo/denemo-devel

Reply via email to