We currently use location.origin quite frequently in gaia, and we also use it 
in workers. My vote would be to keep it around, especially if we have no way of 
getting document.origin from a worker.

The naming is a bit confusing to me as a web developer. Not sure if it's 
possible, but at first glance something like `location.documentOrigin` would 
make more sense to me - then we could use it in workers I assume?

Best,
Kevin

----- Original Message -----
From: "Mounir Lamouri" <mou...@lamouri.fr>
To: dev-platform@lists.mozilla.org
Sent: Tuesday, December 2, 2014 3:43:08 AM
Subject: Re: Intent to implement and ship: document.origin

On Tue, 2 Dec 2014, at 02:09, Boris Zbarsky wrote:
> Summary: document.origin returns the Unicode serialization of the 
> document's origin.  The returned value does not depend on what 
> document.domain was set to.
> 
> Bug: https://bugzilla.mozilla.org/show_bug.cgi?id=931884
> 
> Spec: http://dom.spec.whatwg.org/#dom-document-origin
> 
> Platform coverage: All of them.
> 
> Estimated release: 37
> 
> I don't plan to put this behind a pref.  It's trivial to back out if 
> need be.
> 
> Blink is considering implementing this too, and they're trying to find 
> out whether we plan to implement.  I think this is a useful feature and 
> we should add it.

For those interested.

Blink patch:
https://codereview.chromium.org/758913002

... and blink-dev discussion:
https://groups.google.com/a/chromium.org/d/msg/blink-dev/8aDWaY9b3BM/sb77MikxNncJ

-- Mounir
_______________________________________________
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform
_______________________________________________
dev-platform mailing list
dev-platform@lists.mozilla.org
https://lists.mozilla.org/listinfo/dev-platform

Reply via email to