I would love to change this name. I did not come from an Ivy background and have always felt this was awkward.

I have also always felt that using configurations to store paths and to specify a distribution archive were two very different uses that didn't belong together. I would like to see the archive part pulled out into another concept.

To me, the core of configurations are named dependencies.  I like:

dependencyNames {
   compile
   openAPI
}

dependencies {
   compile 'commons-io:commons-io:1.4'
}

I think "paths" are a little too generic. And paths.compile.asPath seems a little strange :)


Hans Dockter wrote:
I would love to have a better name for configurations. Initially I just took this name from Ivy as I couldn't think of anything better. Even with Ivy I guess it is not a perfect name. But in the context of a build system it is really confusing.

Mostly configurations are classpaths, but not always (e.g. they may contain distribution archives). Why not calling configurations paths?

paths {
   compile "commons-io:commons-io:1.4"
}

paths.compile.files ...

Thoughts? Better names?

I know that this would be a pretty disruptive change. It would have been much better to have done this earlier. But that's why we are still pre 1.0.

- Hans

--
Hans Dockter
Gradle Project Manager
http://www.gradle.org


---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email




--
Steve Appling
Automated Logic Research Team

---------------------------------------------------------------------
To unsubscribe from this list, please visit:

   http://xircles.codehaus.org/manage_email


Reply via email to