-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36123/#review108065
-----------------------------------------------------------



core/src/main/java/org/apache/oozie/action/callback/CallbackActionExecutor.java 
(line 195)
<https://reviews.apache.org/r/36123/#comment167442>

    We're in the CallbackActionExecutor, so you can just refer to these 
directly: CALLBACK_ACTION_HTTP_CONNECTION_TIMEOUT_SECS, 
CALLBACK_ACTION_HTTP_SOCKET_TIMEOUT_SECS, and CALLBACK_ACTION_KEEPALIVE_SECS
    to improve readability



core/src/test/java/org/apache/oozie/action/callback/TestCallbackActionExecutor.java
 (line 133)
<https://reviews.apache.org/r/36123/#comment167444>

    Perhaps we should use ``(freeHTTPPort + 1)`` for this?



core/src/test/java/org/apache/oozie/action/callback/TestCallbackActionExecutor.java
 (line 172)
<https://reviews.apache.org/r/36123/#comment167445>

    Perhaps we should use ``(freeJMSPort + 1)`` for this?



docs/src/site/twiki/DG_CallbackActionExtension.twiki (line 12)
<https://reviews.apache.org/r/36123/#comment167440>

    Callback Action



docs/src/site/twiki/DG_CallbackActionExtension.twiki (line 97)
<https://reviews.apache.org/r/36123/#comment167439>

    minOccurs="0".
    
    Please double check that this all matches the XSD file.  It might be 
easiest to just copy-paste it again.


- Robert Kanter


On Nov. 12, 2015, 12:21 p.m., Jaydeep Vishwakarma wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36123/
> -----------------------------------------------------------
> 
> (Updated Nov. 12, 2015, 12:21 p.m.)
> 
> 
> Review request for oozie.
> 
> 
> Bugs: OOZIE-2259
>     https://issues.apache.org/jira/browse/OOZIE-2259
> 
> 
> Repository: oozie-git
> 
> 
> Description
> -------
> 
> Adding callback as an action, It have support for HTTP and JMS server. Not 
> covering Excecutor level queue, I will create a separate jira for it.
> 
> 
> Diffs
> -----
> 
>   client/src/main/java/org/apache/oozie/cli/OozieCLI.java 48bac7d 
>   client/src/main/resources/callback-action-0.1.xsd PRE-CREATION 
>   
> core/src/main/java/org/apache/oozie/action/callback/CallbackActionExecutor.java
>  PRE-CREATION 
>   core/src/main/java/org/apache/oozie/action/callback/JMSNotification.java 
> PRE-CREATION 
>   core/src/main/java/org/apache/oozie/service/CallbackActionService.java 
> PRE-CREATION 
>   core/src/main/resources/oozie-default.xml 0a7e250 
>   
> core/src/test/java/org/apache/oozie/action/callback/TestCallbackActionExecutor.java
>  PRE-CREATION 
>   docs/src/site/twiki/DG_CallbackActionExtension.twiki PRE-CREATION 
>   docs/src/site/twiki/DG_CommandLineTool.twiki 1823247 
>   docs/src/site/twiki/index.twiki 8591530 
> 
> Diff: https://reviews.apache.org/r/36123/diff/
> 
> 
> Testing
> -------
> 
> Done, 
> Will add more test cases.
> 
> 
> Thanks,
> 
> Jaydeep Vishwakarma
> 
>

Reply via email to