devel
Thread
Date
Earlier messages
Later messages
Messages by Thread
Re: [PATCH v2 02/35] monitor: replace 'common' with 'parent_obj' in MonitorHMP
marcandre.lureau--- via Devel
[PATCH v2 04/35] monitor: rename monitor_init* to monitor_new*
Daniel P . Berrangé via Devel
Re: [PATCH v2 04/35] monitor: rename monitor_init* to monitor_new*
marcandre.lureau--- via Devel
[PATCH v2 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP
Daniel P . Berrangé via Devel
Re: [PATCH v2 03/35] monitor: replace 'common' with 'parent_obj' in MonitorQMP
marcandre.lureau--- via Devel
[PATCH v2 05/35] monitor: minimal conversion of monitors to QOM
Daniel P . Berrangé via Devel
Re: [PATCH v2 05/35] monitor: minimal conversion of monitors to QOM
marcandre.lureau--- via Devel
[PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
Re: [PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
marcandre.lureau--- via Devel
Re: [PATCH v2 06/35] monitor: add 'chardev' property to Monitor base class
Daniel P . Berrangé via Devel
[PATCH v2 07/35] monitor: add 'readline' property to HMP Monitor class
Daniel P . Berrangé via Devel
Re: [PATCH v2 07/35] monitor: add 'readline' property to HMP Monitor class
marcandre.lureau--- via Devel
[PATCH v2 08/35] monitor: add 'pretty' property to QMP Monitor class
Daniel P . Berrangé via Devel
Re: [PATCH v2 08/35] monitor: add 'pretty' property to QMP Monitor class
marcandre.lureau--- via Devel
[PATCH v2 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize
Daniel P . Berrangé via Devel
Re: [PATCH v2 10/35] monitor: move monitor_data_(init|destroy) into QOM init/finalize
marcandre.lureau--- via Devel
[PATCH v2 09/35] monitor: remove 'skip_flush' field
Daniel P . Berrangé via Devel
Re: [PATCH v2 09/35] monitor: remove 'skip_flush' field
marcandre.lureau--- via Devel
[PATCH v2 12/35] monitor: use class methods for monitor_qapi_event_emit
Daniel P . Berrangé via Devel
Re: [PATCH v2 12/35] monitor: use class methods for monitor_qapi_event_emit
marcandre.lureau--- via Devel
[PATCH v2 11/35] monitor: use class methods for monitor_vprintf
Daniel P . Berrangé via Devel
Re: [PATCH v2 11/35] monitor: use class methods for monitor_vprintf
marcandre.lureau--- via Devel
[PATCH v2 13/35] monitor: use class methods for monitor_accept_input
Daniel P . Berrangé via Devel
Re: [PATCH v2 13/35] monitor: use class methods for monitor_accept_input
marcandre.lureau--- via Devel
[PATCH v2 14/35] monitor: use class method for I/O thread request
Daniel P . Berrangé via Devel
Re: [PATCH v2 14/35] monitor: use class method for I/O thread request
marcandre.lureau--- via Devel
[PATCH v2 16/35] util: use dynamic cast in error vreport
Daniel P . Berrangé via Devel
Re: [PATCH v2 16/35] util: use dynamic cast in error vreport
marcandre.lureau--- via Devel
[PATCH v2 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
Daniel P . Berrangé via Devel
Re: [PATCH v2 15/35] monitor: use dynamic cast in monitor_qmp_requests_pop_any_with_lock
marcandre.lureau--- via Devel
[PATCH v2 17/35] monitor: drop unused monitor_cur_is_qmp
Daniel P . Berrangé via Devel
Re: [PATCH v2 17/35] monitor: drop unused monitor_cur_is_qmp
marcandre.lureau--- via Devel
[PATCH v2 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive
Daniel P . Berrangé via Devel
Re: [PATCH v2 19/35] monitor: use dynamic cast in monitor_is_hmp_non_interactive
marcandre.lureau--- via Devel
[PATCH v2 20/35] monitor: drop unused monitor_is_qmp method
Daniel P . Berrangé via Devel
Re: [PATCH v2 20/35] monitor: drop unused monitor_is_qmp method
marcandre.lureau--- via Devel
[PATCH v2 18/35] monitor: use dynamic cast in QMP commands
Daniel P . Berrangé via Devel
Re: [PATCH v2 18/35] monitor: use dynamic cast in QMP commands
marcandre.lureau--- via Devel
[PATCH v2 22/35] monitor: implement "user creatable" interface for adding monitors
Daniel P . Berrangé via Devel
Re: [PATCH v2 22/35] monitor: implement "user creatable" interface for adding monitors
marcandre.lureau--- via Devel
[PATCH v2 21/35] monitor: eliminate monitor_is_hmp_non_interactive method
Daniel P . Berrangé via Devel
Re: [PATCH v2 21/35] monitor: eliminate monitor_is_hmp_non_interactive method
marcandre.lureau--- via Devel
[PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
Re: [PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
marcandre.lureau--- via Devel
Re: [PATCH v2 23/35] qemu-options: document new monitor-hmp and monitor-qmp objects
Daniel P . Berrangé via Devel
[PATCH v2 24/35] monitor: convert from oneshot BH to persistent BH
Daniel P . Berrangé via Devel
Re: [PATCH v2 24/35] monitor: convert from oneshot BH to persistent BH
marcandre.lureau--- via Devel
[PATCH v2 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock
Daniel P . Berrangé via Devel
Re: [PATCH v2 26/35] monitor: protect qemu_chr_fe_accept_input with monitor lock
marcandre.lureau--- via Devel
[PATCH v2 28/35] tests/qtest: add tests for dynamic monitor add/remove
Daniel P . Berrangé via Devel
Re: [PATCH v2 28/35] tests/qtest: add tests for dynamic monitor add/remove
marcandre.lureau--- via Devel
[PATCH v2 27/35] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
Re: [PATCH v2 27/35] monitor: implement support for deleting QMP objects
marcandre.lureau--- via Devel
Re: [PATCH v2 27/35] monitor: implement support for deleting QMP objects
Daniel P . Berrangé via Devel
[PATCH v2 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug
Daniel P . Berrangé via Devel
Re: [PATCH v2 29/35] tests/functional: add e2e test for dynamic QMP monitor hotplug
marcandre.lureau--- via Devel
[PATCH v2 25/35] monitor: reject attempts to delete the current monitor
Daniel P . Berrangé via Devel
Re: [PATCH v2 25/35] monitor: reject attempts to delete the current monitor
marcandre.lureau--- via Devel
[PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
Daniel P . Berrangé via Devel
Re: [PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
marcandre.lureau--- via Devel
Re: [PATCH v2 31/35] qom: add method for getting the "id" of a QOM object
Daniel P . Berrangé via Devel
[PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
Re: [PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
marcandre.lureau--- via Devel
Re: [PATCH v2 33/35] monitor: add support for auto-deleting monitors upon close
Daniel P . Berrangé via Devel
[PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
Re: [PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
marcandre.lureau--- via Devel
Re: [PATCH v2 30/35] tests/functional: add a stress test for monitor hot unplug
Daniel P . Berrangé via Devel
[PATCH v2 32/35] qom: add trace events for user creatable create/delete APIs
Daniel P . Berrangé via Devel
Re: [PATCH v2 32/35] qom: add trace events for user creatable create/delete APIs
marcandre.lureau--- via Devel
[PATCH v2 34/35] tests: switch from -mon to -object monitor-qmp
Daniel P . Berrangé via Devel
Re: [PATCH v2 34/35] tests: switch from -mon to -object monitor-qmp
marcandre.lureau--- via Devel
[PATCH v2 35/35] docs: mark '-mon' as deprecated in favour of -object
Daniel P . Berrangé via Devel
Re: [PATCH v2 35/35] docs: mark '-mon' as deprecated in favour of -object
marcandre.lureau--- via Devel
[PATCH v2 0/5] qemu: add async vCPU unplug coverage
Akash Kulhalli via Devel
[PATCH v2 2/5] tests: add helper for DEVICE_DELETED events
Akash Kulhalli via Devel
[PATCH v2 1/5] qemu: expose process event handler to tests
Akash Kulhalli via Devel
[PATCH v2 4/5] qemuhotplugtest: test setvcpu async unplug
Akash Kulhalli via Devel
[PATCH v2 3/5] qemuhotplugtest: support async vcpu unplug completion
Akash Kulhalli via Devel
[PATCH v2 5/5] qemuhotplugtest: test setvcpus async downscale
Akash Kulhalli via Devel
Re: [PATCH v2 0/5] qemu: add async vCPU unplug coverage
Peter Krempa via Devel
[PATCH] bhyve: support populating SMBIOS fields
Roman Bogorodskiy
Re: [PATCH] bhyve: support populating SMBIOS fields
Michal Prívozník via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Daniel P . Berrangé via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Ján Tomko via Devel
[PATCH] ci: refresh with 'lcitool manifest'
Daniel P . Berrangé via Devel
Re: [PATCH] ci: refresh with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH 0/3] implement a few guest agent based APIs
Roman Bogorodskiy
[PATCH 1/3] bhyve: implement domain{Get,Set}Time APIs
Roman Bogorodskiy
[PATCH 3/3] bhyve: implement domainAuthorizedSSHKeys{Get,Set} APIs
Roman Bogorodskiy
[PATCH 2/3] bhyve: implement domainSetUserPassword API
Roman Bogorodskiy
Re: [PATCH 0/3] implement a few guest agent based APIs
Michal Prívozník via Devel
[PATCH 0/2] bhyve: guest agent bugfixes
Roman Bogorodskiy
[PATCH 1/2] bhyve: process: properly handle misconfigured agent
Roman Bogorodskiy
[PATCH 2/2] bhyve: fix domainQemuAgentCommand
Roman Bogorodskiy
Re: [PATCH 0/2] bhyve: guest agent bugfixes
Michal Prívozník via Devel
[PATCH 1/2] bhyve: respect domain's on_poweroff action
Roman Bogorodskiy
[PATCH 2/2] bhyve: respect domain's on_reboot action
Roman Bogorodskiy
Re: [PATCH 2/2] bhyve: respect domain's on_reboot action
Michal Prívozník via Devel
Re: [PATCH 1/2] bhyve: respect domain's on_poweroff action
Michal Prívozník via Devel
[PATCH] domaincapstest: Drop support for old qemu
Michal Privoznik via Devel
Re: [PATCH] domaincapstest: Drop support for old qemu
Ján Tomko via Devel
Re: [PATCH] domaincapstest: Drop support for old qemu
Daniel P . Berrangé via Devel
[PATCH 0/3] tests: Add capability dump data for the qemu-11.1 dev cycle
Peter Krempa via Devel
[PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Peter Krempa via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Michal Prívozník via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Peter Krempa via Devel
Re: [PATCH 1/3] qemublocktest: Skip schema validation on 'gluster' backend tests
Michal Prívozník via Devel
Re: [PATCH 3/3] qemucapabilitiestest: Add data for the qemu-11.1 dev cycle (aarch64)
Michal Prívozník via Devel
Re: [PATCH 2/3] qemucapabilitiestest: Add data for the qemu-11.1 dev cycle (x86_64)
Michal Prívozník via Devel
[PATCH 0/3] hyperv: Add support for detecting nested virtualization capability
Jonathon Jongsma via Devel
[PATCH 1/3] hyperv: fix error handling of hypervGetProcessorsByName()
Jonathon Jongsma via Devel
[PATCH 2/3] hyperv: Rename hypervGetProcessorsByName() to hypervGetProcessorList()
Jonathon Jongsma via Devel
[PATCH 3/3] hyperv: report nested virtualization setting in domain XML
Jonathon Jongsma via Devel
Re: [PATCH 0/3] hyperv: Add support for detecting nested virtualization capability
Michal Prívozník via Devel
[PATCH 0/2] ci: Bump to Debian 13 and drop Cirrus
Michal Privoznik via Devel
[PATCH 2/2] ci: Drop cirrus
Michal Privoznik via Devel
Re: [PATCH 2/2] ci: Drop cirrus
Michal Prívozník via Devel
[PATCH 1/2] ci: regenerate with 'lcitool manifest'
Michal Privoznik via Devel
Re: [PATCH 1/2] ci: regenerate with 'lcitool manifest'
Pavel Hrdina via Devel
[PATCH 0/3] ci: Remove cirrus jobs
Peter Krempa via Devel
[PATCH 1/3] ci: README: Delete section about 'Cirrus CI'
Peter Krempa via Devel
[PATCH 2/3] ci: Drop 'Cirrus CI' job defnitions
Peter Krempa via Devel
[PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Michal Prívozník via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Michal Prívozník via Devel
Re: [PATCH 3/3] ci: Regenerate with 'lcitool'
Peter Krempa via Devel
Re: [PATCH 0/3] ci: Remove cirrus jobs
Peter Krempa via Devel
Re: [PATCH 0/3] ci: Remove cirrus jobs
Michal Prívozník via Devel
[PATCH 0/4] qemu: add API to ammounce guest interfaces to the network
Laine Stump via Devel
[PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Laine Stump via Devel
Re: [PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Martin Kletzander via Devel
Re: [PATCH 1/4] qemu: new monitor function qemuMonitorAnnounceSelf()
Peter Krempa via Devel
[PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Laine Stump via Devel
Re: [PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Peter Krempa via Devel
Re: [PATCH] test: unit test for qemuMonitorJSONAnnounceSelf()
Laine Stump via Devel
[PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Laine Stump via Devel
Re: [PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Martin Kletzander via Devel
Re: [PATCH 3/4] qemu: implement virDomainAnnounceInterface() API
Laine Stump via Devel
[PATCH 2/4] API: Introduce virDomainAnnounceInterface
Laine Stump via Devel
Re: [PATCH 2/4] API: Introduce virDomainAnnounceInterface
Martin Kletzander via Devel
Re: [PATCH 2/4] API: Introduce virDomainAnnounceInterface
Laine Stump via Devel
[PATCH 4/4] virsh: new command "domifannounce"
Laine Stump via Devel
Re: [PATCH 4/4] virsh: new command "domifannounce"
Martin Kletzander via Devel
[PATCHv2] lxc: truncate LOOP_GET_STATUS64.lo_file_name for long loop backing paths
Radoslaw Smigielski via Devel
Release of libvirt-12.4.0
Jiri Denemark via Devel
[PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Dion Bosschieter
[PATCH v8 1/4] nwfilter: add nwfilter nftables driver
Dion Bosschieter
[PATCH v8 2/4] nwfilter: allow use of nftables nwfilter driver via nwfilter.conf
Dion Bosschieter
[PATCH v8 4/4] nwfilter: add used firewall backend to nwfilterbinding
Dion Bosschieter
Re: [PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Daniel P . Berrangé via Devel
Re: [PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Dion
Re: [PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Daniel P . Berrangé via Devel
Re: [PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Dion
Re: [PATCH v8 0/4] nwfilter: add nwfilter nftables driver
Daniel P . Berrangé via Devel
[RFC patch 00/17] qemu: Unlock VM object while accessing storage (in certain cases)
Peter Krempa via Devel
[RFC patch 01/17] storage_source: Don't modify @src in 'virStorageSourceUpdatePhysicalSize'
Peter Krempa via Devel
[RFC patch 03/17] virStorageFileProbeFormatFromBuf: Allow NULL 'path' argument
Peter Krempa via Devel
[RFC patch 02/17] virStorageSourceGetSize: Return also 'allocation' value if needed
Peter Krempa via Devel
[RFC patch 05/17] virStorageSourceGetMetadataFromBuf: Refactor cleanup
Peter Krempa via Devel
[RFC patch 04/17] virStorageFileProbeGetMetadata: Allow NULL 'meta->path'
Peter Krempa via Devel
[RFC patch 06/17] virStorageSourceUpdateCapacity: Factor out size probing to 'virStorageSourceProbeCapacityFromBuf'
Peter Krempa via Devel
[RFC patch 07/17] qemu: domain: Introduce 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 08/17] qemuDomainGetBlockInfo: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 09/17] qemuDomainGetStatsOneBlock: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 10/17] qemuMigrationDstPrepareStorage: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 11/17] qemuDomainBlockResize: Rewrite to 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 12/17] qemu: domain: Remove 'qemuDomainStorageUpdatePhysical'
Peter Krempa via Devel
[RFC patch 13/17] qemuDomainGetStatsOneBlockFallback: Rewrite using 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 14/17] qemuDomainGetBlockInfo: Rewrite using 'qemuDomainStorageSourceProbeSize'
Peter Krempa via Devel
[RFC patch 16/17] qemu: domain: Introduce APIs for unlocking domain object during potentially long running operations
Peter Krempa via Devel
[RFC patch 15/17] qemu: domain: Fix coding style of domain object locking helpers
Peter Krempa via Devel
[RFC patch 17/17] qemuDomainStorageSourceProbeSize: Yield domain object while accessing storage
Peter Krempa via Devel
[PATCH 1/1] qemu: Inherit SCSI controller model from existing peers
Denis V. Lunev via Devel
Re: [PATCH 1/1] qemu: Inherit SCSI controller model from existing peers
Denis V. Lunev via Devel
Re: [PATCH 1/1] qemu: Inherit SCSI controller model from existing peers
Michal Prívozník via Devel
[PATCH v2 00/16] qemu: Fix CPU feature reporting on AMD CPUs
Jiri Denemark via Devel
[PATCH v2 01/16] cpu_conf: Introduce virCPUDefSortFeatures
Jiri Denemark via Devel
Re: [PATCH v2 01/16] cpu_conf: Introduce virCPUDefSortFeatures
Peter Krempa via Devel
[PATCH v2 02/16] qemu_capabilities: Split virQEMUCapsFillDomainCPUCaps
Jiri Denemark via Devel
[PATCH v2 03/16] qemu: Move domain caps flags handling to virQEMUCapsFillDomainCPUHostModel
Jiri Denemark via Devel
Re: [PATCH v2 03/16] qemu: Move domain caps flags handling to virQEMUCapsFillDomainCPUHostModel
Peter Krempa via Devel
[PATCH v2 05/16] qemu_capabilities: Use g_autoptr in virQEMUCapsInitHostCPUModel
Jiri Denemark via Devel
Re: [PATCH v2 05/16] qemu_capabilities: Use g_autoptr in virQEMUCapsInitHostCPUModel
Peter Krempa via Devel
[PATCH v2 06/16] qemu_capabilities: Split conditions in virQEMUCapsInitHostCPUModel
Jiri Denemark via Devel
Re: [PATCH v2 06/16] qemu_capabilities: Split conditions in virQEMUCapsInitHostCPUModel
Peter Krempa via Devel
[PATCH v2 07/16] qemu_capabilities: Cache expanded CPU
Jiri Denemark via Devel
Re: [PATCH v2 07/16] qemu_capabilities: Cache expanded CPU
Peter Krempa via Devel
[PATCH v2 11/16] cpu: Introduce virCPUUpdateFeatures
Jiri Denemark via Devel
Re: [PATCH v2 11/16] cpu: Introduce virCPUUpdateFeatures
Peter Krempa via Devel
[PATCH v2 09/16] util: Publish and mock virHostCPUGetMSRFromKVM
Jiri Denemark via Devel
Re: [PATCH v2 09/16] util: Publish and mock virHostCPUGetMSRFromKVM
Peter Krempa via Devel
[PATCH v2 12/16] Fix documentation of VIR_CONNECT_GET_DOMAIN_CAPABILITIES_EXPAND_CPU_FEATURES
Jiri Denemark via Devel
Re: [PATCH v2 12/16] Fix documentation of VIR_CONNECT_GET_DOMAIN_CAPABILITIES_EXPAND_CPU_FEATURES
Peter Krempa via Devel
[PATCH v2 10/16] cpu_x86: Introduce virCPUx86DataAddMSR
Jiri Denemark via Devel
Re: [PATCH v2 10/16] cpu_x86: Introduce virCPUx86DataAddMSR
Peter Krempa via Devel
Earlier messages
Later messages