On 01/29/2011 06:09 PM, Simon Buerger wrote:
Things to note:
* container should be named with respect to their use, not the implementation.
"HashSet" is a bad name, because the user shouldnt care about the implemenation.

* unordered sets are used more often than ordered. So it should be
"Set/OrderedSet", and not "UnorderedSet/Set" (also, the first one is two
characters less typing *g*)

* opEqual should work between different types of Sets (or Maps, or sequences).
Nothing wrong with comparing an ordered to an unordered one, or a list to an
array.

+++ on all those points

Denis
--
_________________
vita es estrany
spir.wikidot.com

Reply via email to