Dear Kevon,

Thank you for your support.

I have resolved the initial issue with uploading content to DSpace CRIS.
The problem was a missing line in the Tomcat service file regarding
ReadWrite permissions for the DSpace directory, which was likely
overwritten during a recent system patch by our IT team.

Batch uploads, imports, exports, and individual files like images, Excel
sheets, and Word documents are now working correctly. However, we are still
encountering a file upload error specifically when attempting to upload
single PDF files.

Thank you once again for your help.

Regards,
Mansoor Koormath


On Fri, Sep 4, 2026 at 5:29 PM Mansoor Koormath <[email protected]>
wrote:

> Dear Kevon,
> 🙂🙂🙂
>
> Thank you so much for being so supportive. Let us try these steps to
> resolve the problem.
>
> Regards
>
> Mansoor Koormath
>
>
> On Fri, Sep 4, 2026 at 12:13 PM Kevon Muhoozi <[email protected]>
> wrote:
>
>> Dear Mansoor,
>>
>> Thank you for the feedback but usually when this happens it always
>> rotates around file, directory path ownership and permissions, because when
>> i faced the same issue in 2025, it was a rate limiting in my nginx
>> configuration and system user permissions to asseststore, you may need to
>> first verify your system user groups that are associated with 1.
>> assetstore-ownership and permissions, *tail -f
>> /var/log/apache2/access.log  and also tail -f  /var/log/apache2/error.log*
>> and go to the frontend and retry to upload a file on the server side you
>> will be able to locate the actual error possibly if convenient you may
>> share that terminal log but certainly these two will be able to pinpoint
>> the issue why the upload fails because the proxy server can locate it if it
>> can not access any thing.
>> These are the first steps that can actually provide clearer details and
>> information about the error.
>> However, if you configured mod_security in your apache2 conf, you may
>> need to revise the mod security parameters that if when you placed the
>> patch you did refine you config.
>>
>> But most likely, if the patch was on both the frontend and backend, the
>> error relies more on backend directory ownership and permissions then
>> also proxy level configs.
>>
>> Thank you.
>> All the best,
>> Kevon
>>
>>
>>
>> On Thu, Sep 3, 2026 at 5:24 PM Mansoor Koormath <
>> [email protected]> wrote:
>>
>>> Dear Team,
>>>
>>> We have verified the DSpace server and related services. Based on the
>>> checks performed so far, Apache2, Tomcat10, PM2, and Solr are running
>>> normally, and the DSpace REST APIs are responding successfully.
>>>
>>> We also checked the server permissions and the Apache2 configuration,
>>> including the reverse proxy and virtual host configuration. We did not
>>> identify any permission-related issue, reverse proxy issue, or virtual
>>> host configuration issue that could explain the current behaviour.
>>>
>>>
>>> Thank you
>>>
>>>
>>> Regards
>>>
>>>
>>> Mansoor Koormath
>>>
>>> On Thu, Sep 3, 2026 at 12:03 PM Mansoor Koormath <
>>> [email protected]> wrote:
>>>
>>>> Dear Kevon,
>>>>
>>>> Thank you for your response and the suggestions. Let me check the file
>>>> permissions and the web server logs as you recommended.
>>>>
>>>> Regards,
>>>>
>>>> Mansoor Koormath
>>>>
>>>> On Thu, Sep 3, 2026 at 11:31 AM Kevon Muhoozi <[email protected]>
>>>> wrote:
>>>>
>>>>> Dear Mansoor,
>>>>> The possible issues arise from file permissions and ownership for the
>>>>> DSpace logs, as well as from the upload limitations of the web server, 
>>>>> such
>>>>> as Apache2 or Nginx configurations.
>>>>> But also try reading from the web server logs to see what is actually
>>>>> happening to your instance; tail live logs from Apache2 or Nginx that will
>>>>> pinpoint what is going on with the instance at the proxy level.
>>>>>
>>>>> All the best in debugging.
>>>>>
>>>>> Thank you,
>>>>> Kevon
>>>>>
>>>>> On Thu, Sep 3, 2026 at 8:46 AM Mansoor Koormath <
>>>>> [email protected]> wrote:
>>>>>
>>>>>> Dear Team,
>>>>>> We are unable to submit an item to DSpace CRIS 8.2 after applying the
>>>>>> system patch. It was running fine before. We are now unable to submit an
>>>>>> item to the instance. We are getting an "upload failed" message when we 
>>>>>> try
>>>>>> to upload a file.  Also, we are not able to create a new process. Hence, 
>>>>>> I
>>>>>> checked dspace.log and found that the real-time logs are not currently
>>>>>> updating there. Also, I am unable to find the logs for the failed
>>>>>> processes, so we are unable to identify the exact issue with the
>>>>>> submission. I have checked the asset store permissions and the status of
>>>>>> other applications.  I didn't find any issues with the permissions and
>>>>>> running status. Could you please help me to get resolve this issue?
>>>>>>
>>>>>> Regards
>>>>>>
>>>>>> Mansoor Koormath
>>>>>>
>>>>>> --
>>>>>> All messages to this mailing list should adhere to the Code of
>>>>>> Conduct: https://lyrasis.org/code-of-conduct/
>>>>>> ---
>>>>>> You received this message because you are subscribed to the Google
>>>>>> Groups "DSpace Community" group.
>>>>>> To unsubscribe from this group and stop receiving emails from it,
>>>>>> send an email to [email protected].
>>>>>> To view this discussion visit
>>>>>> https://groups.google.com/d/msgid/dspace-community/CAC8Un-072xxMgK5SvLUEZtjaub7KpNf6%2Biyt521iRpkyGP4yxw%40mail.gmail.com
>>>>>> <https://groups.google.com/d/msgid/dspace-community/CAC8Un-072xxMgK5SvLUEZtjaub7KpNf6%2Biyt521iRpkyGP4yxw%40mail.gmail.com?utm_medium=email&utm_source=footer>
>>>>>> .
>>>>>>
>>>>>

-- 
All messages to this mailing list should adhere to the Code of Conduct: 
https://lyrasis.org/code-of-conduct/
--- 
You received this message because you are subscribed to the Google Groups 
"DSpace Community" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To view this discussion visit 
https://groups.google.com/d/msgid/dspace-community/CAC8Un-2n_OEMz99iRSTvyHbT6HtY71MXOULiaNaqG8EBhhpQTg%40mail.gmail.com.

Reply via email to