Hi,

I think the best solution would be to change naming conventions, so that the main class of a package would be in package directory, like in Java. And as Ralf suggested class Zend could be removed.
So:
Zend/Db.php => Zend/Db/Db.php,
Zend/Db/Table.php => Zend/Db/Table/Table.php
...

This way use of one separate framework package would be much easier: it would be enough to copy directory[now we need to copy directory and one .php class file] and there would be much cleaner package separation.

Ralf Eggert wrote:
Hi,

I personally think that the proposed renaming of the Zend class to
Zend_Framework is very misleading. I would expect that a Zend_Framework
class will set up the whole framework and not be just a funny
conglomeration of methods who did not find their way to a proper component.

Here are my suggestions:

- move Zend::register(), Zend::registry(), Zend::isRegistered(),
  Zend::initRegistry() and Zend::__unsetRegistry() to Zend_Registry

- drop Zend::exception() and Zend::loadInterface()

- move Zend::loadClass(), Zend::loadFile() and Zend::isReadable() to
  a new Zend_Loader class

- as suggested by others, move Zend::dump() to Zend_Debug

- the only method I am not sure about yet is Zend::compareVersion() but
  I bet we will find a solution for this as well

Like others I would also suggest to implement these changes before the
0.9.0 beta release gets launched.

Best Regards,

Ralf




Tautvydas Andrikys aka esminis
begin:vcard
fn:Tautvydas Andrikys
n:Andrikys;Tautvydas
org:M2 Technologijos;Programming
adr;quoted-printable:;;Laisv=C4=97s pr. 77B;Vilnius;;;Lithuania
email;internet:[EMAIL PROTECTED]
title:Programmer
tel;work:00 370 5 2462284
tel;fax:00 370 5 2462285
tel;cell:00 370 671 52246
x-mozilla-html:FALSE
url:http://www.m2.lt
version:2.1
end:vcard

Reply via email to