On Sat, 25 Mar 2023, Ken Matsui via Gcc wrote:
Built-in trait naming simply adds two underscores (__) to the original
trait name. However, the same names are already in use for some
built-in traits, such as is_void, is_pointer, and is_signed.
For example, __is_void is used in the following files:
* gcc/testsuite/g++.dg/tm/pr46567.C
This is a testcase, you can rename __is_void to whatever in there, it
doesn't matter.
* libstdc++-v3/include/bits/cpp_type_traits.h
This __is_void seems to be used in a single place in
include/debug/helper_functions.h, couldn't we tweak that code so __is_void
becomes unused and can be removed?
--
Marc Glisse