On Mon, 27 Mar 2023 at 21:17, Ken Matsui via Libstdc++ <libstd...@gcc.gnu.org> wrote: > > On Mon, Mar 27, 2023 at 10:33 AM François Dumont <frs.dum...@gmail.com> wrote: > > > > > > On 26/03/2023 04:01, Ken Matsui via Libstdc++ wrote: > > > On Sat, Mar 25, 2023 at 5:38 AM Marc Glisse <marc.gli...@inria.fr> wrote: > > >> On Sat, 25 Mar 2023, Ken Matsui via Gcc wrote: > > >> > > >>> Built-in trait naming simply adds two underscores (__) to the original > > >>> trait name. However, the same names are already in use for some > > >>> built-in traits, such as is_void, is_pointer, and is_signed. > > >>> > > >>> For example, __is_void is used in the following files: > > >>> > > >>> * gcc/testsuite/g++.dg/tm/pr46567.C > > >> This is a testcase, you can rename __is_void to whatever in there, it > > >> doesn't matter. > > >> > > >>> * libstdc++-v3/include/bits/cpp_type_traits.h > > >> This __is_void seems to be used in a single place in > > >> include/debug/helper_functions.h, couldn't we tweak that code so > > >> __is_void > > >> becomes unused and can be removed? > > > That worked. Thank you! > > What worked ? > > If you meant about the code, I sent a patch series, as you can see in > the following link. > > https://gcc.gnu.org/pipermail/gcc-patches/2023-March/614620.html > > * In the following patch, I replaced __is_void with std::is_void in > helper_functions.h.
You can't do that. std::is_void is not present in C++98 mode, but the code in <debug/helper_functions.h> needs to work for C++98 mode. > https://gcc.gnu.org/pipermail/gcc-patches/2023-March/614624.html > * And then, I deleted __is_void in cpp_type_traits.h. > https://gcc.gnu.org/pipermail/gcc-patches/2023-March/614623.html > * Also, I replaced __is_void with ____is_void in the testcase. > https://gcc.gnu.org/pipermail/gcc-patches/2023-March/614625.html > > If you meant what tests had been done, I did the following tests > because the header is under libstdc++. > > * make check-gcc-c++ (because the patches involve changes on GCC) > * make check-target-libstdc++-v3 > > > > So, we can remove a code in a header as long as it is not standard and > > > is not used elsewhere, can't we? > > > > You can do anything you like as long as you run the testsuite before > > presenting your patch. Here note that you'll need to run: > > > > make check-debug > > > > to run tests in _GLIBCXX_DEBUG mode which is making use of the code in > > helper_functions.h. > > > > Clearly this usage of std::__is_void could be replaced with your builtin > > by reimplementing _Distance_traits like this: > > > > template<typename _Iterator, > > typename = typename std::__is_integer<_Iterator>::__type> > > struct _Distance_traits > > { > > private: > > typedef > > typename std::iterator_traits<_Iterator>::difference_type _ItDiffType; > > > > typedef > > typename std::conditional<__is_void<_ItDiffType>, > > std::ptrdiff_t, _ItDiffType>::type _DiffType; > > > > public: > > typedef std::pair<_DiffType, _Distance_precision> __type; > > }; > > > > this is untested, just to give you an idea of what your patch could be. > > > > François > > Thank you! I thought the tests that I did included the > hepler_function.h header, but they don’t...? If not, I must check if > std::is_void in the type_traits header was correctly used.