> I tried unproxying without sorting and the regressions passed, so it looks 
> like you were right that it's unnecessary.  I then got rid of 
> iterSortedChildren() and replaced the one remaining use with
>  for obj in sorted(root.iterChildren(), key=lambda o: o.path()):
>      obj.print_ini(ini_file)
> I can upload a new diff if you want but it seemed like overkill.
>
> As far as the naming, I guess iterChildren has kind of grown on me; the 
> @property thing does seem like going overboard, but calling it descendants() 
> might not be too bad.  How much benefit is there in having 'iter' in there so 
> you know it's an iterator?  I'd be interested in having people other than 
> Nate weigh in on this, since while I consider his opinions valuable, his 
> perspective is not necessarily typical ;-).

What so atypical about trying to find a very short, descriptive name?

  Nate
_______________________________________________
m5-dev mailing list
[email protected]
http://m5sim.org/mailman/listinfo/m5-dev

Reply via email to