Hey Scott, before continuing this review, I'd appreciate a patch I can
apply so I can look at this in Eclipse.


http://gwt-code-reviews.appspot.com/1113801/diff/1/4
File dev/core/src/com/google/gwt/core/ext/typeinfo/JAnnotationType.java
(right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/4#newcode2
dev/core/src/com/google/gwt/core/ext/typeinfo/JAnnotationType.java:2: *
Copyright 2007 Google Inc.
(why didn't you change the date on this file?)

http://gwt-code-reviews.appspot.com/1113801/diff/1/4#newcode23
dev/core/src/com/google/gwt/core/ext/typeinfo/JAnnotationType.java:23:
throws NotFoundException;
Looks like this method is already defined in JClassType?

http://gwt-code-reviews.appspot.com/1113801/diff/1/10
File dev/core/src/com/google/gwt/core/ext/typeinfo/JField.java (right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/10#newcode30
dev/core/src/com/google/gwt/core/ext/typeinfo/JField.java:30: boolean
isDefaultAccess();
isDefaultAccess(), isPrivate(), isProtected(), isPublic(), isStatic()
are defined in more than one class.  Deserves to be consolidated under
new HasAccess/HasProtection interface?

http://gwt-code-reviews.appspot.com/1113801/diff/1/28
File
dev/core/src/com/google/gwt/dev/javac/typemodel/JAbstractMethod.java
(right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/28#newcode30
dev/core/src/com/google/gwt/dev/javac/typemodel/JAbstractMethod.java:30:
com.google.gwt.core.ext.typeinfo.JAbstractMethod {
This is a bit awkward to me.  Isn't the usual pattern to name the
implementation class XXXImpl so that you don't have to deal with two
classes with the same name at the same time?

http://gwt-code-reviews.appspot.com/1113801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to