still slogging through, a few more comments

http://gwt-code-reviews.appspot.com/1113801/diff/1/12
File dev/core/src/com/google/gwt/core/ext/typeinfo/JMethod.java (right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/12#newcode36
dev/core/src/com/google/gwt/core/ext/typeinfo/JMethod.java:36: String
toString();
are you sure you want to declare toString() in an interface like this?

http://gwt-code-reviews.appspot.com/1113801/diff/1/13
File dev/core/src/com/google/gwt/core/ext/typeinfo/JPackage.java
(right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/13#newcode25
dev/core/src/com/google/gwt/core/ext/typeinfo/JPackage.java:25:
JClassType findType(String[] typeName);
From looking at the method signature, I'm not sure what this array is
for.  Is it a notation for looking for inner classes?  Do you pass
multiple type names in for some other reason?  s/typeName/typeNames/ ?

http://gwt-code-reviews.appspot.com/1113801/diff/1/15
File
dev/core/src/com/google/gwt/core/ext/typeinfo/JParameterizedType.java
(right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/15#newcode22
dev/core/src/com/google/gwt/core/ext/typeinfo/JParameterizedType.java:22:
public interface JParameterizedType extends JClassType {
While investigating the origin of getBaseType() I got lost for a few
minutes.  I don't think this is a problem, but it looks like the removal
of the file "JMaybeParameterizedType" didn't make it into the patch.

http://gwt-code-reviews.appspot.com/1113801/diff/1/16
File dev/core/src/com/google/gwt/core/ext/typeinfo/JPrimitiveType.java
(right):

http://gwt-code-reviews.appspot.com/1113801/diff/1/16#newcode34
dev/core/src/com/google/gwt/core/ext/typeinfo/JPrimitiveType.java:34:
public enum JPrimitiveType implements JType {
finl?  Based on your other changes, I would have expected this to be an
interface, not an implementation based on where it is, but I guess there
will be no need of an alternative implementation.

http://gwt-code-reviews.appspot.com/1113801/diff/1/16#newcode40
dev/core/src/com/google/gwt/core/ext/typeinfo/JPrimitiveType.java:40:
"void", "Void", DESC_VOID, "null");
This is incredibly hard to read.  To counteract broken eclipse
formatting, I usually put an empty comment between enum constant decl's

http://gwt-code-reviews.appspot.com/1113801/show

--
http://groups.google.com/group/Google-Web-Toolkit-Contributors

Reply via email to