Tim Ellison wrote:
Geir Magnusson Jr. wrote:
+1
BTW, why call it "RepositionLock"?
That was just an example taken from the class I was looking at, I've
called them different names depending upon the inst var name.
Oh, thanks.
It might not be a bad idea to adopt a common pattern like "FOOSyncLock"
- might make it easier to search for hotspots in a profiler...
geir
Tim
Tim Ellison wrote:
BTW, as I go through the code looking at the occurrences of 'new
Object()' and determining if they are used simply for their locks, I
figured we also need a way to record the check has been done.
So, if there is a 'new Object()' that is not simply a lock object (and
therefore named as we agreed) I'll mark it on the same line as
// $NON-LOCK-1$ so we can easily grep for divergences from the pattern.
Regards,
Tim
Mikhail Fursov wrote:
Another variant is to use anonymous class without the name:
Object lock = new Object(){};
But the name by itself (RepositionLock) serves like a comment.
On 10/3/06, Tim Ellison <[EMAIL PROTECTED]> wrote:
private class RepositionLock {}
private Object repositionLock = new RepositionLock();
---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]
---------------------------------------------------------------------
Terms of use : http://incubator.apache.org/harmony/mailing.html
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]