On Fri, Feb 20, 2015 at 8:01 AM, Yasuo Ohgaki <yohg...@ohgaki.net> wrote:
> Hi all,
>
> On Fri, Feb 20, 2015 at 12:14 AM, Trevor Suarez <ric...@gmail.com> wrote:
>
>> I think that naming the new parent exception something like "Throwable" or
>> "Catchable" (as Nikita previously suggested) would be a bit more concise in
>> meaning than "BaseException". You may not have even meant that name as a
>> formal proposal, but I figured I'd weigh in regardless. :P
>>
>
> I think they probably should use namespace...
>
> Regards,
>
> --
> Yasuo Ohgaki
> yohg...@ohgaki.net

Hello,

yes, finally introducing namespaces into PHP core stuff would
definitely be beneficial. Polluting the global namespace more and more
should be avoided.

I would gladly see something like this:
Php\Throwable
- Php\Exception
- Php\ParseException
- Php\EngineException

Of course, the \Exception would need to be kept (maybe as an alias to
\Php\Exception?), for backwards compability.

Regards
Pavel Kouril

-- 
PHP Internals - PHP Runtime Development Mailing List
To unsubscribe, visit: http://www.php.net/unsub.php

Reply via email to