In get_files(), there is 

os.path.splitext(str(z))[1].lower() in self.extensions

I'm just wondering why it isn't g.os_path_splitext() instead.  Are these 
*g.os_path_** commands being phased out? (Actually, I never understood why 
we have them at all but given that we do, why not use it here?)
On Friday, October 22, 2021 at 9:47:22 PM UTC-4 tbp1...@gmail.com wrote:

> This is very nice, and one of the nice things about it is how it 
> automatically ignores non-image files without the user having to do 
> anything.
>
> A suggestion for better usability - after you zoom or shrink a slide, the 
> new zoom factor should stay in effect for all other slides until you change 
> it again.  Currently the new zoom factor is forgotten for the next slide - 
> or even if you go back to one you already resized - and that's really 
> annoying.
>
> On Friday, October 22, 2021 at 9:34:19 PM UTC-4 tbp1...@gmail.com wrote:
>
>> Here's my stab at it.  Replace all the current text in the docstring 
>> ahead of the binding and API information with the following:
>>
>> Display image files in a directory tree as a slide show.
>>
>> This plugin will display all files in a directory tree that have
>> image extensions.  By default the recognized extensions are
>> '.jpeg', '.jpg', and '.png'.  Other types of image files can be
>> displayed as long as the they are types known by the Qt PixMap 
>> class, including '.gif' and '.bmp'. See, for example:
>>
>> https://doc.qt.io/qt-5/qpixmap.html#reading-and-writing-image-files
>>
>> This plugin should be called from a script (or @command or @button node) 
>> as follows:
>>
>>     from leo.plugins.picture_viewer import Slides
>>     Slides().run()  # See below for defaults.
>>
>> *Note*: do not enable this plugin. It will be loaded by the calling 
>> script.
>>
>> On Friday, October 22, 2021 at 3:12:23 PM UTC-4 Edward K. Ream wrote:
>>
>>> On Fri, Oct 22, 2021 at 10:59 AM tbp1...@gmail.com <tbp1...@gmail.com> 
>>> wrote:
>>>
>>> And I see from the PixMap docs that it can actually support some other 
>>>> formats.
>>>>
>>>> You may think it's the same thing, but I suggest spelling out just what 
>>>> the viewer can do would be helpful.
>>>>
>>>
>>> Ah, the curse of knowledge.
>>>
>>> Please suggest some new words for the docstring.  Thanks.
>>>
>>> Edward
>>>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"leo-editor" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to leo-editor+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/leo-editor/02189de4-d4b8-4de9-a444-f27a5f95226an%40googlegroups.com.

Reply via email to