> Use meaningful variable and handler names. It's THE first rule of reusable
programming.

You are right and that is what I normally do. But in this case I need the
name of the handler to be short, because the purpose of the handler is to
get me the content of a text cast member. The whole program is for bulding a
web site. The various segments of the HTML code are stored in text cast
members. And I need the short handler as abbreviation when concatenating the
different html chunks. So in this case, the short handler name makes the
code even easier to read!

Instead of coding

htmlText = member(3, "websiteBuilder").text & member(2,
"websiteBuilder").text & member(7, "websiteBuilder").text

I can write htmlText = t(3) & t(2) & t(7)


with the function

on t chunkNumber
  return member(t, "websiteBuilder").text
end


Or is there a smarter way to do this?

Thanks
Michael

[To remove yourself from this list, or to change to digest mode, go to 
http://www.penworks.com/lingo-l.cgi  To post messages to the list, email [EMAIL 
PROTECTED]  (Problems, email [EMAIL PROTECTED]). Lingo-L is for learning and helping 
with programming Lingo.  Thanks!]

Reply via email to