I didn't mean for you to withdraw.

I would encourage you to still make it Apache::Carp. But then to avoid 
confusion model it more after CGI::Carp while adding the features you 
wanted for Apache::PageKit.

As a person who has hacked and debugged the internals of CGI::Carp and 
looking at your code, I think it is entirely doable for this to happen. As 
a user of CGI::Carp, I'd certainly like to see an Apache::Carp facility.

As for not requiring the programmer to use croak and carp. To some degree I 
agree that it may be nice to override die with a stack traced die. But I 
know that when I program modules and applications I take special care to 
use croak, die, and confess in the different situations they were intended for.

Anyway, you could offer both the stack traced die and the 
croak/confess/carp compatibility in the same fell swoop but just offer it 
as a config option.

The other thing that worries me is that even if you sneak the code back 
into the PageKit hierarchy you are still not doing everything Lincoln is 
doing to help deal with eval issues. This is a particularly thorny problem 
(and I suspect part of the reason why Matt wants CGI::Carp to die ... no 
pun intended).

You may not have experienced this problem because your PageKit hasn't run 
on top of so many different people's scripts and programming styles. 
CGI::Carp runs on a LOT of platforms and programming styles, so it's 
evolved to take care of them which you could/should be taking advantage of 
IMHO while still providing a benefit to the Apache community.

Later,
    Gunther

At 11:37 PM 11/30/2000 -0500, Thomas J. Mather wrote:
>OK, I think Apache::Carp was a misleading name - it is not really a
>replacement for CGI::Carp - instead it is a simple module for reporting
>errors under a mod_perl enviroment that is easy to use and doesn't require
>that the programmer use carp and croak.  A better name would have been
>something like Apache::ErrorReport
>
>So, I think I will keep this bundled with the Apache-PageKit distribution
>as Apache::PageKit::Error, (although it will still work by itself), unless
>there is demand for a seperate Apache-ErrorReport distribution.
>
>
>---------------------------------------------------------------------
>To unsubscribe, e-mail: [EMAIL PROTECTED]
>For additional commands, e-mail: [EMAIL PROTECTED]

__________________________________________________
Gunther Birznieks ([EMAIL PROTECTED])
eXtropia - The Web Technology Company
http://www.extropia.com/


---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

Reply via email to