* Michael G Schwern <[EMAIL PROTECTED]> [2007-12-05 04:30]:
> Why do they care if the plan is output at the beginning or end?
> How does this stricture improve the quality of the test?

It improves the resulting TAP stream, if not the test itself.

But maybe it’s not necessary to impose this stricture by default,
and instead of asking to be allowed to supply a plan later, as I
proposed, people should instead have to ask for the stricture:

    # works:
    use Test::More;
    pass();
    plan tests => 2;
    pass();

    # throws error:
    use Test::More 'ensure_plan_first';
    pass();
    plan tests => 2;
    pass();

> Honestly all that's really holding that up is a good name for
> the plan style and "I'm done testing" terminator.  Nothing has
> really lept out at me yet. Maybe something as straight forward
> as...
> 
>       plan 'until_done';
> 
>       ....
> 
>       done_testing;

    plan 'until_completion';
    # ...
    plan 'completed';

Regards,
-- 
Aristotle Pagaltzis // <http://plasmasturm.org/>

Reply via email to