On Wed, Feb 4, 2009 at 4:35 PM, Ovid <publiustemp-perl...@yahoo.com> wrote:
> ----- Original Message ----
>
>> From: Michael G Schwern <schw...@pobox.com>
>
> First of all, thank you!  This is fantastic work and I'm sure it will make a 
> lot of people happy.

++


> Thoughts on first order support:
>
> use Test::More;
>
> plan(3);
> pass;
> pass;
> pass;
> plan(2)
> pass;
> pass;
> done_testing() # optional
>
> Then, you can incrementally build a plan for those who want it and it seems 
> backwards almost compatible (since done_testing() wouldn't be required).
>
> The problem is that internally, TB will see that plan() has been called and 
> will die if a plan has been called twice.

why not call it something else then?
plan_more(2)   or  add_plan(2)

You might want to report error if both plan(2) and add_plan(2) was
called in the same file.


BTW what about

use Test::More;
pass;
pass;
# done_testing() # not being called at all.

Is this a failure now as there was no plan, not even a no_plan ?

Gabor

Reply via email to