On Wed, 15 Jun 2022 at 16:51, Aleksander Alekseev <[email protected]> wrote: > > Hi hackers, > > I noticed that cfbot is not entirely happy with the patch, so I rebased it. > > > I see that COMPRESSION and STORAGE now are handled slightly > > differently in the grammar. Maybe we could standardize that a bit > > more; so that we have only one `STORAGE [kind]` definition in the > > grammar? > > > > As I'm new to the grammar files; would you know the difference between > > `name` and `ColId`, and why you would change from one to the other in > > ALTER COLUMN STORAGE? > > Good point, Matthias. I addressed this in 0002. Does it look better now?
When updating a patchset generally we try to keep the patches self-contained, and update patches as opposed to adding incremental patches to the set. Apart from this comment on the format of the patch, the result seems solid. - Matthias
