Moshe Zadka <[EMAIL PROTECTED]> writes:

> As long as you're breaking things anyway, let me suggest one change:
> have the "Gtk" prefix stripped from the classes' names (GtkText -> Text,
> etc) [...]

For one, I would be happy to make that change, as well (partly because
I've not that much written so far :-).

However, should we write `Gtk.FILL' instead of `FILL'?  Just from an
aesthetical viewpoint, since we already use `GDK.' to prefix GDK constants,
maybe we should import GTK and write `GTK.FILL', or just `from GTK import *'
if we like to stay terse with GTK constants.  The need of another import
might be unwelcome, but on the other hand, `import gtk, GTK, GDK' is easy
to write on one line.

I'm not sure of anything, beside the fact I would like to turn `GtkText' into
`Gtk.Text'.  We might even guess that `pygtk' intensive applications/users
would like `from gtk import *' still, and just use unprefixed `Text'.
What is not nice is having the module name repeated in module objects.

-- 
François Pinard   http://www.iro.umontreal.ca/~pinard
-
To unsubscribe: echo "unsubscribe" | mail [EMAIL PROTECTED]

Reply via email to