I used the same convention as you, and my vote was thus as the record will
show (note the negatives):

zip(strict=True) +1
itertools.zip_strict() +0
zip(mode='strict') -1
zip.strict() -1

And I stand by that: I think Python would be better off without the 3rd and
4th option, even if no alternative was implemented. To go to one of the
examples (not exactly, you'll understand why...) was given in the other
thread: if we suggested

asdfasfa.kjllasdfa.asdf()

as the name(space) for the zip(strict=True) functionality, I would:

- vote -1 (or hyperbole -10^googol)
- still use the feature when I wanted to use 'zip(strict=True)'
- think Python would be a worse programming environment for allowing this
to be introduced

Obviously the 3rd and 4th option are not as insane/illogical as the above
example (apologies, I would attribute, but the nature of this example makes
it hard for me to search for it!) but I do not like functionality exposed
in this way and I think the lack of this functionality in the stdlib does
not weigh up against the precedent/bad example this would set.

You, and anyone else, can and some definitely will disagree with me but
it's my vote, and I don't think it matters that much anyway:

There has been a lot of discussion, and these straw polls, from my limited
understanding, are often taken to see whether there is a clear consensus to
short-circuit/end the discussion, I would say in this case it has shown
inconclusiveness, which is fine, the final decision on this PEP will
(fortunately) not be decided by our votes.

I understand your 'pain' Stephen: I still think it is weird that people on
these lists don't want "for x in some_iterable if x is not None:" as valid
syntax, but I have, almost, made my peace with it.

On Sun, 17 May 2020 at 18:42, Stephen J. Turnbull <
turnbull.stephen...@u.tsukuba.ac.jp> wrote:

> These negative votes surprise me.
>
> Given that it's clear that a generic strict-mode zip is non-trivial to
> write, and that there is significant demand for it, are people saying
> "+0 Python would not be a better programming environment if
> itertools.zip_strict() were adopted," and "-1 Python would be a worse
> programming environment if zip.strict() were adopted"?
>
> I can see why folks would say the latter about zip.strict(), but even
> though I really dislike the mode switches, I'm still positive about
> adding them if one of them ranks highest among those who care.  I'm
> not going to give them negative votes, they don't make Python worse.
>
> I don't mind hyperbole ("I'm +1000 on this feature!" or "-10 on the
> worst proposal I've seen since <potentially controversial example
> removed>!")  But I would like it if "0" meant "indifferent", "+1"
> meant "no-brainer, add it", and "-1" meant "no-brainer, just don't".
>
>
> FWIW,
>
> +1   itertools.zip_strict(*iterables)
> +0.5 zip(*iterables, mode)                # mode is 3-way, default
> "shortest"
> +0.4 zip(*iterables, strict)              # strict is boolean, default
> False
> +0   zip.strict(*iterables)
> _______________________________________________
> Python-Dev mailing list -- python-dev@python.org
> To unsubscribe send an email to python-dev-le...@python.org
> https://mail.python.org/mailman3/lists/python-dev.python.org/
> Message archived at
> https://mail.python.org/archives/list/python-dev@python.org/message/DLHIE5DOI5G3IH7OEK7RDW2K37DEQ7VB/
> Code of Conduct: http://python.org/psf/codeofconduct/
>
_______________________________________________
Python-Dev mailing list -- python-dev@python.org
To unsubscribe send an email to python-dev-le...@python.org
https://mail.python.org/mailman3/lists/python-dev.python.org/
Message archived at 
https://mail.python.org/archives/list/python-dev@python.org/message/IXCPI6VHT3DLQKESDJ5KAV372J4PE7ZW/
Code of Conduct: http://python.org/psf/codeofconduct/

Reply via email to