On Sat, Jan 01, 2011 at 11:46:16PM +0000, Peter Maydell wrote:
> On 17 December 2010 15:56, Peter Maydell <peter.mayd...@linaro.org> wrote:
> > The softfloat functions float*_is_nan() were badly misnamed,
> > because they return true only for quiet NaNs, not for all NaNs.
> > Rename them to float*_is_quiet_nan() to more accurately reflect
> > what they do.
> >
> > This change was produced by:
> >  perl -p -i -e 's/_is_nan/_is_quiet_nan/g' $(git grep -l is_nan)
> > (with the results manually checked.)
> >
> > Signed-off-by: Peter Maydell <peter.mayd...@linaro.org>
> > Reviewed-by: Nathan Froyd <froy...@codesourcery.com>
> > Acked-by: Edgar E. Iglesias <edgar.igles...@gmail.com>
> 
> Ping? This patch got no further comments (although it provoked
> a long thread on a completely unrelated topic), it's been
> reviewed and it still applies to master currently. I think it's
> an uncontroversially good idea (~80% of current uses of the
> functions are actually buggy because the people who wrote
> them were misled by the function name!).
> 
> Can it be applied please? (cc'd Aurelien since you seem to be
> committing various missed patches at the moment :-))
> 

Sorry, I understood there was a conflict with another patch series, and
it was better to wait. Committed now.

As a side note, there are now a few places where the following code is
present:

  float32_is_quiet_nan(x) || float32_is_signaling_nan(x)

It might be a good idea to add back a function float32_is_nan() that
this time checks for both quiet and signaling NaN.

-- 
Aurelien Jarno                          GPG: 1024D/F1BCDB73
aurel...@aurel32.net                 http://www.aurel32.net

Reply via email to