-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43879/#review121255
-----------------------------------------------------------




docs/monitoring.md (lines 859 - 862)
<https://reviews.apache.org/r/43879/#comment182935>

    We already have one, `event_queue_dispatches`, do you want to list it here 
as well?



docs/monitoring.md (lines 861 - 862)
<https://reviews.apache.org/r/43879/#comment183077>

    This is true only for the default hierarchical allocator, right?



docs/monitoring.md (lines 872 - 874)
<https://reviews.apache.org/r/43879/#comment183099>

    Why not putting these onto the same line?



src/master/allocator/mesos/hierarchical.hpp (lines 276 - 277)
<https://reviews.apache.org/r/43879/#comment183100>

    Let's maintain the same order everywhere: field declarations in the class, 
c-tor initializer list, c-tor body, d-tor body.



src/tests/hierarchical_allocator_tests.cpp (line 30)
<https://reviews.apache.org/r/43879/#comment183102>

    Why do you pull in this one?



src/tests/hierarchical_allocator_tests.cpp (line 60)
<https://reviews.apache.org/r/43879/#comment183101>

    Do you use it?



src/tests/hierarchical_allocator_tests.cpp (line 2390)
<https://reviews.apache.org/r/43879/#comment183103>

    Why do we need a settle here?



src/tests/hierarchical_allocator_tests.cpp (line 2391)
<https://reviews.apache.org/r/43879/#comment183079>

    This looks like a creation of an instance of some `Metrics` class. Let's 
rename it to somehting like `GetMetricsSnapshot()` in a separate clean-up patch.
    
    Also, I would move this down right before `EXPECT_EQ` for clarity.



src/tests/hierarchical_allocator_tests.cpp (line 2393)
<https://reviews.apache.org/r/43879/#comment183107>

    I don't see `using std::size_t` above : )



src/tests/hierarchical_allocator_tests.cpp (line 2396)
<https://reviews.apache.org/r/43879/#comment183080>

    s/0/0u
    
    Please, make sure types in gtest macros are the same!



src/tests/hierarchical_allocator_tests.cpp (line 2398)
<https://reviews.apache.org/r/43879/#comment183086>

    If there is a single agent in the test, we do not enumerate for clarity.



src/tests/hierarchical_allocator_tests.cpp (line 2400)
<https://reviews.apache.org/r/43879/#comment183104>

    If you write a proper comment for the test you may avoid putting trailing 
comments here : ).



src/tests/hierarchical_allocator_tests.cpp (lines 2415 - 2418)
<https://reviews.apache.org/r/43879/#comment183087>

    I would format it differently: blank line between `settle` and sending the 
request, no blank line between sending the request and checking it.


- Alexander Rukletsov


On Feb. 28, 2016, 9:28 p.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43879/
> -----------------------------------------------------------
> 
> (Updated Feb. 28, 2016, 9:28 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov and Ben Mahler.
> 
> 
> Bugs: MESOS-4718
>     https://issues.apache.org/jira/browse/MESOS-4718
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added allocator metrics for number of allocations made.
> 
> 
> Diffs
> -----
> 
>   docs/monitoring.md 827f7073204fcf8575ca980a5571c8be4f5e4110 
>   src/master/allocator/mesos/hierarchical.hpp 
> 3043888630b066505410d3b32c5b3f813cc458c1 
>   src/master/allocator/mesos/hierarchical.cpp 
> 24fa50f62dec10ed43089297473cc386d6ba2f78 
>   src/tests/hierarchical_allocator_tests.cpp 
> 5f771f02db9bd098f3cd36730cd84bf2f5e87a33 
> 
> Diff: https://reviews.apache.org/r/43879/diff/
> 
> 
> Testing
> -------
> 
> make check (OS X)
> 
> I confirmed that this does not lead to general performance regressions in the 
> allocator; this is partially expected since the added code only inserts 
> metrics in the allocator while the actual work is perform asynchronously. 
> These tests where performed with 
> `HierarchicalAllocator_BENCHMARK_Test.DeclineOffers` on an optimized build 
> under OS X using clang(trunk) as compiler.
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>

Reply via email to