> On March 1, 2016, 12:48 p.m., Alexander Rukletsov wrote: > > src/tests/hierarchical_allocator_tests.cpp, line 2391 > > <https://reviews.apache.org/r/43879/diff/9/?file=1273632#file1273632line2391> > > > > This looks like a creation of an instance of some `Metrics` class. > > Let's rename it to somehting like `GetMetricsSnapshot()` in a separate > > clean-up patch. > > > > Also, I would move this down right before `EXPECT_EQ` for clarity.
MESOS-4826. > On March 1, 2016, 12:48 p.m., Alexander Rukletsov wrote: > > docs/monitoring.md, lines 872-874 > > <https://reviews.apache.org/r/43879/diff/9/?file=1273629#file1273629line872> > > > > Why not putting these onto the same line? Let's keep consistent formatting with other tables here. - Benjamin ----------------------------------------------------------- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/43879/#review121255 ----------------------------------------------------------- On March 2, 2016, 11:35 a.m., Benjamin Bannier wrote: > > ----------------------------------------------------------- > This is an automatically generated e-mail. To reply, visit: > https://reviews.apache.org/r/43879/ > ----------------------------------------------------------- > > (Updated March 2, 2016, 11:35 a.m.) > > > Review request for mesos, Alexander Rukletsov and Ben Mahler. > > > Bugs: MESOS-4718 > https://issues.apache.org/jira/browse/MESOS-4718 > > > Repository: mesos > > > Description > ------- > > Added allocator metrics for number of allocations made. > > > Diffs > ----- > > docs/monitoring.md 827f7073204fcf8575ca980a5571c8be4f5e4110 > src/master/allocator/mesos/hierarchical.hpp > 3043888630b066505410d3b32c5b3f813cc458c1 > src/master/allocator/mesos/hierarchical.cpp > 24fa50f62dec10ed43089297473cc386d6ba2f78 > src/master/allocator/mesos/metrics.hpp PRE-CREATION > src/tests/hierarchical_allocator_tests.cpp > 5f771f02db9bd098f3cd36730cd84bf2f5e87a33 > > Diff: https://reviews.apache.org/r/43879/diff/ > > > Testing > ------- > > make check (OS X) > > I confirmed that this does not lead to general performance regressions in the > allocator; this is partially expected since the added code only inserts > metrics in the allocator while the actual work is perform asynchronously. > These tests where performed with > `HierarchicalAllocator_BENCHMARK_Test.DeclineOffers` on an optimized build > under OS X using clang(trunk) as compiler. > > > Thanks, > > Benjamin Bannier > >