-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/43879/#review120570
-----------------------------------------------------------




src/tests/hierarchical_allocator_tests.cpp (lines 2395 - 2398)
<https://reviews.apache.org/r/43879/#comment182035>

    Why isn't it an `AWAIT_READY` macro? you still use an `AWAIT_*` afterwards, 
so I doubt is the result value.



src/tests/hierarchical_allocator_tests.cpp (line 2425)
<https://reviews.apache.org/r/43879/#comment182036>

    from the C++ styleguide:
    
    > Prefer trailing underscores for use as member fields (but not required). 
Some trailing underscores are used to distinguish between similar variables in 
the same scope (think prime symbols), but this should be avoided as much as 
possible, including removing existing instances in the code base.
    
    I'd rather have the test's fixture `flags` being changed to `flags_`, but 
I'm oke with renaming this to `localFlags` or something along those lines.



src/tests/hierarchical_allocator_tests.cpp (line 2435)
<https://reviews.apache.org/r/43879/#comment182037>

    Not an issue here, but equality comparison with doubles are a scary thing.


- Alexander Rojas


On Feb. 24, 2016, 8:25 p.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/43879/
> -----------------------------------------------------------
> 
> (Updated Feb. 24, 2016, 8:25 p.m.)
> 
> 
> Review request for mesos, Alexander Rukletsov and Ben Mahler.
> 
> 
> Bugs: MESOS-4718
>     https://issues.apache.org/jira/browse/MESOS-4718
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added allocator metrics for number of allocations made.
> 
> 
> Diffs
> -----
> 
>   src/master/allocator/mesos/hierarchical.hpp 
> 3043888630b066505410d3b32c5b3f813cc458c1 
>   src/master/allocator/mesos/hierarchical.cpp 
> 5ef29f26ec8071f79c2f4f78dbe2bb0a613cc92d 
>   src/tests/hierarchical_allocator_tests.cpp 
> 5f771f02db9bd098f3cd36730cd84bf2f5e87a33 
> 
> Diff: https://reviews.apache.org/r/43879/diff/
> 
> 
> Testing
> -------
> 
> make check (OS X)
> 
> I confirmed that this does not lead to general performance regressions in the 
> allocator; this is partially expected since the added code only inserts 
> metrics in the allocator while the actual work is perform asynchronously. 
> These tests where performed with 
> `HierarchicalAllocator_BENCHMARK_Test.DeclineOffers` on an optimized build 
> under OS X using clang(trunk) as compiler.
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>

Reply via email to