Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Zeev Suraski <[EMAIL PROTECTED]>: > There's no mention of _() in that page, by the way. Only gettext(). "You may use an underscore character as an alias to this function." It could be clearer, certainly. But it's there. -chuck -- Charles Hagenbuch, <[EMAIL PROTECTED]> Some fallen ang

Re: [PHP-DEV] Woah

2001-09-07 Thread Rasmus Lerdorf
> Using obscure single character operators is simply something that we don't > do in PHP, it's totally inconsistent with the language. Except when it is a known and standard concept. + % * etc. Obviously not as well-known, but it is not a PHP-only magical character. It is the same in C, C++, P

RE: [PHP-DEV] Woah

2001-09-07 Thread Cristopher Daniluk
Same in Perl? I have not used Gettext in Perl, but I'd truly hope not considering the overwhelming usage of $_. Can you imagine &_ and $_? That's not what I'd call increased readability. Regards, Cristopher Daniluk President & CEO email: [EMAIL PROTECTED] direct: 330/530-2373 Digital Services

Re: [PHP-DEV] Woah

2001-09-07 Thread Joey Smith
So let's be the first ones to get our heads on straight and get rid of this ridiculous concept. It is, IMHO, one of the worst ideas in the history of the world...I'd really rather be reading perl regular expressions than this. On Fri, 7 Sep 2001, Rasmus Lerdorf wrote the following to Zeev Suraski

Re: [PHP-DEV] Woah

2001-09-07 Thread Zeev Suraski
At 05:40 08-09-01, Chuck Hagenbuch wrote: >It's the kind of thing that gets used a lot in HTML, where otherwise there >wouldn't be a function call at _all_ - just static text. Replacing gettext() >with _() in this case actually does improve readability, in my opinion. That's exactly what I said -

Re: [PHP-DEV] Woah

2001-09-07 Thread Zeev Suraski
At 05:38 08-09-01, Rasmus Lerdorf wrote: > > Using obscure single character operators is simply something that we don't > > do in PHP, it's totally inconsistent with the language. > >Except when it is a known and standard concept. I don't remember ever coming up with an improved version of the 'D

RE: [PHP-DEV] Woah

2001-09-07 Thread Cristopher Daniluk
I think the more important issue to me is that symbols are generally operators. * + / , - . The list is endless. Couldn't we have just told users to make their own function _($blah) { return gettext($blah) }? At least it doesn't give a user the impression of a operation as opposed to a function.

Re: [PHP-DEV] Woah

2001-09-07 Thread Rodent of Unusual Size
* On 2001-09-07 at 23:06, Joey Smith <[EMAIL PROTECTED]> excited the electrons to say: > > So let's be the first ones to get our heads on straight and get rid of > this ridiculous concept. It is, IMHO, one of the worst ideas in the > history of the world...I'd really rather be reading perl regu

[PHP-DEV] CVS Account Request

2001-09-07 Thread CVS Account Request
Full name: Bruno Mignoni Email: [EMAIL PROTECTED] ID:mignoni Purpose: Manual Translation -- PHP Development Mailing List To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED] To contact the list administrators, e-mail: [E

Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Joey Smith <[EMAIL PROTECTED]>: > So let's be the first ones to get our heads on straight and get rid of > this ridiculous concept. It is, IMHO, one of the worst ideas in the > history of the world...I'd really rather be reading perl regular > expressions than this. I know that backwards

Re: [PHP-DEV] Woah

2001-09-07 Thread Joey Smith
Yes, it bothers me. If it stays, I suppose I'll accept it, but it is such a horrendously bad idea that could easily be done in user-space insteadthis is *NOT* the kind of thing that should be encouraged on a language level. On Fri, 7 Sep 2001, Rodent of Unusual Size wrote the following to PH

Re: [PHP-DEV] Woah

2001-09-07 Thread Joey Smith
No, I haven't, but let me get this straight: You're saying that if something is a bad idea, that the more often it is used, the "less bad" [1] it becomes? [1] Yes, I know this is improper...but think about it in context. I'm trying to illustrate the point. On Fri, 7 Sep 2001, Chuck Hagenbuch wr

Re: [PHP-DEV] Woah

2001-09-07 Thread Rodent of Unusual Size
* On 2001-09-07 at 23:40, Joey Smith <[EMAIL PROTECTED]> excited the electrons to say: > > On Fri, 7 Sep 2001, Rodent of Unusual Size wrote the following to PHP...: > > > Um, it has been around since sometime in version 3. Have you > > noticed it before? Has it bothered you? > > Yes, it bot

RE: [PHP-DEV] Woah

2001-09-07 Thread Cristopher Daniluk
Again, as mentioned before, this is suitable: function _($string) { return gettext($string); } once in your code. Voila, now you can still have your short cut, and we can still have our consistent naming structure. Sure, it would be an adjustment at first, but I personally believe it is worth it

Re: [PHP-DEV] Woah

2001-09-07 Thread Zeev Suraski
At 06:30 08-09-01, Chuck Hagenbuch wrote: >Quoting Joey Smith <[EMAIL PROTECTED]>: > > > So let's be the first ones to get our heads on straight and get rid of > > this ridiculous concept. It is, IMHO, one of the worst ideas in the > > history of the world...I'd really rather be reading perl regul

Re: [PHP-DEV] Woah

2001-09-07 Thread Rodent of Unusual Size
* On 2001-09-07 at 23:42, Joey Smith <[EMAIL PROTECTED]> excited the electrons to say: > > No, I haven't, but let me get this straight: > > You're saying that if something is a bad idea, that the more often it is > used, the "less bad" [1] it becomes? Speaking only for myself and not Chuck, I

Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Joey Smith <[EMAIL PROTECTED]>: > No, I haven't, but let me get this straight: > > You're saying that if something is a bad idea, that the more often it is > used, the "less bad" [1] it becomes? Uh, no. I was just pointing out that it's been around for a long time, and is used in a lot

Re: [PHP-DEV] Woah

2001-09-07 Thread Joey Smith
Did it occur to you that people who *DON'T* use gettext() frequently have to maintain the code of those who do, and that _() isn't going to make one lick of sense to them? On Fri, 7 Sep 2001, Chuck Hagenbuch wrote the following to Joey Smith : > Quoting Joey Smith <[EMAIL PROTECTED]>: > > > No

Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Rodent of Unusual Size <[EMAIL PROTECTED]>: > Speaking only for myself and not Chuck, I would say, "This is > a decision that was made 2.5 years ago. It may have been > the wrong decision then, but it is a waste of time second-guessing > it now. Keeping similar things from happening is

Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Joey Smith <[EMAIL PROTECTED]>: > Did it occur to you that people who *DON'T* use gettext() frequently > have to maintain the code of those who do, and that _() isn't going to > make one lick of sense to them? Given the suggestion to just have people who already use gettext to define f

RE: [PHP-DEV] Woah

2001-09-07 Thread Cristopher Daniluk
But I think the point is this function has no business in the core language. Now we can satisfy that. It IS still obscure, but thats why I won't use it :) Those who want to be obscure can choose to be on their own dime. We should not encourage it though, we'll end up like VBScript, a language of r

Re: [PHP-DEV] Woah

2001-09-07 Thread Chuck Hagenbuch
Quoting Cristopher Daniluk <[EMAIL PROTECTED]>: > But I think the point is this function has no business in the core language. It's not in the core language. It's in the gettext extension. -chuck -- "I have pointy little boobs!" - Jason -- PHP Development Mailing List T

RE: [PHP-DEV] Woah

2001-09-07 Thread Cristopher Daniluk
Heh, touche on my poor terminology. What I mean is it has no business being a function brought to the table by PHP. Even if we moved it to PEAR in a GetText module I'd be a happier guy. What good are ignored standards? Regards, Cristopher Daniluk President & CEO email: [EMAIL PROTECTED] direct:

[PHP-DEV] Bug #13210: problens with php and pws

2001-09-07 Thread fefcamel
From: [EMAIL PROTECTED] Operating system: win98 PHP version: 4.0.4 PHP Bug Type: Any Bug description: problens with php and pws I tried to configure php within pws, but it not work. I tried to use with isapi and cgi configuration, i configured the registry with its path ([H

Re: [PHP-DEV] Woah

2001-09-07 Thread Andrei Zmievski
At 05:33 AM 9/8/01 +0300, Zeev Suraski wrote: >That's unfortunate. IMHO, it should be phased out. I'm against it. _() has been around forever as part of gettext package and people who expect to find it in PHP will be pretty disappointed. -Andrei -- PHP Development Mailing List

Re: [PHP-DEV] Woah

2001-09-07 Thread Rasmus Lerdorf
> Using obscure single character operators is simply something that we don't > do in PHP, it's totally inconsistent with the language. You know I hate magic more than most. I have lobbied against it forever. However, sometimes you need to conform with the underlying 3rd-party mechanism you are c

Re: [PHP-DEV] Woah

2001-09-07 Thread Emiliano
Zeev Suraski wrote: > That's fine and dandy, except gettext() is just one way to internationalize > a site, and there are all sorts of other functionalities people use and > reuse. We can get back to the idea of letting people define % as > htmlspecialchars(), You can do that in PHP? How? E

Re: [PHP-DEV] Woah

2001-09-07 Thread Rasmus Lerdorf
> Zeev Suraski wrote: > > > That's fine and dandy, except gettext() is just one way to internationalize > > a site, and there are all sorts of other functionalities people use and > > reuse. We can get back to the idea of letting people define % as > > htmlspecialchars(), > > You can do that in P

Re: [PHP-DEV] Woah

2001-09-07 Thread Egon Schmid
Zeev Suraski wrote: > > At 05:40 08-09-01, Chuck Hagenbuch wrote: > >It's the kind of thing that gets used a lot in HTML, where otherwise there > >wouldn't be a function call at _all_ - just static text. Replacing gettext() > >with _() in this case actually does improve readability, in my opinion

Re: [PHP-DEV] Woah

2001-09-07 Thread Emiliano
Rasmus Lerdorf wrote: > > > reuse. We can get back to the idea of letting people define % as > > > htmlspecialchars(), > > > > You can do that in PHP? How? > > You can't. You missed the dripping sarcasm. Well, I was torn between accepting it as sarcasm, and getting hints on how to accomplish

[PHP-DEV] IIS/PWS Config done by PHP

2001-09-07 Thread james
Hi, I'm curious to know how PHP configures IIS/PWS to let itself handle all requests for files ending in .php, etc. How is it done? Is it the same for IIS and PWS? Is the configuration different for using PHP as a CGI and as an ISAPI module? PHP puts a string value under the "Script Map" regist

[PHP-DEV] Bug #13191: PHP4 docs .chm missing FAQs

2001-09-07 Thread lispenard
From: [EMAIL PROTECTED] Operating system: PHP version: 4.0.6 PHP Bug Type: Documentation problem Bug description: PHP4 docs .chm missing FAQs Hello, All the .chm versions of the PHP4 documentation since Thu Jul 26 22:28:30 2001 have been missing the excellent and helpfu

[PHP-DEV] Bug #13191 Updated: PHP4 docs English .chm missing FAQs

2001-09-07 Thread lispenard
ID: 13191 User updated by: [EMAIL PROTECTED] Reported By: [EMAIL PROTECTED] Old Summary: PHP4 docs .chm missing FAQs Status: Open Bug Type: Documentation problem Operating System: PHP Version: 4.0.6 New Comment: Very sorry, I forgot to mention the first time that I was referring to the English

[PHP-DEV] Bug #13191 Updated: PHP4 docs .chm missing FAQs

2001-09-07 Thread derick
ID: 13191 Updated by: derick Reported By: [EMAIL PROTECTED] Old Status: Open Status: Assigned Bug Type: Documentation problem Operating System: PHP Version: 4.0.6 New Comment: Working on it Previous Comments: [2001-09-07

[PHP-DEV] Bug #13191 Updated: PHP4 docs .chm missing FAQs

2001-09-07 Thread derick
ID: 13191 Updated by: derick Reported By: [EMAIL PROTECTED] Old Status: Assigned Status: Closed Bug Type: Documentation problem Operating System: PHP Version: 4.0.6 New Comment: Will be fixed as soon as they are regenerated (prolly tomorrow). Derick Previous Comments: ---

<    1   2