RE: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-06-04 Thread Michael W. Oliver

If anyone is interested, I have written a javascript on one of my web pages
that will calculate the canonical MAC address of whatever you enter.  The
URL is http://michael.gargantuan.com/network/calcmac.htm if you want to give
it a whirl

HTH,

Michael







-Original Message-
From: ElephantChild [mailto:[EMAIL PROTECTED]]
Sent: Wednesday, May 31, 2000 8:14 PM
To: Joe Martin
Cc: [EMAIL PROTECTED]
Subject: Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746
to a ethernet attached SNA client over Frame-relay...


On Wed, 31 May 2000, Joe Martin wrote:

 After writing down the binary representation of the mac address, read the
 binary from left to right instead of right to left.  in other words,
 something like 04d0 binary  0100 1101  when read from left to
right
 becomes 02b0.  then swap the nibbles so 02b0 becomes 200b.

ITYM read *each nibble* from left to right, not the whole 48-bit string.
A simpler way to say it is "read each *byte* from right to left." This
combines steps 2 and 3 below.

ObThreadLongPast: You could also learn to reverse hex digits in your
head and eliminate step 1. :-) 

 ""Chuck Larrieu"" [EMAIL PROTECTED] wrote in message
 008901bfcabb$b82fd1e0$[EMAIL PROTECTED]">news:008901bfcabb$b82fd1e0$[EMAIL PROTECTED]...
  Lost me someplace along the line, Joe. Step two - read from left to
right.
 
  You still on cloud nine, or is it past my bedtime? :-
 
  -Original Message-
  From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] On Behalf Of
 Joe
  Martin
 
  heres an example of conversion:
 
  0060.035f.0804
 
  write it in binary
    0110  .  0011 0101  .  1000  0100
 
  read it from left to right
  0060.0caf.0102
 
  swap the nibbles
  0006.c0fa.1020
 
  Thats it
 
  "Mohan" [EMAIL PROTECTED] wrote in message
  [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
  
   joe, can you pls. explain a little more in detail here, and how do i
do
  the conversion, any doc. on this?
   thanks,
   mohan

-- 
Bungee jumping and skydiving are for wimps. If you want to experience
true gut-wrenching terror, have children. --Dusty Rhoades.

___
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

___
UPDATED Posting Guidelines: http://www.groupstudy.com/list/guide.html
FAQ, list archives, and subscription info: http://www.groupstudy.com
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-31 Thread Joe Martin

After writing down the binary representation of the mac address, read the
binary from left to right instead of right to left.  in other words,
something like 04d0 binary  0100 1101  when read from left to right
becomes 02b0.  then swap the nibbles so 02b0 becomes 200b.

And yes, I'm still on cloud nine!!!

JOE
CCIE 5917


""Chuck Larrieu"" [EMAIL PROTECTED] wrote in message
008901bfcabb$b82fd1e0$[EMAIL PROTECTED]">news:008901bfcabb$b82fd1e0$[EMAIL PROTECTED]...
 Lost me someplace along the line, Joe. Step two - read from left to right.

 You still on cloud nine, or is it past my bedtime? :-

 Chuck

 -Original Message-
 From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] On Behalf Of
Joe
 Martin
 Sent: Tuesday, May 30, 2000 8:36 PM
 To: [EMAIL PROTECTED]
 Subject: Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to
a
 ethernet attached SNA client over Frame-relay...

 heres an example of conversion:

 0060.035f.0804

 write it in binary
   0110  .  0011 0101  .  1000  0100

 read it from left to right
 0060.0caf.0102

 swap the nibbles
 0006.c0fa.1020

 Thats it

 JOE
 CCIE 5917


 "Mohan" [EMAIL PROTECTED] wrote in message
 [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
 
  joe, can you pls. explain a little more in detail here, and how do i do
 the conversion, any doc. on this?
  thanks,
  mohan
 
  -Original Message-
  From: Joe Martin [SMTP:[EMAIL PROTECTED]]
  Sent: Tuesday, May 30, 2000 5:15 AM
  To: [EMAIL PROTECTED]
  Subject: Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746
to
 a ethernet attached SNA client over Frame-relay...
 
  MAC addresses are carried in non-canonical format in DLSW.  If your
 running
  a protocol converter on the Ethernet segment and have created a peer mac
  address, make sure you do the conversion.  This is also true of any peer
  statements you have in the routers.
 
  I did an install like this about 3 years ago and that was the only
"issue"
 I
  had.
 
  JOE
  CCIE #5917
 
 
  "Mohan" [EMAIL PROTECTED] wrote in message
  [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
  
   Hi gurus, i have this problem getting a token-ring attached FEP 3746
   talking to a Ethernet attached SNA client over a back-to-back
 frame-relay
   network configured for DLSW+. I followed the instructions and
guidelines
   provided on the cisco DLSW+ docs, however, i fails to get the
  configuration
   work. I hope you gurus can shed some light and help me with this.
  
   the following are my observations:
  
   1. Initially, the interface and line protocol on to0 (Hostrouter) was
 up,
   however shortly after the client was configured the interface gone
into
   shutdown state and i fail to do a no shut, no response and remained at
   shutdown state, i'm only able to do a no shut after removing the
   souce-bridge 9 1 11 statement from the hostrouter. any idea why is
this
   happening. I have even tried upgrading the ios from 11.1 to 11.2 on
the
   hostrouter.
  
   2. I have checked the cables and  cards and confirm to be working
fine.
  
   3. on the remote router, the dlsw peer reach output was showing the
 client
   searching for the 3746 MAC but the session never came-up.
  
   i have attached the config. and show outputs, pls. help to get this
  problem
   fixed. PLS. HELP.
  
   thank you,
  
   mohan
  
 FR
  Ethernet
|3746||ring 9|-|host router|---|remote
   R|-|client|
  
   sh run
   Building configuration...
  
  
  
   Current configuration:
   !
   version 11.2
   no service password-encryption
   service udp-small-servers
   service tcp-small-servers
   !
   hostname Hostrouter
   !
   enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
   enable password router
   !
   source-bridge ring-group 2000
   dlsw local-peer peer-id 150.150.1.1
   dlsw remote-peer 0 tcp 150.150.2.1
   !
   interface Loopback0
ip address 150.150.1.1 255.255.255.0
   !
   interface Serial0
ip address 150.150.100.1 255.255.255.0
encapsulation frame-relay IETF
no fair-queue
frame-relay map ip 150.150.100.2 70
frame-relay lmi-type ansi
   !
   interface Serial1
no ip address
shutdown
   !
   interface TokenRing0
no ip address
shutdown
ring-speed 16
source-bridge 9 1 2000
source-bridge spanning
   !
   no ip classless
   !
   !
   line con 0
   line aux 0
   line vty 0 4
password cisco
login
   !
   end
  
   Hostrouter#sh dlsw peers
   Peers:state pkts_rx   pkts_tx  type  drops ckts
TCP
 uptime
TCP 150.150.2.1 DISCONN  0 0  conf  0
 0   -
  -
  
   Hostrouter#sh dlsw peers reach
   DLSw Local MAC address reachability cache list
   Mac Addrstatus Loc.port rif
  
   DLSw Remote MAC address reachability cach

Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-29 Thread Flem

Mohan ,

The problem is right here ;

04:38:03: DLSw: CONN: peer 150.150.1.1 open failed,
unreachable [17] 

This is one (possible) reason why dlsw is not working
.
Try to do an extended ping between the dlsw peers .
If you get this working the dlsw peers will come in a
connect state .

On the remote router you don't need a source-bridge
ring-group , so you can remove this entry .
Also change the spanning tree protocol to ieee instead
of dec .

On the Fep side , do a 'debug token event ' to see why
the router is not inserting . One reason could be a
ring mismatch .


flem

--- Mohan [EMAIL PROTECTED] wrote:
 
 Hi gurus, i have this problem getting a token-ring
 attached FEP 3746 
 talking to a Ethernet attached SNA client over a
 back-to-back frame-relay 
 network configured for DLSW+. I followed the
 instructions and guidelines 
 provided on the cisco DLSW+ docs, however, i fails
 to get the configuration 
 work. I hope you gurus can shed some light and help
 me with this.
 
 the following are my observations:
 
 1. Initially, the interface and line protocol on to0
 (Hostrouter) was up, 
 however shortly after the client was configured the
 interface gone into 
 shutdown state and i fail to do a no shut, no
 response and remained at 
 shutdown state, i'm only able to do a no shut after
 removing the 
 souce-bridge 9 1 11 statement from the hostrouter.
 any idea why is this 
 happening. I have even tried upgrading the ios from
 11.1 to 11.2 on the 
 hostrouter.
 
 2. I have checked the cables and  cards and confirm
 to be working fine.
 
 3. on the remote router, the dlsw peer reach output
 was showing the client 
 searching for the 3746 MAC but the session never
 came-up.
 
 i have attached the config. and show outputs, pls.
 help to get this problem 
 fixed. PLS. HELP.
 
 thank you,
 
 mohan
 
   FR
 
Ethernet
  |3746||ring 9|-|host
 router|---|remote 
 R|-|client|
 
 sh run
 Building configuration...
 
 
 
 Current configuration:
 !
 version 11.2
 no service password-encryption
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Hostrouter
 !
 enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
 enable password router
 !
 source-bridge ring-group 2000
 dlsw local-peer peer-id 150.150.1.1
 dlsw remote-peer 0 tcp 150.150.2.1
 !
 interface Loopback0
  ip address 150.150.1.1 255.255.255.0
 !
 interface Serial0
  ip address 150.150.100.1 255.255.255.0
  encapsulation frame-relay IETF
  no fair-queue
  frame-relay map ip 150.150.100.2 70
  frame-relay lmi-type ansi
 !
 interface Serial1
  no ip address
  shutdown
 !
 interface TokenRing0
  no ip address
  shutdown
  ring-speed 16
  source-bridge 9 1 2000
  source-bridge spanning
 !
 no ip classless
 !
 !
 line con 0
 line aux 0
 line vty 0 4
  password cisco
  login
 !
 end
 
 Hostrouter#sh dlsw peers
 Peers:state pkts_rx   pkts_tx 
 type  drops ckts TCP 
   uptime
  TCP 150.150.2.1 DISCONN  0 0 
 conf  00   - 
-
 
 Hostrouter#sh dlsw peers reach
 DLSw Local MAC address reachability cache list
 Mac Addrstatus Loc.port 
rif
 
 DLSw Remote MAC address reachability cache list
 Mac Addrstatus Loc.peer
 
 DLSw Local NetBIOS Name reachability cache list
 NetBIOS Namestatus Loc.port 
rif
 
 DLSw Remote NetBIOS Name reachability cache list
 NetBIOS Namestatus Loc.peer
 
 Hostrouter#
 
 
 Remote#sh run
 Building configuration...
 
 
 
 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname Remote
 !
 !
 ip subnet-zero
 ip host HQ 150.150.100.1
 frame-relay switching
 !
 !
 !
 !
 source-bridge ring-group 2000
 dlsw local-peer peer-id 150.150.2.1
 dlsw remote-peer 0 tcp 150.150.1.1
 dlsw bridge-group 1
 !
 !
 !
 interface Loopback0
  ip address 150.150.2.1 255.255.255.0
  no ip directed-broadcast
 !
 interface Ethernet0/0
  ip address 150.150.30.1 255.255.255.0
  no ip directed-broadcast
  bridge-group 1
 !
 interface Serial0/0
  ip address 150.150.100.2 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay IETF
  no ip mroute-cache
  no fair-queue
  frame-relay map ip 150.150.100.1 70
  frame-relay lmi-type ansi
  frame-relay intf-type dce
 !
 interface Serial0/1
  no ip address
  no ip directed-broadcast
  shutdown
 !
 no ip classless
 !
 !
 bridge 1 protocol dec
 !
 line con 0
  transport input none
 line aux 0
  session-timeout 2
  no exec
  exec-timeout 0 0
  modem InOut
  transport input all
  stopbits 1
 line vty 0 4
  password cisco
  login
 !
 end
 
 Remote#sh dlsw peers
 Peers:state pkts_rx   pkts_tx 
 type  drops ckts TCP 
   uptime
  TCP 150.150.1.1 DISCONN  0 0 
 conf  00   - 
-
 Total number of connected peers: 0
 Total number of 

RE: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-29 Thread Andrew Larkins

where are the routes

Andrew Larkins
Usko Communications
Tel: +2711 236-8000 
Fax: +2711 236-8350
Cell: +2783-656-7214
Email: [EMAIL PROTECTED] 
   

"This message may contain information which is confidential and subject to
legal privilege.  If you are not the intended recipient, you may not peruse,
use, disseminate, distribute or copy this message.  If you have received
this message in error, please notify the sender immediately by email,
facsimile or telephone and return and/or destroy the original message."




-Original Message-
From: Mohan [mailto:[EMAIL PROTECTED]]
Sent: 29 May 2000 11:47
To: '[EMAIL PROTECTED]'
Subject: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a
ethernet attached SNA client over Frame-relay...



Hi gurus, i have this problem getting a token-ring attached FEP 3746 
talking to a Ethernet attached SNA client over a back-to-back frame-relay 
network configured for DLSW+. I followed the instructions and guidelines 
provided on the cisco DLSW+ docs, however, i fails to get the configuration 
work. I hope you gurus can shed some light and help me with this.

the following are my observations:

1. Initially, the interface and line protocol on to0 (Hostrouter) was up, 
however shortly after the client was configured the interface gone into 
shutdown state and i fail to do a no shut, no response and remained at 
shutdown state, i'm only able to do a no shut after removing the 
souce-bridge 9 1 11 statement from the hostrouter. any idea why is this 
happening. I have even tried upgrading the ios from 11.1 to 11.2 on the 
hostrouter.

2. I have checked the cables and  cards and confirm to be working fine.

3. on the remote router, the dlsw peer reach output was showing the client 
searching for the 3746 MAC but the session never came-up.

i have attached the config. and show outputs, pls. help to get this problem 
fixed. PLS. HELP.

thank you,

mohan

  FR 
   Ethernet
 |3746||ring 9|-|host router|---|remote 
R|-|client|

sh run
Building configuration...



Current configuration:
!
version 11.2
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Hostrouter
!
enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
enable password router
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.1.1
dlsw remote-peer 0 tcp 150.150.2.1
!
interface Loopback0
 ip address 150.150.1.1 255.255.255.0
!
interface Serial0
 ip address 150.150.100.1 255.255.255.0
 encapsulation frame-relay IETF
 no fair-queue
 frame-relay map ip 150.150.100.2 70
 frame-relay lmi-type ansi
!
interface Serial1
 no ip address
 shutdown
!
interface TokenRing0
 no ip address
 shutdown
 ring-speed 16
 source-bridge 9 1 2000
 source-bridge spanning
!
no ip classless
!
!
line con 0
line aux 0
line vty 0 4
 password cisco
 login
!
end

Hostrouter#sh dlsw peers
Peers:state pkts_rx   pkts_tx  type  drops ckts TCP 
  uptime
 TCP 150.150.2.1 DISCONN  0 0  conf  00   - 
   -

Hostrouter#sh dlsw peers reach
DLSw Local MAC address reachability cache list
Mac Addrstatus Loc.port rif

DLSw Remote MAC address reachability cache list
Mac Addrstatus Loc.peer

DLSw Local NetBIOS Name reachability cache list
NetBIOS Namestatus Loc.port rif

DLSw Remote NetBIOS Name reachability cache list
NetBIOS Namestatus Loc.peer

Hostrouter#


Remote#sh run
Building configuration...



Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Remote
!
!
ip subnet-zero
ip host HQ 150.150.100.1
frame-relay switching
!
!
!
!
source-bridge ring-group 2000
dlsw local-peer peer-id 150.150.2.1
dlsw remote-peer 0 tcp 150.150.1.1
dlsw bridge-group 1
!
!
!
interface Loopback0
 ip address 150.150.2.1 255.255.255.0
 no ip directed-broadcast
!
interface Ethernet0/0
 ip address 150.150.30.1 255.255.255.0
 no ip directed-broadcast
 bridge-group 1
!
interface Serial0/0
 ip address 150.150.100.2 255.255.255.0
 no ip directed-broadcast
 encapsulation frame-relay IETF
 no ip mroute-cache
 no fair-queue
 frame-relay map ip 150.150.100.1 70
 frame-relay lmi-type ansi
 frame-relay intf-type dce
!
interface Serial0/1
 no ip address
 no ip directed-broadcast
 shutdown
!
no ip classless
!
!
bridge 1 protocol dec
!
line con 0
 transport input none
line aux 0
 session-timeout 2
 no exec
 exec-timeout 0 0
 modem InOut
 transport input all
 stopbits 1
line vty 0 4
 password cisco
 login
!
end

Remote#sh dlsw peers
Peers:state pkts_rx   pkts_tx  type  drops ckts TCP 
  uptime
 TCP 150.150.1.1 DISCONN  0 0  conf  00   - 
   -
Total number of connected peers: 0
Total number of connections: 0

Remote#sh dlsw peers reach
DLSw Local MAC 

Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-29 Thread Joe Martin

MAC addresses are carried in non-canonical format in DLSW.  If your running
a protocol converter on the Ethernet segment and have created a peer mac
address, make sure you do the conversion.  This is also true of any peer
statements you have in the routers.

I did an install like this about 3 years ago and that was the only "issue" I
had.

JOE
CCIE #5917


"Mohan" [EMAIL PROTECTED] wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...

 Hi gurus, i have this problem getting a token-ring attached FEP 3746
 talking to a Ethernet attached SNA client over a back-to-back frame-relay
 network configured for DLSW+. I followed the instructions and guidelines
 provided on the cisco DLSW+ docs, however, i fails to get the
configuration
 work. I hope you gurus can shed some light and help me with this.

 the following are my observations:

 1. Initially, the interface and line protocol on to0 (Hostrouter) was up,
 however shortly after the client was configured the interface gone into
 shutdown state and i fail to do a no shut, no response and remained at
 shutdown state, i'm only able to do a no shut after removing the
 souce-bridge 9 1 11 statement from the hostrouter. any idea why is this
 happening. I have even tried upgrading the ios from 11.1 to 11.2 on the
 hostrouter.

 2. I have checked the cables and  cards and confirm to be working fine.

 3. on the remote router, the dlsw peer reach output was showing the client
 searching for the 3746 MAC but the session never came-up.

 i have attached the config. and show outputs, pls. help to get this
problem
 fixed. PLS. HELP.

 thank you,

 mohan

   FR
Ethernet
  |3746||ring 9|-|host router|---|remote
 R|-|client|

 sh run
 Building configuration...



 Current configuration:
 !
 version 11.2
 no service password-encryption
 service udp-small-servers
 service tcp-small-servers
 !
 hostname Hostrouter
 !
 enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
 enable password router
 !
 source-bridge ring-group 2000
 dlsw local-peer peer-id 150.150.1.1
 dlsw remote-peer 0 tcp 150.150.2.1
 !
 interface Loopback0
  ip address 150.150.1.1 255.255.255.0
 !
 interface Serial0
  ip address 150.150.100.1 255.255.255.0
  encapsulation frame-relay IETF
  no fair-queue
  frame-relay map ip 150.150.100.2 70
  frame-relay lmi-type ansi
 !
 interface Serial1
  no ip address
  shutdown
 !
 interface TokenRing0
  no ip address
  shutdown
  ring-speed 16
  source-bridge 9 1 2000
  source-bridge spanning
 !
 no ip classless
 !
 !
 line con 0
 line aux 0
 line vty 0 4
  password cisco
  login
 !
 end

 Hostrouter#sh dlsw peers
 Peers:state pkts_rx   pkts_tx  type  drops ckts TCP
   uptime
  TCP 150.150.2.1 DISCONN  0 0  conf  00   -
-

 Hostrouter#sh dlsw peers reach
 DLSw Local MAC address reachability cache list
 Mac Addrstatus Loc.port rif

 DLSw Remote MAC address reachability cache list
 Mac Addrstatus Loc.peer

 DLSw Local NetBIOS Name reachability cache list
 NetBIOS Namestatus Loc.port rif

 DLSw Remote NetBIOS Name reachability cache list
 NetBIOS Namestatus Loc.peer

 Hostrouter#


 Remote#sh run
 Building configuration...



 Current configuration:
 !
 version 12.0
 service timestamps debug uptime
 service timestamps log uptime
 no service password-encryption
 !
 hostname Remote
 !
 !
 ip subnet-zero
 ip host HQ 150.150.100.1
 frame-relay switching
 !
 !
 !
 !
 source-bridge ring-group 2000
 dlsw local-peer peer-id 150.150.2.1
 dlsw remote-peer 0 tcp 150.150.1.1
 dlsw bridge-group 1
 !
 !
 !
 interface Loopback0
  ip address 150.150.2.1 255.255.255.0
  no ip directed-broadcast
 !
 interface Ethernet0/0
  ip address 150.150.30.1 255.255.255.0
  no ip directed-broadcast
  bridge-group 1
 !
 interface Serial0/0
  ip address 150.150.100.2 255.255.255.0
  no ip directed-broadcast
  encapsulation frame-relay IETF
  no ip mroute-cache
  no fair-queue
  frame-relay map ip 150.150.100.1 70
  frame-relay lmi-type ansi
  frame-relay intf-type dce
 !
 interface Serial0/1
  no ip address
  no ip directed-broadcast
  shutdown
 !
 no ip classless
 !
 !
 bridge 1 protocol dec
 !
 line con 0
  transport input none
 line aux 0
  session-timeout 2
  no exec
  exec-timeout 0 0
  modem InOut
  transport input all
  stopbits 1
 line vty 0 4
  password cisco
  login
 !
 end

 Remote#sh dlsw peers
 Peers:state pkts_rx   pkts_tx  type  drops ckts TCP
   uptime
  TCP 150.150.1.1 DISCONN  0 0  conf  00   -
-
 Total number of connected peers: 0
 Total number of connections: 0

 Remote#sh dlsw peers reach
 DLSw Local MAC address reachability cache list
 Mac Addr status Loc.port rif

 DLSw Remote MAC address reachability cache list
 Mac Addr status 

Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-29 Thread Flem

Joe ,

Dlsw peers are active peers . They need to be in a
connect state . Debugs shows that they cannot connect
.
( 100% sure this is a routing issue )

Don't think you are correct in your response ;
Mac addresses are kept in the dlsw reachability in a
non-cannonical format . This means that you do NOT
need to do the conversion yourself . Dlsw will take
care of this . If you are talking about translational
bridging or SDLC connections you do need to make the
conversion yourself .


flem

--- Joe Martin [EMAIL PROTECTED] wrote:
 MAC addresses are carried in non-canonical format in
 DLSW.  If your running
 a protocol converter on the Ethernet segment and
 have created a peer mac
 address, make sure you do the conversion.  This is
 also true of any peer
 statements you have in the routers.
 
 I did an install like this about 3 years ago and
 that was the only "issue" I
 had.
 
 JOE
 CCIE #5917
 
 
 "Mohan" [EMAIL PROTECTED] wrote in message
 [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
 
  Hi gurus, i have this problem getting a token-ring
 attached FEP 3746
  talking to a Ethernet attached SNA client over a
 back-to-back frame-relay
  network configured for DLSW+. I followed the
 instructions and guidelines
  provided on the cisco DLSW+ docs, however, i fails
 to get the
 configuration
  work. I hope you gurus can shed some light and
 help me with this.
 
  the following are my observations:
 
  1. Initially, the interface and line protocol on
 to0 (Hostrouter) was up,
  however shortly after the client was configured
 the interface gone into
  shutdown state and i fail to do a no shut, no
 response and remained at
  shutdown state, i'm only able to do a no shut
 after removing the
  souce-bridge 9 1 11 statement from the hostrouter.
 any idea why is this
  happening. I have even tried upgrading the ios
 from 11.1 to 11.2 on the
  hostrouter.
 
  2. I have checked the cables and  cards and
 confirm to be working fine.
 
  3. on the remote router, the dlsw peer reach
 output was showing the client
  searching for the 3746 MAC but the session never
 came-up.
 
  i have attached the config. and show outputs, pls.
 help to get this
 problem
  fixed. PLS. HELP.
 
  thank you,
 
  mohan
 
   
 FR
 Ethernet
   |3746||ring 9|-|host
 router|---|remote
  R|-|client|
 
  sh run
  Building configuration...
 
 
 
  Current configuration:
  !
  version 11.2
  no service password-encryption
  service udp-small-servers
  service tcp-small-servers
  !
  hostname Hostrouter
  !
  enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
  enable password router
  !
  source-bridge ring-group 2000
  dlsw local-peer peer-id 150.150.1.1
  dlsw remote-peer 0 tcp 150.150.2.1
  !
  interface Loopback0
   ip address 150.150.1.1 255.255.255.0
  !
  interface Serial0
   ip address 150.150.100.1 255.255.255.0
   encapsulation frame-relay IETF
   no fair-queue
   frame-relay map ip 150.150.100.2 70
   frame-relay lmi-type ansi
  !
  interface Serial1
   no ip address
   shutdown
  !
  interface TokenRing0
   no ip address
   shutdown
   ring-speed 16
   source-bridge 9 1 2000
   source-bridge spanning
  !
  no ip classless
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   password cisco
   login
  !
  end
 
  Hostrouter#sh dlsw peers
  Peers:state pkts_rx   pkts_tx 
 type  drops ckts TCP
uptime
   TCP 150.150.2.1 DISCONN  0 0 
 conf  00   -
 -
 
  Hostrouter#sh dlsw peers reach
  DLSw Local MAC address reachability cache list
  Mac Addrstatus Loc.port   
  rif
 
  DLSw Remote MAC address reachability cache list
  Mac Addrstatus Loc.peer
 
  DLSw Local NetBIOS Name reachability cache list
  NetBIOS Namestatus Loc.port   
  rif
 
  DLSw Remote NetBIOS Name reachability cache list
  NetBIOS Namestatus Loc.peer
 
  Hostrouter#
 
 
  Remote#sh run
  Building configuration...
 
 
 
  Current configuration:
  !
  version 12.0
  service timestamps debug uptime
  service timestamps log uptime
  no service password-encryption
  !
  hostname Remote
  !
  !
  ip subnet-zero
  ip host HQ 150.150.100.1
  frame-relay switching
  !
  !
  !
  !
  source-bridge ring-group 2000
  dlsw local-peer peer-id 150.150.2.1
  dlsw remote-peer 0 tcp 150.150.1.1
  dlsw bridge-group 1
  !
  !
  !
  interface Loopback0
   ip address 150.150.2.1 255.255.255.0
   no ip directed-broadcast
  !
  interface Ethernet0/0
   ip address 150.150.30.1 255.255.255.0
   no ip directed-broadcast
   bridge-group 1
  !
  interface Serial0/0
   ip address 150.150.100.2 255.255.255.0
   no ip directed-broadcast
   encapsulation frame-relay IETF
   no ip mroute-cache
   no fair-queue
   frame-relay map ip 150.150.100.1 70
   frame-relay lmi-type ansi
   frame-relay intf-type dce
  !
  interface Serial0/1
   no ip address
   no ip directed-broadcast
   

RE: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to a ethernet attached SNA client over Frame-relay...

2000-05-29 Thread Mohan


hi all,  a CCIE from the cisco open forum responded as below:

Answer:
You probably have another bridge on the ring.  do the following debugs 
before

trying to no shut the interface

debug source events

term mon



Typically, you do not want to peer to an interface address, but rather a 
loopback

address.  This way DLSW will come to the "connected" state.  This of course 
would

not help you in this case because you have a problem on your token ring 
anyway.

You will need to resolve that.  If you have another RPS (Ring Parameter 
Server)

on the ring, and you try to come up with a different ring number, the RPS 
will

not allow you into the ring.

i'm using a loopback interface for my peers and its not connecting, routing 
might not be a issue here since i have no problem to ping or connecting to 
the remote router unless i'm missing out something important here. 
 secondly, there is no other ring other than ring 9 and there is no RPS 
server present.
flem,  you're right. no MAC address conversion is needed for dlsw unlike 
sdlc, cisco doc. confirms this. BUT, what could have gone wrong here...
pls. help and thanks guys,
mohan


-Original Message-
From:   Flem [SMTP:[EMAIL PROTECTED]]
Sent:   Tuesday, May 30, 2000 6:23 AM
To: [EMAIL PROTECTED]
Cc: [EMAIL PROTECTED]
Subject:        Re: PLS HELP - DLSW+ not working, token-ring attached FEP 3746 to 
a ethernet attached SNA client over Frame-relay...

Joe ,

Dlsw peers are active peers . They need to be in a
connect state . Debugs shows that they cannot connect
.
( 100% sure this is a routing issue )

Don't think you are correct in your response ;
Mac addresses are kept in the dlsw reachability in a
non-cannonical format . This means that you do NOT
need to do the conversion yourself . Dlsw will take
care of this . If you are talking about translational
bridging or SDLC connections you do need to make the
conversion yourself .


flem

--- Joe Martin [EMAIL PROTECTED] wrote:
 MAC addresses are carried in non-canonical format in
 DLSW.  If your running
 a protocol converter on the Ethernet segment and
 have created a peer mac
 address, make sure you do the conversion.  This is
 also true of any peer
 statements you have in the routers.

 I did an install like this about 3 years ago and
 that was the only "issue" I
 had.

 JOE
 CCIE #5917


 "Mohan" [EMAIL PROTECTED] wrote in message
 [EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
 
  Hi gurus, i have this problem getting a token-ring
 attached FEP 3746
  talking to a Ethernet attached SNA client over a
 back-to-back frame-relay
  network configured for DLSW+. I followed the
 instructions and guidelines
  provided on the cisco DLSW+ docs, however, i fails
 to get the
 configuration
  work. I hope you gurus can shed some light and
 help me with this.
 
  the following are my observations:
 
  1. Initially, the interface and line protocol on
 to0 (Hostrouter) was up,
  however shortly after the client was configured
 the interface gone into
  shutdown state and i fail to do a no shut, no
 response and remained at
  shutdown state, i'm only able to do a no shut
 after removing the
  souce-bridge 9 1 11 statement from the hostrouter.
 any idea why is this
  happening. I have even tried upgrading the ios
 from 11.1 to 11.2 on the
  hostrouter.
 
  2. I have checked the cables and  cards and
 confirm to be working fine.
 
  3. on the remote router, the dlsw peer reach
 output was showing the client
  searching for the 3746 MAC but the session never
 came-up.
 
  i have attached the config. and show outputs, pls.
 help to get this
 problem
  fixed. PLS. HELP.
 
  thank you,
 
  mohan
 
 
 FR
 Ethernet
   |3746||ring 9|-|host
 router|---|remote
  R|-|client|
 
  sh run
  Building configuration...
 
 
 
  Current configuration:
  !
  version 11.2
  no service password-encryption
  service udp-small-servers
  service tcp-small-servers
  !
  hostname Hostrouter
  !
  enable secret 5 $1$Fw2W$g97jlFnPbudx14b2qBeGO.
  enable password router
  !
  source-bridge ring-group 2000
  dlsw local-peer peer-id 150.150.1.1
  dlsw remote-peer 0 tcp 150.150.2.1
  !
  interface Loopback0
   ip address 150.150.1.1 255.255.255.0
  !
  interface Serial0
   ip address 150.150.100.1 255.255.255.0
   encapsulation frame-relay IETF
   no fair-queue
   frame-relay map ip 150.150.100.2 70
   frame-relay lmi-type ansi
  !
  interface Serial1
   no ip address
   shutdown
  !
  interface TokenRing0
   no ip address
   shutdown
   ring-speed 16
   source-bridge 9 1 2000
   source-bridge spanning
  !
  no ip classless
  !
  !
  line con 0
  line aux 0
  line vty 0 4
   password cisco
   login
  !
  end
 
  Hostrouter#sh dlsw peers
  Peers:state pkts_rx   pkts_tx
 type  drops ckts TCP
uptime
   TCP 150.150.2.1 DISCONN  0 0
 conf  00   -
 -
 
  Hostrouter#sh dlsw peers reach
  DLS