Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-04 Thread David Lang

A given radio can be either an AP or a client, but not both at once.

so if you use a radio to connect to another AP, you are making it a client, and 
in client mode all it can do is connect to that other AP as shows up as the SSID 
of that other AP.


you can do this with one radio, while using the other radio (assuming you have 
two) to act as an AP for local clients.


David Lang

 On Tue, 4 Aug 2015, John kerry wrote:


Hi,

Its working, i am able to access internet but there is one problem,

When i scan the wireless devices, its gives the list of devices are there
nearby, then i connect anyone device, it will connect but my board wifi0
SSID name will change to that router which i connected. I mean LAN side
SSID should not change after connecting to WAN SSID.



On Tue, Aug 4, 2015 at 12:42 PM, John kerry kerry9...@gmail.com wrote:


Hi
This is my firewall file:

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

On Tue, Aug 4, 2015 at 12:38 PM, Weedy weedy2...@gmail.com wrote:


Is there something wrong with the default rules for your use case?

Your WiFi interfaces are tagged LAN, things should just work.
On 4 Aug 2015 00:07, John kerry kerry9...@gmail.com wrote:


Hi,

below is the /etc/config/network and /etc/config/wireless changes.

*/etc/config/network:*
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1 eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.5'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0t 1'

config switch
option name 'eth1'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 1 2 3 4 5'



















*/etc/config/wireless:config wifi-device 'wifi0'option type
'qcawifi'option channel 'auto'option macaddr

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-04 Thread John kerry
Hi,

Yes i configured the mode as AP. could you please guide how i can add
script for another radio.

presently my wireless script is as below:















*config wifi-device 'wifi0'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:61'option
hwmode '11ng'option txpower '19'option htmode 'HT20'config
wifi-ifaceoption device 'wifi0'option network 'lan'
option mode 'ap'option encryption 'psk2'option ssid
'Test_ap_1'option key **'Test_ap_1'*

















*config wifi-device 'wifi1'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:62'option
hwmode '11na'option txpower '23'option htmode 'HT20'config
wifi-ifaceoption device 'wifi1'option network 'lan'
option mode 'ap'option ssid 'Test_ap_2'option encryption
'psk2'option key 'test_ap_2'*


*How i can change this to make it work.*


*Thanks,*

On Tue, Aug 4, 2015 at 2:26 PM, David Lang da...@lang.hm wrote:

 A given radio can be either an AP or a client, but not both at once.

 so if you use a radio to connect to another AP, you are making it a
 client, and in client mode all it can do is connect to that other AP as
 shows up as the SSID of that other AP.

 you can do this with one radio, while using the other radio (assuming you
 have two) to act as an AP for local clients.

 David Lang

  On Tue, 4 Aug 2015, John kerry wrote:

 Hi,

 Its working, i am able to access internet but there is one problem,

 When i scan the wireless devices, its gives the list of devices are there
 nearby, then i connect anyone device, it will connect but my board wifi0
 SSID name will change to that router which i connected. I mean LAN side
 SSID should not change after connecting to WAN SSID.



 On Tue, Aug 4, 2015 at 12:42 PM, John kerry kerry9...@gmail.com wrote:

 Hi
 This is my firewall file:

 config defaults
 option syn_flood '1'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'REJECT'

 config zone
 option name 'lan'
 option network 'lan'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'REJECT'

 config zone
 option name 'wan'
 option network 'wan'
 option input 'REJECT'
 option output 'ACCEPT'
 option forward 'REJECT'
 option masq '1'
 option mtu_fix '1'

 config forwarding
 option src 'lan'
 option dest 'wan'

 config rule
 option name 'Allow-DHCP-Renew'
 option src 'wan'
 option proto 'udp'
 option dest_port '68'
 option target 'ACCEPT'
 option family 'ipv4'

 config rule
 option name 'Allow-Ping'
 option src 'wan'
 option proto 'icmp'
 option icmp_type 'echo-request'
 option family 'ipv4'
 option target 'ACCEPT'

 config rule
 option name 'Allow-DHCPv6'
 option src 'wan'
 option proto 'udp'
 option src_ip 'fe80::/10'
 option src_port '547'
 option dest_ip 'fe80::/10'
 option dest_port '546'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Input'
 option src 'wan'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 list icmp_type 'router-solicitation'
 list icmp_type 'neighbour-solicitation'
 list icmp_type 'router-advertisement'
 list icmp_type 'neighbour-advertisement'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Forward'
 option src 'wan'
 option dest '*'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config include
 option path '/etc/firewall.user'

 config include 'miniupnpd'
 option type 'script'
 option path '/usr/share/miniupnpd/firewall.include'
 option family 'IPv4'
 option reload '1'

 On Tue, Aug 4, 2015 at 12:38 PM, Weedy weedy2...@gmail.com wrote:

 Is there something wrong with the default rules for your use case?

 Your WiFi interfaces are tagged LAN, things should just work.
 On 4 Aug 2015 00:07, John kerry kerry9...@gmail.com wrote:

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-04 Thread David Lang
you can't create a new radio with a script, you have to have a second radio in 
the hardware.


wifi0 is one radio, wifi1 is the second. configure one as an AP, the other as a 
client (you probably want to make the client be part of the wan 
interface/firewall group if it's your connection to the Internet)


As I said before, since you don't understand how the configs work, I'd suggest 
using the GUI to configure them and then look at what the resulting file looks 
like. A lot of expertise went into making the GUI set the right config options 
to make pretty complex things happen.


David Lang

On Tue, 4 Aug 2015, John kerry wrote:


Date: Tue, 4 Aug 2015 14:41:38 +0800
From: John kerry kerry9...@gmail.com
To: David Lang da...@lang.hm
Cc: Weedy weedy2...@gmail.com, N. Leiten nicklei...@gmail.com,
OpenWrt Development List openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

Hi,

Yes i configured the mode as AP. could you please guide how i can add
script for another radio.

presently my wireless script is as below:















*config wifi-device 'wifi0'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:61'option
hwmode '11ng'option txpower '19'option htmode 'HT20'config
wifi-ifaceoption device 'wifi0'option network 'lan'
option mode 'ap'option encryption 'psk2'option ssid
'Test_ap_1'option key **'Test_ap_1'*

















*config wifi-device 'wifi1'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:62'option
hwmode '11na'option txpower '23'option htmode 'HT20'config
wifi-ifaceoption device 'wifi1'option network 'lan'
option mode 'ap'option ssid 'Test_ap_2'option encryption
'psk2'option key 'test_ap_2'*


*How i can change this to make it work.*


*Thanks,*

On Tue, Aug 4, 2015 at 2:26 PM, David Lang da...@lang.hm wrote:


A given radio can be either an AP or a client, but not both at once.

so if you use a radio to connect to another AP, you are making it a
client, and in client mode all it can do is connect to that other AP as
shows up as the SSID of that other AP.

you can do this with one radio, while using the other radio (assuming you
have two) to act as an AP for local clients.

David Lang

 On Tue, 4 Aug 2015, John kerry wrote:

Hi,


Its working, i am able to access internet but there is one problem,

When i scan the wireless devices, its gives the list of devices are there
nearby, then i connect anyone device, it will connect but my board wifi0
SSID name will change to that router which i connected. I mean LAN side
SSID should not change after connecting to WAN SSID.



On Tue, Aug 4, 2015 at 12:42 PM, John kerry kerry9...@gmail.com wrote:

Hi

This is my firewall file:

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-04 Thread David Lang

On Tue, 4 Aug 2015, John kerry wrote:


I have one doubts, both should be configured either 2.4GHz or 5GHz but for
wifi1 in GUI there is no option to change to 2.4GHz.


no, one radio is only able to operate on the 2.4GHz band and the other is only 
able to operate on the 5GHz band. this isn't a configuration item, this is teh 
physical/electrical properties of the radios.


without some rather complicated (and expensive) setup you can't have two radios 
on te 2.4GHz band in one AP, when one transmits it would defen (if not actually 
damage) the other


you can use one as a client to a remote AP (say the 5GHz band) and then use the 
other (the 2.4GHz band) to provide service to nearby equipment. I actually just 
finished setting up this exact configuration to extend service into a nearby 
building across a parking lot.


David Lang


Thanks,

On Tue, Aug 4, 2015 at 2:56 PM, David Lang da...@lang.hm wrote:


you can't create a new radio with a script, you have to have a second
radio in the hardware.

wifi0 is one radio, wifi1 is the second. configure one as an AP, the other
as a client (you probably want to make the client be part of the wan
interface/firewall group if it's your connection to the Internet)

As I said before, since you don't understand how the configs work, I'd
suggest using the GUI to configure them and then look at what the resulting
file looks like. A lot of expertise went into making the GUI set the right
config options to make pretty complex things happen.

David Lang

On Tue, 4 Aug 2015, John kerry wrote:

Date: Tue, 4 Aug 2015 14:41:38 +0800

From: John kerry kerry9...@gmail.com
To: David Lang da...@lang.hm
Cc: Weedy weedy2...@gmail.com, N. Leiten nicklei...@gmail.com,
OpenWrt Development List openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

Hi,

Yes i configured the mode as AP. could you please guide how i can add
script for another radio.

presently my wireless script is as below:















*config wifi-device 'wifi0'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:61'option
hwmode '11ng'option txpower '19'option htmode 'HT20'config
wifi-ifaceoption device 'wifi0'option network 'lan'
option mode 'ap'option encryption 'psk2'option ssid
'Test_ap_1'option key **'Test_ap_1'*

















*config wifi-device 'wifi1'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:62'option
hwmode '11na'option txpower '23'option htmode 'HT20'config
wifi-ifaceoption device 'wifi1'option network 'lan'
option mode 'ap'option ssid 'Test_ap_2'option encryption
'psk2'option key 'test_ap_2'*


*How i can change this to make it work.*



*Thanks,*

On Tue, Aug 4, 2015 at 2:26 PM, David Lang da...@lang.hm wrote:

A given radio can be either an AP or a client, but not both at once.


so if you use a radio to connect to another AP, you are making it a
client, and in client mode all it can do is connect to that other AP as
shows up as the SSID of that other AP.

you can do this with one radio, while using the other radio (assuming you
have two) to act as an AP for local clients.

David Lang

 On Tue, 4 Aug 2015, John kerry wrote:

Hi,



Its working, i am able to access internet but there is one problem,

When i scan the wireless devices, its gives the list of devices are
there
nearby, then i connect anyone device, it will connect but my board wifi0
SSID name will change to that router which i connected. I mean LAN side
SSID should not change after connecting to WAN SSID.



On Tue, Aug 4, 2015 at 12:42 PM, John kerry kerry9...@gmail.com
wrote:

Hi


This is my firewall file:

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread David Lang
just changes doesn't help a lot (and it's rather hard to see what's what with 
the wireless file)


but it doesn't look like the wireless interfaces are configured to be part of 
the LAN interface.


David Lang

On Tue, 4 Aug 2015, John kerry wrote:


Date: Tue, 4 Aug 2015 12:07:38 +0800
From: John kerry kerry9...@gmail.com
To: David Lang da...@lang.hm
Cc: N.Leiten nicklei...@gmail.com,
OpenWrt Development List openwrt-devel@lists.openwrt.org,
Alex Weedy weedy2...@gmail.com
Subject: Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

Hi,

below is the /etc/config/network and /etc/config/wireless changes.

*/etc/config/network:*
config interface 'loopback'
   option ifname 'lo'
   option proto 'static'
   option ipaddr '127.0.0.1'
   option netmask '255.0.0.0'

config interface 'lan'
   option ifname 'eth0.1 eth1'
   option type 'bridge'
   option proto 'static'
   option ipaddr '192.168.1.5'
   option netmask '255.255.255.0'

config interface 'wan'
   option ifname 'eth0.2'
   option proto 'dhcp'

config switch
   option name 'eth0'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth0'
   option vlan '1'
   option ports '0t 2 3 4 5'

config switch_vlan
   option device 'eth0'
   option vlan '2'
   option ports '0t 1'

config switch
   option name 'eth1'
   option reset '1'
   option enable_vlan '1'

config switch_vlan
   option device 'eth1'
   option vlan '1'
   option ports '0 1 2 3 4 5'



















*/etc/config/wireless:config wifi-device 'wifi0'option type
'qcawifi'option channel 'auto'option macaddr
'00:03:7f:42:06:61'option hwmode '11ng'option txpower
'19'option htmode 'HT20'config wifi-ifaceoption device
'wifi0'option network 'lan'option mode 'ap'option
encryption 'psk2'option ssid 'Test_ap_1'option key *
*'Test_ap_1'*

















*config wifi-device 'wifi1'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:62'option
hwmode '11na'option txpower '23'option htmode 'HT20'config
wifi-ifaceoption device 'wifi1'option network 'lan'
option mode 'ap'option ssid 'Test_ap_2'option encryption
'psk2'option key 'test_ap_2''*


*Thanks,*

On Tue, Aug 4, 2015 at 11:56 AM, David Lang da...@lang.hm wrote:


can you connect via a wired port?

given that you've been changing /etc/config/network and
/etc/config/wireless, could you show us what you ended up with there?

David Lang


On Tue, 4 Aug 2015, John kerry wrote:

Hi,


I am using ar71xx OpenWrt. I have connected internet connection to WAN
port
and my PC to LAN. I have enabled the WiFi0. The LAN port static IP i am
able to open GUI and even my mobile i connected to Wifi AP and able to
open
GUI in mobile. But I am not able to access internet on mobile which is
connected to wifi0 AP.

I have added below script under /etc/firewall.user file.
iptables ...flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables -A FORWARD -j ACCEPT -i br-lan -o eth0.2 -m state --state NEW
iptables -A FORWARD -m state --state ESTABLISHED,RELATED  -j ACCEPT
iptables -A POSTROUTING -t nat -o eth0.2 -j MASQUERADE
echo 1   /proc/sys/net/ipv4/ip_forward

#where br-lan = LAN
  eth0.2 = WAN

Could anyone help me to write the proper NAT rules so that able to access
the internet.

Thanks,

On Mon, Aug 3, 2015 at 11:29 AM, John kerry kerry9...@gmail.com wrote:

Hello Guys,


It's working. Thanks a lot to all of you :)

On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:

The way to do this is to first forget about the factory reset problem and

configure the AP to do what you want (including any encryption)

then you can take the resulting file and put it into the build system so
that it becomes the 'factory default' settings.

Since you are not understanding how to configure the files from the
documentation, configure them from the GUI and then look at the
resulting
files.

David Lang


On Mon, 3 Aug 2015, John kerry wrote:

Hi All,



I created separate files directory and added network and wireless files
and
its working everything but still i am not able to use encryption wpa2.
Below is the my script.
config wifi-device  wifi0
   option type qcawifi
   option channel  auto
   option macaddr  00:03:7f:42:06:61
   option hwmode   11ng
   # REMOVE THIS LINE TO ENABLE WIFI:
   option disabled 0

config wifi-iface
   option device   wifi0
   option network  lan
   option mode ap
   option ssid CD-1
   option encryption psk2
   option key  CD-1

M I doing anything wrong?

Thanks,

On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

to make the config be there after a factory reset, you need

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread John kerry
Hi
This is my firewall file:

config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'lan'
option network 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'

config zone
option name 'wan'
option network 'wan'
option input 'REJECT'
option output 'ACCEPT'
option forward 'REJECT'
option masq '1'
option mtu_fix '1'

config forwarding
option src 'lan'
option dest 'wan'

config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'

config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'

config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fe80::/10'
option src_port '547'
option dest_ip 'fe80::/10'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'

config include
option path '/etc/firewall.user'

config include 'miniupnpd'
option type 'script'
option path '/usr/share/miniupnpd/firewall.include'
option family 'IPv4'
option reload '1'

On Tue, Aug 4, 2015 at 12:38 PM, Weedy weedy2...@gmail.com wrote:

 Is there something wrong with the default rules for your use case?

 Your WiFi interfaces are tagged LAN, things should just work.
 On 4 Aug 2015 00:07, John kerry kerry9...@gmail.com wrote:

 Hi,

 below is the /etc/config/network and /etc/config/wireless changes.

 */etc/config/network:*
 config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

 config interface 'lan'
 option ifname 'eth0.1 eth1'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.1.5'
 option netmask '255.255.255.0'

 config interface 'wan'
 option ifname 'eth0.2'
 option proto 'dhcp'

 config switch
 option name 'eth0'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth0'
 option vlan '1'
 option ports '0t 2 3 4 5'

 config switch_vlan
 option device 'eth0'
 option vlan '2'
 option ports '0t 1'

 config switch
 option name 'eth1'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth1'
 option vlan '1'
 option ports '0 1 2 3 4 5'



















 */etc/config/wireless:config wifi-device 'wifi0'option type
 'qcawifi'option channel 'auto'option macaddr
 '00:03:7f:42:06:61'option hwmode '11ng'option txpower
 '19'option htmode 'HT20'config wifi-ifaceoption device
 'wifi0'option network 'lan'option mode 'ap'option
 encryption 'psk2'option ssid 'Test_ap_1'option key *
 *'Test_ap_1'*

















 *config wifi-device 'wifi1'option type 'qcawifi'option
 channel 'auto'option macaddr '00:03:7f:42:06:62'option
 hwmode '11na'option txpower '23'option htmode 'HT20'config
 wifi-ifaceoption device 'wifi1'option network 'lan'
 option mode 'ap'option ssid 'Test_ap_2'option encryption
 'psk2'option key 'test_ap_2''*


 *Thanks,*

 On Tue, Aug 4, 2015 at 11:56 AM, David Lang da...@lang.hm wrote:

 can 

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread John kerry
Hi,

I am using ar71xx OpenWrt. I have connected internet connection to WAN port
and my PC to LAN. I have enabled the WiFi0. The LAN port static IP i am
able to open GUI and even my mobile i connected to Wifi AP and able to open
GUI in mobile. But I am not able to access internet on mobile which is
connected to wifi0 AP.

I have added below script under /etc/firewall.user file.
iptables ...flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables -A FORWARD -j ACCEPT -i br-lan -o eth0.2 -m state --state NEW
iptables -A FORWARD -m state --state ESTABLISHED,RELATED  -j ACCEPT
iptables -A POSTROUTING -t nat -o eth0.2 -j MASQUERADE
echo 1   /proc/sys/net/ipv4/ip_forward

#where br-lan = LAN
   eth0.2 = WAN

Could anyone help me to write the proper NAT rules so that able to access
the internet.

Thanks,

On Mon, Aug 3, 2015 at 11:29 AM, John kerry kerry9...@gmail.com wrote:

 Hello Guys,

 It's working. Thanks a lot to all of you :)

 On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:

 The way to do this is to first forget about the factory reset problem and
 configure the AP to do what you want (including any encryption)

 then you can take the resulting file and put it into the build system so
 that it becomes the 'factory default' settings.

 Since you are not understanding how to configure the files from the
 documentation, configure them from the GUI and then look at the resulting
 files.

 David Lang


 On Mon, 3 Aug 2015, John kerry wrote:

 Hi All,

 I created separate files directory and added network and wireless files
 and
 its working everything but still i am not able to use encryption wpa2.
 Below is the my script.
 config wifi-device  wifi0
option type qcawifi
option channel  auto
option macaddr  00:03:7f:42:06:61
option hwmode   11ng
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

 config wifi-iface
option device   wifi0
option network  lan
option mode ap
option ssid CD-1
option encryption psk2
option key  CD-1

 M I doing anything wrong?

 Thanks,

 On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

 to make the config be there after a factory reset, you need to put the
 changes into the image that you build.

 you already did this for /etc/config/network, do the same thing for
 /etc/config/wireless

 David Lang


 On Sun, 2 Aug 2015, John kerry wrote:

 Hi Leiten,


 I have one issue, after upgrading this firmware it will load wireless
 configuration with this changes, actually it should load when i do
 factory
 reset.

 Thanks,

 On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com
 wrote:

 Hi Leiten,


 Thank you so much, Its working :)

 On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com
 wrote:

 Hi,


 Don't answer to my e-mail only, you need to add openwrt-devel
 maillist
 to
 CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:

 Hi Leiten,

 I have added new files under and written below :
 vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless


 Use index in prefix of filename to set order of execution, so it'll
 be
 like '99-wireless'.


 #!/bin/sh
 #
 # Copyright (c) 2013 The Linux Foundation. All rights reserved.
 # Copyright (C) 2011 OpenWrt.org
 #

 [ -e /etc/config/wireless ]  exit 0


 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so
 your
 script just exit at this point. Remove this line.


 touch /etc/config/wireless

 uci set wireless.@wifi-device[0].disabled=0;
 uci set system.@system[0].hostname=test_ap
 uci set wireless.@wifi-iface[0].mode=ap
 uci set wireless.@wifi-iface[0].ssid=CD-2.4D
 uci set wireless.@wifi-iface[0].encryption=none
 uci set wireless.@wifi-iface[0].wds=1
 uci set wireless.radio0.disabled=0

 uci commit wireless

 exit 0

 and compile the source code using make V=s but still not changed
 default
 settings.

 Please help me to make it works.

 Thanks,


 On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com
 wrote:

 You can also use uci-defaults mechanism for your purpose. Just put

 script in base-files/etc/uci-defaults and set your preferrable
 parameters with uci and don't forget to 'exit 0' at the end of
 script,
 in elsecase it'll be run every time at boot ruining changes.

 2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:

 Hi,

 I am working on Ar71xx openWRT Luci project. By default the Wi-Fi
 is
 disabled and SSID is OpenWrt. I need to change the default
 settings.
 Could anyone help me to change the default settings.


 Best Regards,
 John

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread John kerry
Hi,

below is the /etc/config/network and /etc/config/wireless changes.

*/etc/config/network:*
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'
option ifname 'eth0.1 eth1'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.5'
option netmask '255.255.255.0'

config interface 'wan'
option ifname 'eth0.2'
option proto 'dhcp'

config switch
option name 'eth0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth0'
option vlan '1'
option ports '0t 2 3 4 5'

config switch_vlan
option device 'eth0'
option vlan '2'
option ports '0t 1'

config switch
option name 'eth1'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'eth1'
option vlan '1'
option ports '0 1 2 3 4 5'



















*/etc/config/wireless:config wifi-device 'wifi0'option type
'qcawifi'option channel 'auto'option macaddr
'00:03:7f:42:06:61'option hwmode '11ng'option txpower
'19'option htmode 'HT20'config wifi-ifaceoption device
'wifi0'option network 'lan'option mode 'ap'option
encryption 'psk2'option ssid 'Test_ap_1'option key *
*'Test_ap_1'*

















*config wifi-device 'wifi1'option type 'qcawifi'option
channel 'auto'option macaddr '00:03:7f:42:06:62'option
hwmode '11na'option txpower '23'option htmode 'HT20'config
wifi-ifaceoption device 'wifi1'option network 'lan'
option mode 'ap'option ssid 'Test_ap_2'option encryption
'psk2'option key 'test_ap_2''*


*Thanks,*

On Tue, Aug 4, 2015 at 11:56 AM, David Lang da...@lang.hm wrote:

 can you connect via a wired port?

 given that you've been changing /etc/config/network and
 /etc/config/wireless, could you show us what you ended up with there?

 David Lang


 On Tue, 4 Aug 2015, John kerry wrote:

 Hi,

 I am using ar71xx OpenWrt. I have connected internet connection to WAN
 port
 and my PC to LAN. I have enabled the WiFi0. The LAN port static IP i am
 able to open GUI and even my mobile i connected to Wifi AP and able to
 open
 GUI in mobile. But I am not able to access internet on mobile which is
 connected to wifi0 AP.

 I have added below script under /etc/firewall.user file.
 iptables ...flush
 iptables --table nat --flush
 iptables --delete-chain
 iptables --table nat --delete-chain
 iptables -A FORWARD -j ACCEPT -i br-lan -o eth0.2 -m state --state NEW
 iptables -A FORWARD -m state --state ESTABLISHED,RELATED  -j ACCEPT
 iptables -A POSTROUTING -t nat -o eth0.2 -j MASQUERADE
 echo 1   /proc/sys/net/ipv4/ip_forward

 #where br-lan = LAN
   eth0.2 = WAN

 Could anyone help me to write the proper NAT rules so that able to access
 the internet.

 Thanks,

 On Mon, Aug 3, 2015 at 11:29 AM, John kerry kerry9...@gmail.com wrote:

 Hello Guys,

 It's working. Thanks a lot to all of you :)

 On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:

 The way to do this is to first forget about the factory reset problem and
 configure the AP to do what you want (including any encryption)

 then you can take the resulting file and put it into the build system so
 that it becomes the 'factory default' settings.

 Since you are not understanding how to configure the files from the
 documentation, configure them from the GUI and then look at the
 resulting
 files.

 David Lang


 On Mon, 3 Aug 2015, John kerry wrote:

 Hi All,


 I created separate files directory and added network and wireless files
 and
 its working everything but still i am not able to use encryption wpa2.
 Below is the my script.
 config wifi-device  wifi0
option type qcawifi
option channel  auto
option macaddr  00:03:7f:42:06:61
option hwmode   11ng
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

 config wifi-iface
option device   wifi0
option network  lan
option mode ap
option ssid CD-1
option encryption psk2
option key  CD-1

 M I doing anything wrong?

 Thanks,

 On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

 to make the config be there after a factory reset, you need to put the

 changes into the image that you build.

 you already did this for /etc/config/network, do the same thing for
 /etc/config/wireless

 David Lang


 On Sun, 2 Aug 2015, John kerry wrote:

 Hi Leiten,


 I have one issue, after upgrading this firmware it will load wireless
 configuration with this changes, actually it should load when i do
 factory
 reset.

 Thanks,

 On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com
 wrote:

 Hi Leiten,


 

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread John kerry
Hi,

Its working, i am able to access internet but there is one problem,

When i scan the wireless devices, its gives the list of devices are there
nearby, then i connect anyone device, it will connect but my board wifi0
SSID name will change to that router which i connected. I mean LAN side
SSID should not change after connecting to WAN SSID.



On Tue, Aug 4, 2015 at 12:42 PM, John kerry kerry9...@gmail.com wrote:

 Hi
 This is my firewall file:

 config defaults
 option syn_flood '1'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'REJECT'

 config zone
 option name 'lan'
 option network 'lan'
 option input 'ACCEPT'
 option output 'ACCEPT'
 option forward 'REJECT'

 config zone
 option name 'wan'
 option network 'wan'
 option input 'REJECT'
 option output 'ACCEPT'
 option forward 'REJECT'
 option masq '1'
 option mtu_fix '1'

 config forwarding
 option src 'lan'
 option dest 'wan'

 config rule
 option name 'Allow-DHCP-Renew'
 option src 'wan'
 option proto 'udp'
 option dest_port '68'
 option target 'ACCEPT'
 option family 'ipv4'

 config rule
 option name 'Allow-Ping'
 option src 'wan'
 option proto 'icmp'
 option icmp_type 'echo-request'
 option family 'ipv4'
 option target 'ACCEPT'

 config rule
 option name 'Allow-DHCPv6'
 option src 'wan'
 option proto 'udp'
 option src_ip 'fe80::/10'
 option src_port '547'
 option dest_ip 'fe80::/10'
 option dest_port '546'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Input'
 option src 'wan'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 list icmp_type 'router-solicitation'
 list icmp_type 'neighbour-solicitation'
 list icmp_type 'router-advertisement'
 list icmp_type 'neighbour-advertisement'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config rule
 option name 'Allow-ICMPv6-Forward'
 option src 'wan'
 option dest '*'
 option proto 'icmp'
 list icmp_type 'echo-request'
 list icmp_type 'echo-reply'
 list icmp_type 'destination-unreachable'
 list icmp_type 'packet-too-big'
 list icmp_type 'time-exceeded'
 list icmp_type 'bad-header'
 list icmp_type 'unknown-header-type'
 option limit '1000/sec'
 option family 'ipv6'
 option target 'ACCEPT'

 config include
 option path '/etc/firewall.user'

 config include 'miniupnpd'
 option type 'script'
 option path '/usr/share/miniupnpd/firewall.include'
 option family 'IPv4'
 option reload '1'

 On Tue, Aug 4, 2015 at 12:38 PM, Weedy weedy2...@gmail.com wrote:

 Is there something wrong with the default rules for your use case?

 Your WiFi interfaces are tagged LAN, things should just work.
 On 4 Aug 2015 00:07, John kerry kerry9...@gmail.com wrote:

 Hi,

 below is the /etc/config/network and /etc/config/wireless changes.

 */etc/config/network:*
 config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

 config interface 'lan'
 option ifname 'eth0.1 eth1'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.1.5'
 option netmask '255.255.255.0'

 config interface 'wan'
 option ifname 'eth0.2'
 option proto 'dhcp'

 config switch
 option name 'eth0'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth0'
 option vlan '1'
 option ports '0t 2 3 4 5'

 config switch_vlan
 option device 'eth0'
 option vlan '2'
 option ports '0t 1'

 config switch
 option name 'eth1'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth1'
 option vlan '1'
 option ports '0 1 2 3 4 5'



















 */etc/config/wireless:config wifi-device 'wifi0'option type
 'qcawifi'option channel 'auto'option macaddr
 '00:03:7f:42:06:61'option hwmode '11ng'option txpower
 '19'option htmode 'HT20'config wifi-ifaceoption device
 'wifi0'option network 'lan'option mode 'ap'option
 encryption 'psk2'option ssid 'Test_ap_1'option key *
 

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread David Lang

can you connect via a wired port?

given that you've been changing /etc/config/network and /etc/config/wireless, 
could you show us what you ended up with there?


David Lang

On Tue, 4 Aug 2015, John kerry wrote:


Hi,

I am using ar71xx OpenWrt. I have connected internet connection to WAN port
and my PC to LAN. I have enabled the WiFi0. The LAN port static IP i am
able to open GUI and even my mobile i connected to Wifi AP and able to open
GUI in mobile. But I am not able to access internet on mobile which is
connected to wifi0 AP.

I have added below script under /etc/firewall.user file.
iptables ...flush
iptables --table nat --flush
iptables --delete-chain
iptables --table nat --delete-chain
iptables -A FORWARD -j ACCEPT -i br-lan -o eth0.2 -m state --state NEW
iptables -A FORWARD -m state --state ESTABLISHED,RELATED  -j ACCEPT
iptables -A POSTROUTING -t nat -o eth0.2 -j MASQUERADE
echo 1   /proc/sys/net/ipv4/ip_forward

#where br-lan = LAN
  eth0.2 = WAN

Could anyone help me to write the proper NAT rules so that able to access
the internet.

Thanks,

On Mon, Aug 3, 2015 at 11:29 AM, John kerry kerry9...@gmail.com wrote:


Hello Guys,

It's working. Thanks a lot to all of you :)

On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:


The way to do this is to first forget about the factory reset problem and
configure the AP to do what you want (including any encryption)

then you can take the resulting file and put it into the build system so
that it becomes the 'factory default' settings.

Since you are not understanding how to configure the files from the
documentation, configure them from the GUI and then look at the resulting
files.

David Lang


On Mon, 3 Aug 2015, John kerry wrote:

Hi All,


I created separate files directory and added network and wireless files
and
its working everything but still i am not able to use encryption wpa2.
Below is the my script.
config wifi-device  wifi0
   option type qcawifi
   option channel  auto
   option macaddr  00:03:7f:42:06:61
   option hwmode   11ng
   # REMOVE THIS LINE TO ENABLE WIFI:
   option disabled 0

config wifi-iface
   option device   wifi0
   option network  lan
   option mode ap
   option ssid CD-1
   option encryption psk2
   option key  CD-1

M I doing anything wrong?

Thanks,

On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

to make the config be there after a factory reset, you need to put the

changes into the image that you build.

you already did this for /etc/config/network, do the same thing for
/etc/config/wireless

David Lang


On Sun, 2 Aug 2015, John kerry wrote:

Hi Leiten,



I have one issue, after upgrading this firmware it will load wireless
configuration with this changes, actually it should load when i do
factory
reset.

Thanks,

On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com
wrote:

Hi Leiten,



Thank you so much, Its working :)

On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com
wrote:

Hi,



Don't answer to my e-mail only, you need to add openwrt-devel
maillist
to
CC or just answer to CC, in each case I'll receive message but also
everyone could see all discussion.

In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
wrote:

Hi Leiten,


I have added new files under and written below :
vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless



Use index in prefix of filename to set order of execution, so it'll
be
like '99-wireless'.


#!/bin/sh

#
# Copyright (c) 2013 The Linux Foundation. All rights reserved.
# Copyright (C) 2011 OpenWrt.org
#

[ -e /etc/config/wireless ]  exit 0



Here is the problem. When uci-defaults invoke scripts there's already
preconfiguration done and /etc/config/wireless already exists, so
your
script just exit at this point. Remove this line.


touch /etc/config/wireless


uci set wireless.@wifi-device[0].disabled=0;
uci set system.@system[0].hostname=test_ap
uci set wireless.@wifi-iface[0].mode=ap
uci set wireless.@wifi-iface[0].ssid=CD-2.4D
uci set wireless.@wifi-iface[0].encryption=none
uci set wireless.@wifi-iface[0].wds=1
uci set wireless.radio0.disabled=0

uci commit wireless

exit 0

and compile the source code using make V=s but still not changed
default
settings.

Please help me to make it works.

Thanks,


On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com
wrote:

You can also use uci-defaults mechanism for your purpose. Just put


script in base-files/etc/uci-defaults and set your preferrable
parameters with uci and don't forget to 'exit 0' at the end of
script,
in elsecase it'll be run every time at boot ruining changes.

2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:

Hi,


I am working on Ar71xx openWRT Luci project. By default the Wi-Fi
is
disabled and SSID is OpenWrt. I need to change the default
settings.
Could anyone help me to change the default settings.


Best Regards,
John


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-03 Thread Weedy
Is there something wrong with the default rules for your use case?

Your WiFi interfaces are tagged LAN, things should just work.
On 4 Aug 2015 00:07, John kerry kerry9...@gmail.com wrote:

 Hi,

 below is the /etc/config/network and /etc/config/wireless changes.

 */etc/config/network:*
 config interface 'loopback'
 option ifname 'lo'
 option proto 'static'
 option ipaddr '127.0.0.1'
 option netmask '255.0.0.0'

 config interface 'lan'
 option ifname 'eth0.1 eth1'
 option type 'bridge'
 option proto 'static'
 option ipaddr '192.168.1.5'
 option netmask '255.255.255.0'

 config interface 'wan'
 option ifname 'eth0.2'
 option proto 'dhcp'

 config switch
 option name 'eth0'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth0'
 option vlan '1'
 option ports '0t 2 3 4 5'

 config switch_vlan
 option device 'eth0'
 option vlan '2'
 option ports '0t 1'

 config switch
 option name 'eth1'
 option reset '1'
 option enable_vlan '1'

 config switch_vlan
 option device 'eth1'
 option vlan '1'
 option ports '0 1 2 3 4 5'



















 */etc/config/wireless:config wifi-device 'wifi0'option type
 'qcawifi'option channel 'auto'option macaddr
 '00:03:7f:42:06:61'option hwmode '11ng'option txpower
 '19'option htmode 'HT20'config wifi-ifaceoption device
 'wifi0'option network 'lan'option mode 'ap'option
 encryption 'psk2'option ssid 'Test_ap_1'option key *
 *'Test_ap_1'*

















 *config wifi-device 'wifi1'option type 'qcawifi'option
 channel 'auto'option macaddr '00:03:7f:42:06:62'option
 hwmode '11na'option txpower '23'option htmode 'HT20'config
 wifi-ifaceoption device 'wifi1'option network 'lan'
 option mode 'ap'option ssid 'Test_ap_2'option encryption
 'psk2'option key 'test_ap_2''*


 *Thanks,*

 On Tue, Aug 4, 2015 at 11:56 AM, David Lang da...@lang.hm wrote:

 can you connect via a wired port?

 given that you've been changing /etc/config/network and
 /etc/config/wireless, could you show us what you ended up with there?

 David Lang


 On Tue, 4 Aug 2015, John kerry wrote:

 Hi,

 I am using ar71xx OpenWrt. I have connected internet connection to WAN
 port
 and my PC to LAN. I have enabled the WiFi0. The LAN port static IP i am
 able to open GUI and even my mobile i connected to Wifi AP and able to
 open
 GUI in mobile. But I am not able to access internet on mobile which is
 connected to wifi0 AP.

 I have added below script under /etc/firewall.user file.
 iptables ...flush
 iptables --table nat --flush
 iptables --delete-chain
 iptables --table nat --delete-chain
 iptables -A FORWARD -j ACCEPT -i br-lan -o eth0.2 -m state --state NEW
 iptables -A FORWARD -m state --state ESTABLISHED,RELATED  -j ACCEPT
 iptables -A POSTROUTING -t nat -o eth0.2 -j MASQUERADE
 echo 1   /proc/sys/net/ipv4/ip_forward

 #where br-lan = LAN
   eth0.2 = WAN

 Could anyone help me to write the proper NAT rules so that able to access
 the internet.

 Thanks,

 On Mon, Aug 3, 2015 at 11:29 AM, John kerry kerry9...@gmail.com wrote:

 Hello Guys,

 It's working. Thanks a lot to all of you :)

 On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:

 The way to do this is to first forget about the factory reset problem
 and
 configure the AP to do what you want (including any encryption)

 then you can take the resulting file and put it into the build system
 so
 that it becomes the 'factory default' settings.

 Since you are not understanding how to configure the files from the
 documentation, configure them from the GUI and then look at the
 resulting
 files.

 David Lang


 On Mon, 3 Aug 2015, John kerry wrote:

 Hi All,


 I created separate files directory and added network and wireless
 files
 and
 its working everything but still i am not able to use encryption wpa2.
 Below is the my script.
 config wifi-device  wifi0
option type qcawifi
option channel  auto
option macaddr  00:03:7f:42:06:61
option hwmode   11ng
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

 config wifi-iface
option device   wifi0
option network  lan
option mode ap
option ssid CD-1
option encryption psk2
option key  CD-1

 M I doing anything wrong?

 Thanks,

 On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

 to make the config be there after a factory reset, you need to put the

 changes into the image that you build.

 you already did this for /etc/config/network, do the same thing for
 /etc/config/wireless

 David Lang


 On Sun, 2 Aug 2015, John kerry wrote:

 Hi Leiten,


 I have one 

Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hello Guys,

It's working. Thanks a lot to all of you :)

On Mon, Aug 3, 2015 at 10:43 AM, David Lang da...@lang.hm wrote:

 The way to do this is to first forget about the factory reset problem and
 configure the AP to do what you want (including any encryption)

 then you can take the resulting file and put it into the build system so
 that it becomes the 'factory default' settings.

 Since you are not understanding how to configure the files from the
 documentation, configure them from the GUI and then look at the resulting
 files.

 David Lang


 On Mon, 3 Aug 2015, John kerry wrote:

 Hi All,

 I created separate files directory and added network and wireless files
 and
 its working everything but still i am not able to use encryption wpa2.
 Below is the my script.
 config wifi-device  wifi0
option type qcawifi
option channel  auto
option macaddr  00:03:7f:42:06:61
option hwmode   11ng
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

 config wifi-iface
option device   wifi0
option network  lan
option mode ap
option ssid CD-1
option encryption psk2
option key  CD-1

 M I doing anything wrong?

 Thanks,

 On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

 to make the config be there after a factory reset, you need to put the
 changes into the image that you build.

 you already did this for /etc/config/network, do the same thing for
 /etc/config/wireless

 David Lang


 On Sun, 2 Aug 2015, John kerry wrote:

 Hi Leiten,


 I have one issue, after upgrading this firmware it will load wireless
 configuration with this changes, actually it should load when i do
 factory
 reset.

 Thanks,

 On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:

 Hi Leiten,


 Thank you so much, Its working :)

 On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

 Hi,


 Don't answer to my e-mail only, you need to add openwrt-devel maillist
 to
 CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:

 Hi Leiten,

 I have added new files under and written below :
 vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless


 Use index in prefix of filename to set order of execution, so it'll be
 like '99-wireless'.


 #!/bin/sh
 #
 # Copyright (c) 2013 The Linux Foundation. All rights reserved.
 # Copyright (C) 2011 OpenWrt.org
 #

 [ -e /etc/config/wireless ]  exit 0


 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so your
 script just exit at this point. Remove this line.


 touch /etc/config/wireless

 uci set wireless.@wifi-device[0].disabled=0;
 uci set system.@system[0].hostname=test_ap
 uci set wireless.@wifi-iface[0].mode=ap
 uci set wireless.@wifi-iface[0].ssid=CD-2.4D
 uci set wireless.@wifi-iface[0].encryption=none
 uci set wireless.@wifi-iface[0].wds=1
 uci set wireless.radio0.disabled=0

 uci commit wireless

 exit 0

 and compile the source code using make V=s but still not changed
 default
 settings.

 Please help me to make it works.

 Thanks,


 On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com
 wrote:

 You can also use uci-defaults mechanism for your purpose. Just put

 script in base-files/etc/uci-defaults and set your preferrable
 parameters with uci and don't forget to 'exit 0' at the end of
 script,
 in elsecase it'll be run every time at boot ruining changes.

 2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:

 Hi,

 I am working on Ar71xx openWRT Luci project. By default the Wi-Fi
 is
 disabled and SSID is OpenWrt. I need to change the default
 settings.
 Could anyone help me to change the default settings.


 Best Regards,
 John

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

 ___

 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

 ___

 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel





___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread N.Leiten
Hi,

Don't answer to my e-mail only, you need to add openwrt-devel maillist to CC or 
just answer to CC, in each case I'll receive message but also everyone could 
see all discussion.

In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry wrote:
 Hi Leiten,
 
 I have added new files under and written below :
 vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless

Use index in prefix of filename to set order of execution, so it'll be like 
'99-wireless'.

 
 #!/bin/sh
 #
 # Copyright (c) 2013 The Linux Foundation. All rights reserved.
 # Copyright (C) 2011 OpenWrt.org
 #
 
 [ -e /etc/config/wireless ]  exit 0

Here is the problem. When uci-defaults invoke scripts there's already 
preconfiguration done and /etc/config/wireless already exists, so your script 
just exit at this point. Remove this line.

 
 touch /etc/config/wireless
 
 uci set wireless.@wifi-device[0].disabled=0;
 uci set system.@system[0].hostname=test_ap
 uci set wireless.@wifi-iface[0].mode=ap
 uci set wireless.@wifi-iface[0].ssid=CD-2.4D
 uci set wireless.@wifi-iface[0].encryption=none
 uci set wireless.@wifi-iface[0].wds=1
 uci set wireless.radio0.disabled=0
 
 uci commit wireless
 
 exit 0
 
 and compile the source code using make V=s but still not changed default
 settings.
 
 Please help me to make it works.
 
 Thanks,
 
 
 On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:
 
  You can also use uci-defaults mechanism for your purpose. Just put
  script in base-files/etc/uci-defaults and set your preferrable
  parameters with uci and don't forget to 'exit 0' at the end of script,
  in elsecase it'll be run every time at boot ruining changes.
 
  2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:
   Hi,
  
   I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
   disabled and SSID is OpenWrt. I need to change the default settings.
   Could anyone help me to change the default settings.
  
  
   Best Regards,
   John
  
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  
  ___
  openwrt-devel mailing list
  openwrt-devel@lists.openwrt.org
  https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
 
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi Leiten,

Thank you so much, Its working :)

On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

 Hi,

 Don't answer to my e-mail only, you need to add openwrt-devel maillist to
 CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:
  Hi Leiten,
 
  I have added new files under and written below :
  vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless

 Use index in prefix of filename to set order of execution, so it'll be
 like '99-wireless'.

 
  #!/bin/sh
  #
  # Copyright (c) 2013 The Linux Foundation. All rights reserved.
  # Copyright (C) 2011 OpenWrt.org
  #
 
  [ -e /etc/config/wireless ]  exit 0

 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so your
 script just exit at this point. Remove this line.

 
  touch /etc/config/wireless
 
  uci set wireless.@wifi-device[0].disabled=0;
  uci set system.@system[0].hostname=test_ap
  uci set wireless.@wifi-iface[0].mode=ap
  uci set wireless.@wifi-iface[0].ssid=CD-2.4D
  uci set wireless.@wifi-iface[0].encryption=none
  uci set wireless.@wifi-iface[0].wds=1
  uci set wireless.radio0.disabled=0
 
  uci commit wireless
 
  exit 0
 
  and compile the source code using make V=s but still not changed default
  settings.
 
  Please help me to make it works.
 
  Thanks,
 
 
  On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:
 
   You can also use uci-defaults mechanism for your purpose. Just put
   script in base-files/etc/uci-defaults and set your preferrable
   parameters with uci and don't forget to 'exit 0' at the end of script,
   in elsecase it'll be run every time at boot ruining changes.
  
   2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:
Hi,
   
I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.
   
   
Best Regards,
John
   
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
   
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi Leiten,

I have one issue, after upgrading this firmware it will load wireless
configuration with this changes, actually it should load when i do factory
reset.

Thanks,

On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:

 Hi Leiten,

 Thank you so much, Its working :)

 On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

 Hi,

 Don't answer to my e-mail only, you need to add openwrt-devel maillist to
 CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:
  Hi Leiten,
 
  I have added new files under and written below :
  vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless

 Use index in prefix of filename to set order of execution, so it'll be
 like '99-wireless'.

 
  #!/bin/sh
  #
  # Copyright (c) 2013 The Linux Foundation. All rights reserved.
  # Copyright (C) 2011 OpenWrt.org
  #
 
  [ -e /etc/config/wireless ]  exit 0

 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so your
 script just exit at this point. Remove this line.

 
  touch /etc/config/wireless
 
  uci set wireless.@wifi-device[0].disabled=0;
  uci set system.@system[0].hostname=test_ap
  uci set wireless.@wifi-iface[0].mode=ap
  uci set wireless.@wifi-iface[0].ssid=CD-2.4D
  uci set wireless.@wifi-iface[0].encryption=none
  uci set wireless.@wifi-iface[0].wds=1
  uci set wireless.radio0.disabled=0
 
  uci commit wireless
 
  exit 0
 
  and compile the source code using make V=s but still not changed default
  settings.
 
  Please help me to make it works.
 
  Thanks,
 
 
  On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:
 
   You can also use uci-defaults mechanism for your purpose. Just put
   script in base-files/etc/uci-defaults and set your preferrable
   parameters with uci and don't forget to 'exit 0' at the end of script,
   in elsecase it'll be run every time at boot ruining changes.
  
   2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:
Hi,
   
I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.
   
   
Best Regards,
John
   
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
   
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel



___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread Weedy
On 2 Aug 2015 12:19, John kerry kerry9...@gmail.com wrote:

 Hi,

 I am using below uci script,

 vi target/linux/ar71xx/base-files/etc/uci-defaults/99-wireless

If you're building images yourself you might like to use files/ instead.

svn checkout/files/etc/config/wireless

You can dump any file you want in the finished image in there.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread Weedy
You seem to be having problems using uci-defaults. So forget that.

Copy the running/working/complete config file from your device into
files/etc/config/wireless.
You need to make the files directory. You can put anything in there.

weedy@HAF ~/projects/openwrt $ ls -al files/etc/config/
total 60
drwxr-xr-x 2 weedy weedy 4096 Jul 13 23:05 .
drwxr-xr-x 8 weedy weedy 4096 Jul 31 00:35 ..
-rw-r--r-- 1 weedy weedy  138 Jul 13 23:05 darkstat
-rw-r--r-- 1 weedy weedy  441 Jul 13 23:05 ddns
-rw-r--r-- 1 weedy weedy 1204 Jul 30 22:48 dhcp
-rw-r--r-- 1 weedy weedy  119 Jul 13 23:05 dropbear
-rw-r--r-- 1 weedy weedy 4290 Jul 13 23:05 firewall
-rw-r--r-- 1 weedy weedy   38 Jun 11  2013 netcheck
-rw-r--r-- 1 weedy weedy 1059 Jul 13 23:05 network
-rw-r--r-- 1 weedy weedy 1821 Jun 30 21:04 qos
-rw-r--r-- 1 weedy weedy  761 Jul 13 23:05 system
-rw-r--r-- 1 weedy weedy 2165 Jul 13 23:05 uhttpd
-rw-r--r-- 1 weedy weedy  639 Jul 13 23:05 upnpd
-rw-r--r-- 1 weedy weedy 1353 Jul 13 23:05 wireless
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi,

Sorry i didn't get, you mean to say i should not add files under

vi target/linux/ar71xx/base-files/etc/uci-defaults/99-wireless

Could you please explain.



On Mon, Aug 3, 2015 at 12:22 AM, Weedy weedy2...@gmail.com wrote:


 On 2 Aug 2015 12:19, John kerry kerry9...@gmail.com wrote:
 
  Hi,
 
  I am using below uci script,
 
  vi target/linux/ar71xx/base-files/etc/uci-defaults/99-wireless

 If you're building images yourself you might like to use files/ instead.

 svn checkout/files/etc/config/wireless

 You can dump any file you want in the finished image in there.

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread Weedy
make

On Sun, Aug 2, 2015 at 12:56 PM, John kerry kerry9...@gmail.com wrote:
 Hi,

 so i created directory as below  and copy the following files

 root@OpenWrt:/# ls -al files/etc/config/
 drwxr-xr-x2 root root 0 Jul 30 18:42 .
 drwxr-xr-x3 root root 0 Jul 30 18:35 ..
 -rw-r--r--1 root root  4045 Jul 30 18:42 ddns
 -rw-r--r--1 root root   885 Jul 30 18:41 dhcp
 -rw-r--r--1 root root  2148 Jul 30 18:41 firewall
 -rw-r--r--1 root root   763 Jul 30 18:41 network
 -rw-r--r--1 root root   646 Jul 30 18:42 upnpd
 -rw-r--r--1 root root   718 Jul 30 18:36 wireless

 but how i will link this into building image.




 2015-08-03 0:38 GMT+08:00 Weedy weedy2...@gmail.com:

 You seem to be having problems using uci-defaults. So forget that.

 Copy the running/working/complete config file from your device into
 files/etc/config/wireless.
 You need to make the files directory. You can put anything in there.

 weedy@HAF ~/projects/openwrt $ ls -al files/etc/config/
 total 60
 drwxr-xr-x 2 weedy weedy 4096 Jul 13 23:05 .
 drwxr-xr-x 8 weedy weedy 4096 Jul 31 00:35 ..
 -rw-r--r-- 1 weedy weedy  138 Jul 13 23:05 darkstat
 -rw-r--r-- 1 weedy weedy  441 Jul 13 23:05 ddns
 -rw-r--r-- 1 weedy weedy 1204 Jul 30 22:48 dhcp
 -rw-r--r-- 1 weedy weedy  119 Jul 13 23:05 dropbear
 -rw-r--r-- 1 weedy weedy 4290 Jul 13 23:05 firewall
 -rw-r--r-- 1 weedy weedy   38 Jun 11  2013 netcheck
 -rw-r--r-- 1 weedy weedy 1059 Jul 13 23:05 network
 -rw-r--r-- 1 weedy weedy 1821 Jun 30 21:04 qos
 -rw-r--r-- 1 weedy weedy  761 Jul 13 23:05 system
 -rw-r--r-- 1 weedy weedy 2165 Jul 13 23:05 uhttpd
 -rw-r--r-- 1 weedy weedy  639 Jul 13 23:05 upnpd
 -rw-r--r-- 1 weedy weedy 1353 Jul 13 23:05 wireless


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi,

See that i created files in console,

The main source code there is path :

package/base-files/files/etc/config/

under this now already two files are there, but if i see in console under
/etc/config it shows
rwxrwxr-x1 root root 0 Jan  1  1970 .
drwxrwxr-x1 root root 0 Jul 30 18:33 ..
-rw-rw-r--1 root root  4045 Jul 30 16:47 ddns
-rw-r--r--1 root root   885 Jul 30 18:08 dhcp
-rw-r--r--1 root root  1642 Jul 30  2015 dhcp6c
-rw-r--r--1 root root   134 Jul 30 18:09 dropbear
-rw-r--r--1 root root  2148 Jul 30 18:33 firewall
-rw-r--r--1 root root   645 Jul 30 18:33 luci
-rw-r--r--1 root root   131 Jul 30 18:44 mcproxy
-rw-r--r--1 root root   763 Jul 30 18:33 network
-rw-rw-r--1 root root89 Jul 30 16:47 pppoe
-rw-rw-r--1 root root  1773 Jul 30 16:47 qos
-rw-r--r--1 root root   652 Jul 30 18:49 radvd
-rw-r--r--1 root root   324 Jul 30 18:49 ripd
-rw-r--r--1 root root 0 Jul 30 18:33 sound
-rw-rw-r--1 root root   407 Jul 30 18:33 system
-rw-r--r--1 root root   128 Jul 30 18:33 ubootenv
-rw-r--r--1 root root   680 Jul 30 18:33 ucitrack
-rw-r--r--1 root root  2408 Jul 30 18:23 uhttpd
-rw-r--r--1 root root   646 Jul 30 18:33 upnpd

I am not getting where to create new directory and add this files.

Sorry I am totally new in this, It may be silly question please guide me.

Thanks,

On Mon, Aug 3, 2015 at 12:58 AM, Weedy weedy2...@gmail.com wrote:

 make

 On Sun, Aug 2, 2015 at 12:56 PM, John kerry kerry9...@gmail.com wrote:
  Hi,
 
  so i created directory as below  and copy the following files
 
  root@OpenWrt:/# ls -al files/etc/config/
  drwxr-xr-x2 root root 0 Jul 30 18:42 .
  drwxr-xr-x3 root root 0 Jul 30 18:35 ..
  -rw-r--r--1 root root  4045 Jul 30 18:42 ddns
  -rw-r--r--1 root root   885 Jul 30 18:41 dhcp
  -rw-r--r--1 root root  2148 Jul 30 18:41 firewall
  -rw-r--r--1 root root   763 Jul 30 18:41 network
  -rw-r--r--1 root root   646 Jul 30 18:42 upnpd
  -rw-r--r--1 root root   718 Jul 30 18:36 wireless
 
  but how i will link this into building image.
 
 
 
 
  2015-08-03 0:38 GMT+08:00 Weedy weedy2...@gmail.com:
 
  You seem to be having problems using uci-defaults. So forget that.
 
  Copy the running/working/complete config file from your device into
  files/etc/config/wireless.
  You need to make the files directory. You can put anything in there.
 
  weedy@HAF ~/projects/openwrt $ ls -al files/etc/config/
  total 60
  drwxr-xr-x 2 weedy weedy 4096 Jul 13 23:05 .
  drwxr-xr-x 8 weedy weedy 4096 Jul 31 00:35 ..
  -rw-r--r-- 1 weedy weedy  138 Jul 13 23:05 darkstat
  -rw-r--r-- 1 weedy weedy  441 Jul 13 23:05 ddns
  -rw-r--r-- 1 weedy weedy 1204 Jul 30 22:48 dhcp
  -rw-r--r-- 1 weedy weedy  119 Jul 13 23:05 dropbear
  -rw-r--r-- 1 weedy weedy 4290 Jul 13 23:05 firewall
  -rw-r--r-- 1 weedy weedy   38 Jun 11  2013 netcheck
  -rw-r--r-- 1 weedy weedy 1059 Jul 13 23:05 network
  -rw-r--r-- 1 weedy weedy 1821 Jun 30 21:04 qos
  -rw-r--r-- 1 weedy weedy  761 Jul 13 23:05 system
  -rw-r--r-- 1 weedy weedy 2165 Jul 13 23:05 uhttpd
  -rw-r--r-- 1 weedy weedy  639 Jul 13 23:05 upnpd
  -rw-r--r-- 1 weedy weedy 1353 Jul 13 23:05 wireless
 
 

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi,

so i created directory as below  and copy the following files

root@OpenWrt:/# ls -al files/etc/config/
drwxr-xr-x2 root root 0 Jul 30 18:42 .
drwxr-xr-x3 root root 0 Jul 30 18:35 ..
-rw-r--r--1 root root  4045 Jul 30 18:42 ddns
-rw-r--r--1 root root   885 Jul 30 18:41 dhcp
-rw-r--r--1 root root  2148 Jul 30 18:41 firewall
-rw-r--r--1 root root   763 Jul 30 18:41 network
-rw-r--r--1 root root   646 Jul 30 18:42 upnpd
-rw-r--r--1 root root   718 Jul 30 18:36 wireless

but how i will link this into building image.




2015-08-03 0:38 GMT+08:00 Weedy weedy2...@gmail.com:

 You seem to be having problems using uci-defaults. So forget that.

 Copy the running/working/complete config file from your device into
 files/etc/config/wireless.
 You need to make the files directory. You can put anything in there.

 weedy@HAF ~/projects/openwrt $ ls -al files/etc/config/
 total 60
 drwxr-xr-x 2 weedy weedy 4096 Jul 13 23:05 .
 drwxr-xr-x 8 weedy weedy 4096 Jul 31 00:35 ..
 -rw-r--r-- 1 weedy weedy  138 Jul 13 23:05 darkstat
 -rw-r--r-- 1 weedy weedy  441 Jul 13 23:05 ddns
 -rw-r--r-- 1 weedy weedy 1204 Jul 30 22:48 dhcp
 -rw-r--r-- 1 weedy weedy  119 Jul 13 23:05 dropbear
 -rw-r--r-- 1 weedy weedy 4290 Jul 13 23:05 firewall
 -rw-r--r-- 1 weedy weedy   38 Jun 11  2013 netcheck
 -rw-r--r-- 1 weedy weedy 1059 Jul 13 23:05 network
 -rw-r--r-- 1 weedy weedy 1821 Jun 30 21:04 qos
 -rw-r--r-- 1 weedy weedy  761 Jul 13 23:05 system
 -rw-r--r-- 1 weedy weedy 2165 Jul 13 23:05 uhttpd
 -rw-r--r-- 1 weedy weedy  639 Jul 13 23:05 upnpd
 -rw-r--r-- 1 weedy weedy 1353 Jul 13 23:05 wireless

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread Donk
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA256

A how-to for create your own firmware with your own default files:
http://wiki.openwrt.org/doc/howto/obtain.firmware.generate
-BEGIN PGP SIGNATURE-
Version: GnuPG v1
Comment: Using GnuPG with Thunderbird - http://www.enigmail.net/

iQIcBAEBCAAGBQJVvlEPAAoJEFk5KK+nQki4+4kQAIzZDpsGuDvRv+EVJMOTWEkR
wnxnCY5SccLMkBKi3S14Klm8z/gnScUpPmv628tUeg6E8MBdCSLCHdShF9Y/cNtO
TgEEo5zUi0dmRSGkGZhctsyKr3u3ua2tXSDPm5cBLVJuWQmXZB04kabky94uCFOH
bTQ51tgFMw6MZvQ1gZ4PRwlNjHl2LqrvZ1j6m3iPFykJbpMBtwD101XiXNfHU/SQ
zzGR5KHWGrATMmb1Gq7v5ibC4yrjYJSk96+psTlbh+0jZTCB5EydsfWcXz1s6/uG
N9cAa6CZk2K1QkpvdXNSG37BzKlSm9XYxKfJTHx/tBlBDyk+7GwvVEMCho2M5umb
jrozr6FqB9wdkFZAiFfOqBzN+TyyTnYZB6UgTrREEj7XKr7/MLV8oGJWnObz8wVI
Yg/X6UqcV7Ev7capldbpfsZzh3HQMybM8ps3X6u7FvJwCn5PpFskYrfN+z6PW+Lx
/MxG03YoolIQAgQA7mrnn0p1XygAzNZaq44z7cerx1B/8ts1LTd4mQrn0QQHaQn1
I9ab7P599C5dzAUEn0IvmDr7CL+H6CWonRYoi/Tt+FbuGhobITvh1Aq8cXlnsXtw
PWxxKNrz2ibNbIIIOIKf29I7R30kIklh2tKBbemI7Z222L3HIb6gur/ZMgccPmua
pQeba8dGEjlyQNQtuaTN
=21X+
-END PGP SIGNATURE-
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi,

I am using below uci script,

vi target/linux/ar71xx/base-files/etc/uci-defaults/99-wireless

#copyright (c) 2013 The Linux Foundation. All rights reserved.
# Copyright (C) 2011 OpenWrt.org
#


touch /etc/config/wireless

uci set wireless.@wifi-device[0].disabled=0;
uci set system.@system[0].hostname=OpenWrt
uci set wireless.@wifi-iface[0].mode=ap
uci set wireless.@wifi-iface[0].ssid=Home_plug_1
uci set wireless.@wifi-iface[0].encryption=wpa2
uci set wireless.@wifi-iface[0].key=Home_plug_1
#uci set wireless.radio0.disabled=0

uci set wireless.@wifi-device[1].disabled=0;
uci set wireless.@wifi-iface[1].mode=ap
uci set wireless.@wifi-iface[1].ssid=Home_plug_2
uci set wireless.@wifi-iface[1].encryption=wpa2
uci set wireless.@wifi-iface[1].key=Home_plug_2
#uci set wireless.radio0.disabled=0


uci commit wireless

exit 0

The default SSID is working but not able to set encryption type and key.

Thanks,


On Sun, Aug 2, 2015 at 9:19 PM, John kerry kerry9...@gmail.com wrote:

 Hi Leiten,

 I have one issue, after upgrading this firmware it will load wireless
 configuration with this changes, actually it should load when i do factory
 reset.

 Thanks,

 On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:

 Hi Leiten,

 Thank you so much, Its working :)

 On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

 Hi,

 Don't answer to my e-mail only, you need to add openwrt-devel maillist
 to CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:
  Hi Leiten,
 
  I have added new files under and written below :
  vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless

 Use index in prefix of filename to set order of execution, so it'll be
 like '99-wireless'.

 
  #!/bin/sh
  #
  # Copyright (c) 2013 The Linux Foundation. All rights reserved.
  # Copyright (C) 2011 OpenWrt.org
  #
 
  [ -e /etc/config/wireless ]  exit 0

 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so your
 script just exit at this point. Remove this line.

 
  touch /etc/config/wireless
 
  uci set wireless.@wifi-device[0].disabled=0;
  uci set system.@system[0].hostname=test_ap
  uci set wireless.@wifi-iface[0].mode=ap
  uci set wireless.@wifi-iface[0].ssid=CD-2.4D
  uci set wireless.@wifi-iface[0].encryption=none
  uci set wireless.@wifi-iface[0].wds=1
  uci set wireless.radio0.disabled=0
 
  uci commit wireless
 
  exit 0
 
  and compile the source code using make V=s but still not changed
 default
  settings.
 
  Please help me to make it works.
 
  Thanks,
 
 
  On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:
 
   You can also use uci-defaults mechanism for your purpose. Just put
   script in base-files/etc/uci-defaults and set your preferrable
   parameters with uci and don't forget to 'exit 0' at the end of
 script,
   in elsecase it'll be run every time at boot ruining changes.
  
   2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:
Hi,
   
I am working on Ar71xx openWRT Luci project. By default the Wi-Fi
 is
disabled and SSID is OpenWrt. I need to change the default
 settings.
Could anyone help me to change the default settings.
   
   
Best Regards,
John
   
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
   
   ___
   openwrt-devel mailing list
   openwrt-devel@lists.openwrt.org
   https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel
  
 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread David Lang
to make the config be there after a factory reset, you need to put the changes 
into the image that you build.


you already did this for /etc/config/network, do the same thing for 
/etc/config/wireless


David Lang

On Sun, 2 Aug 2015, John kerry wrote:


Hi Leiten,

I have one issue, after upgrading this firmware it will load wireless
configuration with this changes, actually it should load when i do factory
reset.

Thanks,

On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:


Hi Leiten,

Thank you so much, Its working :)

On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:


Hi,

Don't answer to my e-mail only, you need to add openwrt-devel maillist to
CC or just answer to CC, in each case I'll receive message but also
everyone could see all discussion.

In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
wrote:

Hi Leiten,

I have added new files under and written below :
vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless


Use index in prefix of filename to set order of execution, so it'll be
like '99-wireless'.



#!/bin/sh
#
# Copyright (c) 2013 The Linux Foundation. All rights reserved.
# Copyright (C) 2011 OpenWrt.org
#

[ -e /etc/config/wireless ]  exit 0


Here is the problem. When uci-defaults invoke scripts there's already
preconfiguration done and /etc/config/wireless already exists, so your
script just exit at this point. Remove this line.



touch /etc/config/wireless

uci set wireless.@wifi-device[0].disabled=0;
uci set system.@system[0].hostname=test_ap
uci set wireless.@wifi-iface[0].mode=ap
uci set wireless.@wifi-iface[0].ssid=CD-2.4D
uci set wireless.@wifi-iface[0].encryption=none
uci set wireless.@wifi-iface[0].wds=1
uci set wireless.radio0.disabled=0

uci commit wireless

exit 0

and compile the source code using make V=s but still not changed default
settings.

Please help me to make it works.

Thanks,


On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:


You can also use uci-defaults mechanism for your purpose. Just put
script in base-files/etc/uci-defaults and set your preferrable
parameters with uci and don't forget to 'exit 0' at the end of script,
in elsecase it'll be run every time at boot ruining changes.

2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:

Hi,

I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.


Best Regards,
John

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread John kerry
Hi All,

I created separate files directory and added network and wireless files and
its working everything but still i am not able to use encryption wpa2.
Below is the my script.
config wifi-device  wifi0
option type qcawifi
option channel  auto
option macaddr  00:03:7f:42:06:61
option hwmode   11ng
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0

config wifi-iface
option device   wifi0
option network  lan
option mode ap
option ssid CD-1
option encryption psk2
option key  CD-1

M I doing anything wrong?

Thanks,

On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:

 to make the config be there after a factory reset, you need to put the
 changes into the image that you build.

 you already did this for /etc/config/network, do the same thing for
 /etc/config/wireless

 David Lang


 On Sun, 2 Aug 2015, John kerry wrote:

 Hi Leiten,

 I have one issue, after upgrading this firmware it will load wireless
 configuration with this changes, actually it should load when i do factory
 reset.

 Thanks,

 On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:

 Hi Leiten,

 Thank you so much, Its working :)

 On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

 Hi,

 Don't answer to my e-mail only, you need to add openwrt-devel maillist
 to
 CC or just answer to CC, in each case I'll receive message but also
 everyone could see all discussion.

 In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
 wrote:

 Hi Leiten,

 I have added new files under and written below :
 vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless


 Use index in prefix of filename to set order of execution, so it'll be
 like '99-wireless'.


 #!/bin/sh
 #
 # Copyright (c) 2013 The Linux Foundation. All rights reserved.
 # Copyright (C) 2011 OpenWrt.org
 #

 [ -e /etc/config/wireless ]  exit 0


 Here is the problem. When uci-defaults invoke scripts there's already
 preconfiguration done and /etc/config/wireless already exists, so your
 script just exit at this point. Remove this line.


 touch /etc/config/wireless

 uci set wireless.@wifi-device[0].disabled=0;
 uci set system.@system[0].hostname=test_ap
 uci set wireless.@wifi-iface[0].mode=ap
 uci set wireless.@wifi-iface[0].ssid=CD-2.4D
 uci set wireless.@wifi-iface[0].encryption=none
 uci set wireless.@wifi-iface[0].wds=1
 uci set wireless.radio0.disabled=0

 uci commit wireless

 exit 0

 and compile the source code using make V=s but still not changed
 default
 settings.

 Please help me to make it works.

 Thanks,


 On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:

 You can also use uci-defaults mechanism for your purpose. Just put
 script in base-files/etc/uci-defaults and set your preferrable
 parameters with uci and don't forget to 'exit 0' at the end of script,
 in elsecase it'll be run every time at boot ruining changes.

 2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:

 Hi,

 I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
 disabled and SSID is OpenWrt. I need to change the default settings.
 Could anyone help me to change the default settings.


 Best Regards,
 John

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel




___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-02 Thread David Lang
The way to do this is to first forget about the factory reset problem and 
configure the AP to do what you want (including any encryption)


then you can take the resulting file and put it into the build system so that it 
becomes the 'factory default' settings.


Since you are not understanding how to configure the files from the 
documentation, configure them from the GUI and then look at the resulting files.


David Lang

On Mon, 3 Aug 2015, John kerry wrote:


Hi All,

I created separate files directory and added network and wireless files and
its working everything but still i am not able to use encryption wpa2.
Below is the my script.
config wifi-device  wifi0
   option type qcawifi
   option channel  auto
   option macaddr  00:03:7f:42:06:61
   option hwmode   11ng
   # REMOVE THIS LINE TO ENABLE WIFI:
   option disabled 0

config wifi-iface
   option device   wifi0
   option network  lan
   option mode ap
   option ssid CD-1
   option encryption psk2
   option key  CD-1

M I doing anything wrong?

Thanks,

On Mon, Aug 3, 2015 at 6:40 AM, David Lang da...@lang.hm wrote:


to make the config be there after a factory reset, you need to put the
changes into the image that you build.

you already did this for /etc/config/network, do the same thing for
/etc/config/wireless

David Lang


On Sun, 2 Aug 2015, John kerry wrote:

Hi Leiten,


I have one issue, after upgrading this firmware it will load wireless
configuration with this changes, actually it should load when i do factory
reset.

Thanks,

On Sun, Aug 2, 2015 at 3:45 PM, John kerry kerry9...@gmail.com wrote:

Hi Leiten,


Thank you so much, Its working :)

On Sun, Aug 2, 2015 at 3:12 PM, N.Leiten nicklei...@gmail.com wrote:

Hi,


Don't answer to my e-mail only, you need to add openwrt-devel maillist
to
CC or just answer to CC, in each case I'll receive message but also
everyone could see all discussion.

In email dated Воскресенье - 02 августа 2015 12:54:32 user John kerry
wrote:


Hi Leiten,

I have added new files under and written below :
vi target/linux/ar71xx/base-files/etc/uci-defaults/wireless



Use index in prefix of filename to set order of execution, so it'll be
like '99-wireless'.



#!/bin/sh
#
# Copyright (c) 2013 The Linux Foundation. All rights reserved.
# Copyright (C) 2011 OpenWrt.org
#

[ -e /etc/config/wireless ]  exit 0



Here is the problem. When uci-defaults invoke scripts there's already
preconfiguration done and /etc/config/wireless already exists, so your
script just exit at this point. Remove this line.



touch /etc/config/wireless

uci set wireless.@wifi-device[0].disabled=0;
uci set system.@system[0].hostname=test_ap
uci set wireless.@wifi-iface[0].mode=ap
uci set wireless.@wifi-iface[0].ssid=CD-2.4D
uci set wireless.@wifi-iface[0].encryption=none
uci set wireless.@wifi-iface[0].wds=1
uci set wireless.radio0.disabled=0

uci commit wireless

exit 0

and compile the source code using make V=s but still not changed
default
settings.

Please help me to make it works.

Thanks,


On Sat, Aug 1, 2015 at 4:38 PM, N.Leiten nicklei...@gmail.com wrote:

You can also use uci-defaults mechanism for your purpose. Just put

script in base-files/etc/uci-defaults and set your preferrable
parameters with uci and don't forget to 'exit 0' at the end of script,
in elsecase it'll be run every time at boot ruining changes.

2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:


Hi,

I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.


Best Regards,
John

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___

openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___

openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel





___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-08-01 Thread N.Leiten
You can also use uci-defaults mechanism for your purpose. Just put
script in base-files/etc/uci-defaults and set your preferrable
parameters with uci and don't forget to 'exit 0' at the end of script,
in elsecase it'll be run every time at boot ruining changes.

2015-07-31 12:08 GMT+03:00 John kerry kerry9...@gmail.com:
 Hi,

 I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
 disabled and SSID is OpenWrt. I need to change the default settings.
 Could anyone help me to change the default settings.


 Best Regards,
 John

 ___
 openwrt-devel mailing list
 openwrt-devel@lists.openwrt.org
 https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel

___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-07-31 Thread David Lang

/etc/config/wireless

On Fri, 31 Jul 2015, N.Leiten wrote:


Date: Fri, 31 Jul 2015 12:32:14 +0300
From: N.Leiten nicklei...@gmail.com
To: openwrt-devel@lists.openwrt.org
Subject: Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

In email dated Пятница - 31 июля 2015 17:08:23 user John kerry wrote:

Hi,

I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.


Best Regards,
John


You can look at mac80211 package, in 
package/kernel/mac80211/files/lib/wifi/mac80211.sh there's function 
detect_mac80211() and at the end of file there's block of default wifi 
parameters.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


[OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-07-31 Thread John kerry
Hi,

I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
disabled and SSID is OpenWrt. I need to change the default settings.
Could anyone help me to change the default settings.


Best Regards,
John
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel


Re: [OpenWrt-Devel] Change OpenWrt Wifi default settings

2015-07-31 Thread N.Leiten
In email dated Пятница - 31 июля 2015 17:08:23 user John kerry wrote:
 Hi,
 
 I am working on Ar71xx openWRT Luci project. By default the Wi-Fi is
 disabled and SSID is OpenWrt. I need to change the default settings.
 Could anyone help me to change the default settings.
 
 
 Best Regards,
 John

You can look at mac80211 package, in 
package/kernel/mac80211/files/lib/wifi/mac80211.sh there's function 
detect_mac80211() and at the end of file there's block of default wifi 
parameters.
___
openwrt-devel mailing list
openwrt-devel@lists.openwrt.org
https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-devel