Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-27 Thread bhays
Przemek and Mindaugas:

Thanks for the clarification.  I missed the finer point when Mindaugas
first discussed "ADS", but then the second paragraph said
"I propose to rename RDD from ADT ..."
as you noticed, I thought we were still talking about just "ADS".

So, yes, I would agree ADSADT is better than also supporting "ADT".
It might be good to find out how many people might be impacted,
but if it's just a question of changing the rddSetDefault line,
and if an obvious error is generated after the change that makes
it clear what the programmer should fix if he missed the change, 
then it sounds like a good fix.

As for the additional idea of removing "ADS" and:
> so in fact you had over four years to update your code
> Was it my mistake that I left "ADS" RDD?

I never really thought that being "left for backward compatibility"
implied a suggestion for changing code.
For me personally, just changing the rddSetDefault line is no problem.
BUT I wouldn't recommend breaking users' apps if the only reason is
to remove the backwards compatibility for cleanliness sake.
Though I go back that many years, thousands of new users may very
well have used that syntax up to present day, especially in light 
of the lack of significant documentation for rddads.
Have new users been directed to examples or guidelines that suggest
the newer syntax and *not* using "ADS"?

One more point: to "reduce" the ADS RDDs to *just* the specific rdds
MAY imply the temptation to remove the ability to just set the FileType
from one to the other (e.g. from ADT to DBF and back again) in the same
workarea.  If this is where we're headed, it would break a LOT of 
people's code and probably create a lot of grief for people who just 
get a Harbour update, then suddenly find themselves having to debug and 
fixup potentially large amounts of code.
I'm not arguing for clinging to bad design, but concern for our users'
sanity is a virtue.

Thanks for all your work,

--
Brian Hays


> -Original Message-
> From: Przemysław Czerpak [mailto:dru...@acn.waw.pl]
> Sent: Thursday, November 26, 2009 8:16 PM
> To: Xharbour-Developers List; Harbour Project Main Developer List.
> Subject: Re: [xHarbour-developers] RDD: ADT -> ADSADT
> 
> On Thu, 26 Nov 2009, Brian Hays wrote:
> 
> Hi Brian,
> 
> > The addition of specific "sub-rdds" of ADSCDX etc. came years later.
> > I, and I imagine a lot of other people who started using rddads
> > early on, never had a need to explicitly use those other rdds by
> name.
> 
> Any one who has code like:
> 
>proc copy_table( cSrc, cSrcRDD, cDst, cDstRDD )
>   use (cSrc) via (cSrcRDD)
>   copy to (cDst) via (cDstRDD)
>return
> 
> designed to work with different RDDs in Clipper, needs ADS* RDDs to
> port
> his code without introducing unnecessary and incompatible with other
> RDDs
> modifications which are necessary to make working code like:
>copy_table( "sales", "ADSCDX", "sales2", "ADSADT" )
> 
> In fact "ADS" RDD can be safely removed because the only one reason
> to keep it are user habbits but ADS* RDDs cannot be removed without
> reducing important functionality - working VIA clause in different
> command/functions which allows to easy switch between RDDs.
> 
> > Are you suggesting that we should now have to re-write our apps by
> > converting ADS to ADSADT?  But wait: IIRC (I'm not sure),
> > ADSCDX is the DEFAULT for ADS, so converting it to ADT doesn't
> > really make sense, does it?
> > If you're suggesting a change that would require people to change
> > code that's been growing for 9 years, there needs to be a stronger
> > reason to force the change than just compatibility with other rdds,
> > IMHO.
> > Or am I missing something?
> 
> Mindaugas wants to change only "ADT" RDD to "ADSADT" and you are not
> using it so it's not a problem for you.
> Anyhow you wrote that it's 9 years code.
> In the past I left "ADS" RDD only for backward compatibility:
> 
>2005-09-02 20:10 UTC+0200 Przemyslaw Czerpak
> (druzus/at/priv.onet.pl)
>+ register ADS as three separate RDDs: ADSNTX, ADSCDX, ADT
>  (ADS RDD left for backward compatibility) -  they do not
>  need to set table type.
> 
> so in fact you had over four years to update your code.
> This suggests that forcing some modification immediately is better
> because four years ago it was only 5 years code ;-)
> Was it my mistake that I left "ADS" RDD?
> 
> best regards,
> Przemek
> 
> ---

Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread Przemysław Czerpak
On Thu, 26 Nov 2009, Brian Hays wrote:

Hi Brian,

> The addition of specific "sub-rdds" of ADSCDX etc. came years later.
> I, and I imagine a lot of other people who started using rddads
> early on, never had a need to explicitly use those other rdds by name.

Any one who has code like:

   proc copy_table( cSrc, cSrcRDD, cDst, cDstRDD )
  use (cSrc) via (cSrcRDD)
  copy to (cDst) via (cDstRDD)
   return

designed to work with different RDDs in Clipper, needs ADS* RDDs to port
his code without introducing unnecessary and incompatible with other RDDs
modifications which are necessary to make working code like:
   copy_table( "sales", "ADSCDX", "sales2", "ADSADT" )

In fact "ADS" RDD can be safely removed because the only one reason
to keep it are user habbits but ADS* RDDs cannot be removed without
reducing important functionality - working VIA clause in different
command/functions which allows to easy switch between RDDs.

> Are you suggesting that we should now have to re-write our apps by
> converting ADS to ADSADT?  But wait: IIRC (I'm not sure), 
> ADSCDX is the DEFAULT for ADS, so converting it to ADT doesn't 
> really make sense, does it?
> If you're suggesting a change that would require people to change
> code that's been growing for 9 years, there needs to be a stronger
> reason to force the change than just compatibility with other rdds,
> IMHO.
> Or am I missing something?

Mindaugas wants to change only "ADT" RDD to "ADSADT" and you are not
using it so it's not a problem for you.
Anyhow you wrote that it's 9 years code.
In the past I left "ADS" RDD only for backward compatibility:

   2005-09-02 20:10 UTC+0200 Przemyslaw Czerpak (druzus/at/priv.onet.pl)
   + register ADS as three separate RDDs: ADSNTX, ADSCDX, ADT
 (ADS RDD left for backward compatibility) -  they do not
 need to set table type.

so in fact you had over four years to update your code.
This suggests that forcing some modification immediately is better
because four years ago it was only 5 years code ;-)
Was it my mistake that I left "ADS" RDD?

best regards,
Przemek

--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers


Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread Mindaugas Kavaliauskas
Hi,


bhays wrote:
> I'm not sure why you're making the suggestion.
> Right now, the original "ADS" is an all-inclusive rdd that lets
> you switch the file type to cdx, ntx, etc. in different workareas.
> 
> The addition of specific "sub-rdds" of ADSCDX etc. came years later.
> 
> I, and I imagine a lot of other people who started using rddads
> early on, never had a need to explicitly use those other rdds by name.
> 
> Are you suggesting that we should now have to re-write our apps by
> converting ADS to ADSADT? 

No, I want to make you convert from:
   RDDSETDEFAULT("ADT")
to
   RDDSETDEFAULT("ADSADT")

I'm also talking about Harbour code, not sure that names has xHarbour's
ADS RDD. But, it is not nice to have:
   DBUSEAREA(.T., "ADT", ...)
   ? RDDNAME() // prints ADSADT, not ADT!

So, my suggestion is to convert ADT to ADSADT.

"ADS" RDD remains unchanged.


Regards,
Mindaugas



--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers


Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread bhays
Mindaugas:

If you intended it for the Harbour project, please keep this xHarbour group
and/or me in the conversation.  I have continued to work with Viktor
and Przemek to keep rddads coordinated as much as possible in both projects.

It may be worthwhile to forward my concerns to the other project too,
or please inform me if I'm incorrect on any points.

Thanks,

--
Brian Hays


> -Original Message-
> From: Mindaugas Kavaliauskas [mailto:dbto...@dbtopas.lt]
> Sent: Thursday, November 26, 2009 6:29 PM
> To: Xharbour-Developers List
> Subject: Re: [xHarbour-developers] RDD: ADT -> ADSADT
> 
> Mindaugas Kavaliauskas wrote:
> > current ADS RDD is registered using names: ADS, ADT, ADSCDX, ADSNTX,
> > ...
> 
> Sorry, wrong mailing list.
> 
> 
> Regards,
> Mindaugas
> 
> ---
> ---
> Let Crystal Reports handle the reporting - Free Crystal Reports 2008
> 30-Day
> trial. Simplify your report design, integration and deployment - and
> focus on
> what you do best, core application coding. Discover what's new with
> Crystal Reports now.  http://p.sf.net/sfu/bobj-july
> ___
> xHarbour-developers mailing list
> xHarbour-developers@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/xharbour-developers
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.426 / Virus Database: 270.14.67/2506 - Release Date:
> 11/26/09 09:10:00


--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers


Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread bhays
Mindaugas:

I'm not sure why you're making the suggestion.
Right now, the original "ADS" is an all-inclusive rdd that lets
you switch the file type to cdx, ntx, etc. in different workareas.

The addition of specific "sub-rdds" of ADSCDX etc. came years later.

I, and I imagine a lot of other people who started using rddads
early on, never had a need to explicitly use those other rdds by name.

Are you suggesting that we should now have to re-write our apps by
converting ADS to ADSADT?  But wait: IIRC (I'm not sure), 
ADSCDX is the DEFAULT for ADS, so converting it to ADT doesn't 
really make sense, does it?

If you're suggesting a change that would require people to change
code that's been growing for 9 years, there needs to be a stronger
reason to force the change than just compatibility with other rdds,
IMHO.

Or am I missing something?

--
Brian Hays


> -Original Message-
> From: Mindaugas Kavaliauskas [mailto:dbto...@dbtopas.lt]
> Sent: Thursday, November 26, 2009 4:55 PM
> To: Xharbour-Developers List
> Subject: [xHarbour-developers] RDD: ADT -> ADSADT
> 
> Hi,
> 
> 
> current ADS RDD is registered using names: ADS, ADT, ADSCDX, ADSNTX,
> ADSVFP. RDD SYSNAME method (i.e., RDDNAME()) can return one of the
> following values: ADSADT, ADSCDX, ADSNTX, ADSVFP. Original C level ADS
> defines for different database types are: ADS_CDX, ADS_NTX, ADS_VFP,
> ADT_ADT.
> 
> I propose to rename RDD from ADT to ADSADT, thus making both correct
> RDDNAME() return value and to be compatible with naming scheme of
> another ADS RDDs. Any objections?
> 
> 
> Regards,
> Mindaugas
> 
> ---
> ---
> Let Crystal Reports handle the reporting - Free Crystal Reports 2008
> 30-Day
> trial. Simplify your report design, integration and deployment - and
> focus on
> what you do best, core application coding. Discover what's new with
> Crystal Reports now.  http://p.sf.net/sfu/bobj-july
> ___
> xHarbour-developers mailing list
> xHarbour-developers@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/xharbour-developers
> No virus found in this incoming message.
> Checked by AVG - www.avg.com
> Version: 8.5.426 / Virus Database: 270.14.67/2506 - Release Date:
> 11/26/09 09:10:00


--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers


Re: [xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread Mindaugas Kavaliauskas
Mindaugas Kavaliauskas wrote:
> current ADS RDD is registered using names: ADS, ADT, ADSCDX, ADSNTX, 
> ...

Sorry, wrong mailing list.


Regards,
Mindaugas

--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers


[xHarbour-developers] RDD: ADT -> ADSADT

2009-11-26 Thread Mindaugas Kavaliauskas
Hi,


current ADS RDD is registered using names: ADS, ADT, ADSCDX, ADSNTX, 
ADSVFP. RDD SYSNAME method (i.e., RDDNAME()) can return one of the 
following values: ADSADT, ADSCDX, ADSNTX, ADSVFP. Original C level ADS 
defines for different database types are: ADS_CDX, ADS_NTX, ADS_VFP, 
ADT_ADT.

I propose to rename RDD from ADT to ADSADT, thus making both correct 
RDDNAME() return value and to be compatible with naming scheme of 
another ADS RDDs. Any objections?


Regards,
Mindaugas

--
Let Crystal Reports handle the reporting - Free Crystal Reports 2008 30-Day 
trial. Simplify your report design, integration and deployment - and focus on 
what you do best, core application coding. Discover what's new with
Crystal Reports now.  http://p.sf.net/sfu/bobj-july
___
xHarbour-developers mailing list
xHarbour-developers@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/xharbour-developers