Integrated: 8251466: test/java/io/File/GetXSpace.java fails on Windows with mapped network drives.

2022-01-27 Thread Andrey Turbanov
On Thu, 20 Jan 2022 21:10:39 GMT, Andrey Turbanov wrote: > Test `test/java/io/File/GetXSpace.java` always failed on my machine with this > output: > > --System.out:(12/489)-- > --- Testing df > C:/Programs/cygwin64 292848636 49695320 243153316 17% / > D: 59672 59672 0 100% /cygd

Re: RFR: 8251466: test/java/io/File/GetXSpace.java fails on Windows with mapped network drives.

2022-01-27 Thread Andrey Turbanov
On Thu, 20 Jan 2022 21:10:39 GMT, Andrey Turbanov wrote: > Test `test/java/io/File/GetXSpace.java` always failed on my machine with this > output: > > --System.out:(12/489)-- > --- Testing df > C:/Programs/cygwin64 292848636 49695320 243153316 17% / > D: 59672 59672 0 100% /cygd

Re: RFR: JDK-8280534: Enable compile-time doclint reference checking [v2]

2022-01-27 Thread Joe Darcy
> The changes in this PR on top of the out-for-review changes in > https://git.openjdk.java.net/jdk/pull/7222 allow compile-time doclint > checking to be enabled in all JDK modules. > > Typically, a @SuppressWarnings("doclint:refernce") annotation is added to > declaration with javadoc blocks t

Re: Fix proposal for bug JDK-8221642

2022-01-27 Thread Mandy Chung
I see how NPE is thrown (from `AccessibleObject::setAccessible` and `trySetAccessible`).  The proper fix should follow the rule as the access check that it can set the accessible flag only on public members of a public type that is exported unconditionally. The fix is straight forward but invo

Re: RFR: JDK-8280534: Enable compile-time doclint reference checking

2022-01-27 Thread Mandy Chung
On Wed, 26 Jan 2022 20:05:07 GMT, Joe Darcy wrote: > The changes in this PR on top of the out-for-review changes in > https://git.openjdk.java.net/jdk/pull/7222 allow compile-time doclint > checking to be enabled in all JDK modules. > > Typically, a @SuppressWarnings("doclint:refernce") annota

Re: RFR: 8279598: Provide adapter from RandomGenerator to Random [v2]

2022-01-27 Thread liach
On Fri, 28 Jan 2022 00:36:57 GMT, Yasser Bazzi wrote: >> Suggest: >> >>> Returns an instance of {@link java.util.Random} based on this {@code >>> RandomGenerator}. >>> If this generator is already an instance of {@code Random}, it is returned. >>> Otherwise, this method >>> returns an instance

Re: RFR: 8279598: Provide adapter from RandomGenerator to Random

2022-01-27 Thread Yasser Bazzi
On Wed, 26 Jan 2022 17:49:42 GMT, Stuart Marks wrote: > This will also need a regression test. It should have a case to ensure that > `asRandom` returns `this` if it's already an instance of `Random`. Maybe also > a simple case of shuffling a list, similar to the gist. Also see if there are >

Integrated: JDK-8280744: Allow SuppressWarnings to be used in all declaration contexts

2022-01-27 Thread Joe Darcy
On Wed, 26 Jan 2022 21:22:58 GMT, Joe Darcy wrote: > The SuppressWarnings annotation type is declared have multiple targets, > including modules; however, "package" is left off of its target list. As > package-info file are another kind of declaration where a compiler could give > warnings, al

Re: RFR: 8279598: Provide adapter from RandomGenerator to Random [v2]

2022-01-27 Thread Yasser Bazzi
On Wed, 26 Jan 2022 17:31:27 GMT, Stuart Marks wrote: >> Yasser Bazzi has updated the pull request incrementally with four additional >> commits since the last revision: >> >> - make sure setseed its initialized and throw >> - remove tabs >> - Change name of function from wrapRandom to wrap

Re: RFR: 8279598: Provide adapter from RandomGenerator to Random [v2]

2022-01-27 Thread Yasser Bazzi
On Wed, 26 Jan 2022 17:43:09 GMT, Stuart Marks wrote: >> Is something like this better? >> /** >> * Returns a {@link java.util.Random} from this {@link >> java.util.RandomGenerator}. >> * The resulting Random acts in all respects except that setSeed is not >> available. >> * >>

Re: RFR: 8279598: Provide adapter from RandomGenerator to Random [v2]

2022-01-27 Thread Yasser Bazzi
> Hi, could i get a review on this implementation proposed by Stuart Marks, i > decided to use the > https://docs.oracle.com/en/java/javase/17/docs/api/java.base/java/util/random/RandomGenerator.html > interface to create the default method `asRandom()` that wraps around the > newer algorithms

Re: RFR: JDK-8280744: Allow SuppressWarnings to be used in package declarations [v5]

2022-01-27 Thread Joe Darcy
> The SuppressWarnings annotation type is declared have multiple targets, > including modules; however, "package" is left off of its target list. As > package-info file are another kind of declaration where a compiler could give > warnings, allowing SuppressWarnings in that case is reasonable. W

Re: RFR: JDK-8280534: Enable compile-time doclint reference checking

2022-01-27 Thread Joe Darcy
On Fri, 28 Jan 2022 00:04:34 GMT, Naoto Sato wrote: > Looks fine. Nit: some files need copyright year updates. Acknowledged; I'll run a copyright update script before pushing (I tend to run that close to pushing to avoid spurious, if minor, merge conflicts). Thanks. - PR: https://

Re: RFR: JDK-8280534: Enable compile-time doclint reference checking

2022-01-27 Thread Naoto Sato
On Wed, 26 Jan 2022 20:05:07 GMT, Joe Darcy wrote: > The changes in this PR on top of the out-for-review changes in > https://git.openjdk.java.net/jdk/pull/7222 allow compile-time doclint > checking to be enabled in all JDK modules. > > Typically, a @SuppressWarnings("doclint:refernce") annota

Re: RFR: JDK-8280744: Allow SuppressWarnings to be used in package declarations [v4]

2022-01-27 Thread Iris Clark
On Thu, 27 Jan 2022 23:27:54 GMT, Joe Darcy wrote: >> The SuppressWarnings annotation type is declared have multiple targets, >> including modules; however, "package" is left off of its target list. As >> package-info file are another kind of declaration where a compiler could >> give warnings

Re: RFR: JDK-8280744: Allow SuppressWarnings to be used in package declarations [v4]

2022-01-27 Thread Joe Darcy
> The SuppressWarnings annotation type is declared have multiple targets, > including modules; however, "package" is left off of its target list. As > package-info file are another kind of declaration where a compiler could give > warnings, allowing SuppressWarnings in that case is reasonable. W

Integrated: JDK-8270476: Make floating-point test infrastructure more lambda and method reference friendly

2022-01-27 Thread Joe Darcy
On Tue, 25 Jan 2022 21:40:15 GMT, Joe Darcy wrote: > Update the java.lang.{Math, StrictMath} regression test helper library to > accept method references. This allows the test programs to be DRY-er as the > inputs to the method under test don't have to be repeated. The float test > method were

Re: RFR: JDK-8270476: Make floating-point test infrastructure more lambda and method reference friendly [v2]

2022-01-27 Thread Brian Burkhalter
On Wed, 26 Jan 2022 00:20:07 GMT, Joe Darcy wrote: >> Update the java.lang.{Math, StrictMath} regression test helper library to >> accept method references. This allows the test programs to be DRY-er as the >> inputs to the method under test don't have to be repeated. The float test >> method

Re: RFR: JDK-8270476: Make floating-point test infrastructure more lambda and method reference friendly [v3]

2022-01-27 Thread Joe Darcy
> Update the java.lang.{Math, StrictMath} regression test helper library to > accept method references. This allows the test programs to be DRY-er as the > inputs to the method under test don't have to be repeated. The float test > method were not updated due to limitations in type inference if

Re: RFR: JDK-8270476: Make floating-point test infrastructure more lambda and method reference friendly [v2]

2022-01-27 Thread Brian Burkhalter
On Wed, 26 Jan 2022 00:20:07 GMT, Joe Darcy wrote: >> Update the java.lang.{Math, StrictMath} regression test helper library to >> accept method references. This allows the test programs to be DRY-er as the >> inputs to the method under test don't have to be repeated. The float test >> method

Re: RFR: JDK-8270476: Make floating-point test infrastructure more lambda and method reference friendly [v2]

2022-01-27 Thread Brian Burkhalter
On Wed, 26 Jan 2022 00:20:07 GMT, Joe Darcy wrote: >> Update the java.lang.{Math, StrictMath} regression test helper library to >> accept method references. This allows the test programs to be DRY-er as the >> inputs to the method under test don't have to be repeated. The float test >> method

Re: Additional Date-Time Formats

2022-01-27 Thread Stephen Colebourne
On Thu, 27 Jan 2022 at 19:23, Naoto Sato wrote: > Now come to think of it, I came up with the draft based on `ofPattern()` > methods. One of them is a overload method that takes a Locale argument. > Why is it so? There is a case for the Locale on the static method (as a convenience, and to remind

Re: RFR: JDK-8280745: Allow SuppressWarnings to be used in package declarations [v3]

2022-01-27 Thread Joe Darcy
> The SuppressWarnings annotation type is declared have multiple targets, > including modules; however, "package" is left off of its target list. As > package-info file are another kind of declaration where a compiler could give > warnings, allowing SuppressWarnings in that case is reasonable. W

Re: RFR: JDK-8277795: ldap connection timeout not honoured under contention [v3]

2022-01-27 Thread Rob McKenna
On Tue, 25 Jan 2022 15:30:46 GMT, Mark Sheppard wrote: >> yes a redeclaration of timeout with a type long across the component >> would be a consistent approach, also > > so just to clarify, we're not taking the approach to homogenise the timeout > declarations, throughout the component, to

Re: Additional Date-Time Formats

2022-01-27 Thread Naoto Sato
Hi Stephen, On 1/27/22 1:00 AM, Stephen Colebourne wrote: Hi, This would be a useful addition. Some comments: There is no need for the method overload that takes Locale. The other similar methods all operate using the locale of the formatter, and have this Javadoc: * The locale is determ

Re: RFR: JDK-8280745: Allow SuppressWarnings to be used in package declarations [v2]

2022-01-27 Thread Joe Darcy
On Thu, 27 Jan 2022 18:54:06 GMT, Joe Darcy wrote: >> The SuppressWarnings annotation type is declared have multiple targets, >> including modules; however, "package" is left off of its target list. As >> package-info file are another kind of declaration where a compiler could >> give warnings

Re: RFR: JDK-8280745: Allow SuppressWarnings to be used in package declarations [v2]

2022-01-27 Thread Joe Darcy
> The SuppressWarnings annotation type is declared have multiple targets, > including modules; however, "package" is left off of its target list. As > package-info file are another kind of declaration where a compiler could give > warnings, allowing SuppressWarnings in that case is reasonable. W

Re: JarIndex not following the specification

2022-01-27 Thread Daniel Fuchs
Hi Tobias, Regardless of whether this is a bug or not, JarIndex has been disabled by default in JDK 18, in the hope to eventually remove it in the future. See https://bugs.openjdk.java.net/browse/JDK-8273473 best regards, -- daniel On 27/01/2022 18:41, Tobias Stadler wrote: Hello everyone,

Re: RFR: 8279842: HTTPS Channel Binding support for Java GSS/Kerberos [v12]

2022-01-27 Thread Daniel Fuchs
On Thu, 27 Jan 2022 18:05:25 GMT, Michael McMahon wrote: >> Hi, >> >> This change adds Channel Binding Token (CBT) support to HTTPS >> (java.net.HttpsURLConnection) when used with the Negotiate (SPNEGO, >> Kerberos) authentication scheme. When enabled, the implementation >> preemptively inclu

Re: RFR: 8279842: HTTPS Channel Binding support for Java GSS/Kerberos [v10]

2022-01-27 Thread Michael McMahon
On Thu, 27 Jan 2022 16:47:52 GMT, Daniel Fuchs wrote: >> It's `java.net.SocketException: Unexpected end of file from server`. Does >> not include any CBT words so don't know if it's worth parsing. > > Thanks. Then it would be better to catch only `SocketException` here rather > than `Exception`

Re: RFR: 8279842: HTTPS Channel Binding support for Java GSS/Kerberos [v12]

2022-01-27 Thread Michael McMahon
> Hi, > > This change adds Channel Binding Token (CBT) support to HTTPS > (java.net.HttpsURLConnection) when used with the Negotiate (SPNEGO, Kerberos) > authentication scheme. When enabled, the implementation preemptively includes > a CBT with authentication requests over Kerberos. The feature

Re: RFR: 8279842: HTTPS Channel Binding support for Java GSS/Kerberos [v10]

2022-01-27 Thread Daniel Fuchs
On Wed, 26 Jan 2022 19:00:14 GMT, Weijun Wang wrote: >> test/jdk/sun/security/krb5/auto/HttpsCB.java line 201: >> >>> 199: return reader.readLine().equals(CONTENT); >>> 200: } catch (Exception e) { >>> 201: return false; >> >> Should we log that we have received

Re: Fix proposal for bug JDK-8221642

2022-01-27 Thread Mandy Chung
Hi Andreas, What methods are you calling that throws NPE?  Do you have the stack trace to share? The spec of AccessibleObject was updated for JDK-8221530 if there is no caller frame when calling from JNI: "The check when invoked by JNI code with no Java class on the stack only succeeds if

Re: RFR: 8279842: HTTPS Channel Binding support for Java GSS/Kerberos [v11]

2022-01-27 Thread Michael McMahon
> Hi, > > This change adds Channel Binding Token (CBT) support to HTTPS > (java.net.HttpsURLConnection) when used with the Negotiate (SPNEGO, Kerberos) > authentication scheme. When enabled, the implementation preemptively includes > a CBT with authentication requests over Kerberos. The feature

Withdrawn: JDK-8277375: jdeps errors on a class path with a file path with no permission

2022-01-27 Thread duke
On Wed, 24 Nov 2021 01:12:01 GMT, Mandy Chung wrote: > This changes jdeps -cp to ignore files/directories with no permission to > access. This is consistent with the runtime behavior. This pull request has been closed without being integrated. - PR: https://git.openjdk.java.net/j

Re: Additional Date-Time Formats

2022-01-27 Thread Stephen Colebourne
Hi, This would be a useful addition. Some comments: There is no need for the method overload that takes Locale. The other similar methods all operate using the locale of the formatter, and have this Javadoc: * The locale is determined from the formatter. The formatter returned directly by