Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Mike Trahearn via Development
To Volker's point: I also mentioned in my post that Qt Quick never had a Triangle. Or Circle. Or any other primitive shapes. It has come up before that the use of ShapePath is one solution for such cases, but that also it isn't the most performant. To that end I would recommend this thread

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Lars Knoll via Development
> On 22 Dec 2023, at 17:48, Giuseppe D'Angelo via Development > wrote: > > Il 22/12/23 17:08, Pierre-Yves Siret ha scritto: >> I wouldn't want a radii grouped property just because of its name. >> I much prefer writing topLeftRadius: 10 than radii.topLeft: 10. >> The pedantic latin syntax

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Giuseppe D'Angelo via Development
Il 22/12/23 17:08, Pierre-Yves Siret ha scritto: I wouldn't want a radii grouped property just because of its name. I much prefer writing topLeftRadius: 10 than radii.topLeft: 10. The pedantic latin syntax doesn't help with the readability. Maybe that's just because I am not a native English

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Pierre-Yves Siret
Le ven. 22 déc. 2023 à 14:19, André Somers a écrit : > The point I wanted to raise was that having four separate properties isn't > ideal, and that we could give ourselves a lot of room for improvement by > having a `corners` grouped property that can contain more than just a > single real value

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Volker Hilsheimer via Development
> On 22 Dec 2023, at 13:59, Lars Knoll via Development > wrote: > >> >> On 22 Dec 2023, at 13:54, Tor Arne Vestbø via Development >> wrote: >> >>> On 22 Dec 2023, at 13:20, Giuseppe D'Angelo via Development >>> wrote: >>> >>> Il 22/12/23 11:15, André Somers ha scritto: I can see

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread André Somers
On 22-12-2023 14:12, Tor Arne Vestbø wrote: On 22 Dec 2023, at 13:59, André Somers wrote: And what type would the radius property return then? I guess it would have to be the grouped type. But that would break all code that currently creates a binding on radius expecting it to be a real.

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Tor Arne Vestbø via Development
On 22 Dec 2023, at 13:59, André Somers wrote: And what type would the radius property return then? I guess it would have to be the grouped type. But that would break all code that currently creates a binding on radius expecting it to be a real. True, that would not work too well. The

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread kde
Hi, my biggest gripe is actually the fact that -1 denotes "no specific radius". Right now if you assign a negative radius it will effectively clamp to zero, so you can easily assign radius: magicValue - otherValue without worrying about it doing weird things. Or use an animation on it. With

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Tor Arne Vestbø via Development
On 22 Dec 2023, at 13:59, Lars Knoll wrote: You don't often get email from l...@knoll.priv.no. Learn why this is important On 22 Dec 2023, at 13:54, Tor Arne Vestbø via Development wrote: On 22 Dec 2023, at 13:20,

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Lars Knoll via Development
> On 22 Dec 2023, at 13:54, Tor Arne Vestbø via Development > wrote: > >> On 22 Dec 2023, at 13:20, Giuseppe D'Angelo via Development >> wrote: >> >> Il 22/12/23 11:15, André Somers ha scritto: >>> I can see two options. The simplest option is to have a `radii` >>> property, which is a

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread André Somers
On 22-12-2023 13:54, Tor Arne Vestbø via Development wrote: On 22 Dec 2023, at 13:20, Giuseppe D'Angelo via Development wrote: Il 22/12/23 11:15, André Somers ha scritto: I can see two options. The simplest option is to have a `radii` property, which is a grouped property containing the

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Tor Arne Vestbø via Development
On 22 Dec 2023, at 13:54, Tor Arne Vestbø wrote: We can change the `radius` property from a qreal into a group property with left/rigth/top/bottom, similar to anchors. We can detect in the setRadius setter if the incoming argument is a real, and apply that to all of the corners. That would

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread André Somers
On 22-12-2023 13:20, Giuseppe D'Angelo via Development wrote: Il 22/12/23 11:15, André Somers ha scritto: I can see two options. The simplest option is to have a `radii` property, which is a grouped property containing the `topLeft`, `topRight`, `bottomLeft` and `bottomRight` properties as a

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Tor Arne Vestbø via Development
> On 22 Dec 2023, at 13:20, Giuseppe D'Angelo via Development > wrote: > > Il 22/12/23 11:15, André Somers ha scritto: >> I can see two options. The simplest option is to have a `radii` >> property, which is a grouped property containing the `topLeft`, >> `topRight`, `bottomLeft` and

Re: [Development] 6.7 FF vs. C++20 comparisons

2023-12-22 Thread Volker Hilsheimer via Development
> On 17 Dec 2023, at 14:16, Marc Mutz via Development > wrote: > > On 16.12.23 10:20, apoenitz wrote: >> Recently there were two serious regression on the Qt side due to "just using >> string views" (which would also be formally permitted), and I've seen now a >> patch that changes a map to a

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Giuseppe D'Angelo via Development
Il 22/12/23 11:15, André Somers ha scritto: I can see two options. The simplest option is to have a `radii` property, which is a grouped property containing the `topLeft`, `topRight`, `bottomLeft` and `bottomRight` properties as a floating point value as we have now. I think that would be

Re: [Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread Mike Trahearn via Development
+1 for tidying up the API in the manner suggested. But a welcome addition - thanks to Matthias Rauter.and Mitch Curtis - who I would be asking about the group properties in the first instance. - which I already did 7 months ago...

[Development] QML Rectangle corner radius API for Qt 6.7

2023-12-22 Thread André Somers
Hi, Starting from 6.7 we'll have separate corner radii for the corners of a Rectangle. Nice, very welcome! https://doc-snapshots.qt.io/qt6-6.7/qml-qtquick-rectangle.html Unfortunately, the API looks a bit clunky and not ready for further extension. Would it not be better to use a grouped

[Development] [Announce] Qt 5.15.12 Opensource released

2023-12-22 Thread List for announcements regarding Qt releases and development via Announce via Development
Hi all, we have released Qt 5.15.12 opensource today: * release note: https://code.qt.io/cgit/qt/qtreleasenotes.git/about/qt/5.15.12/release-note.md * source packages in download.qt.io: * https://download.qt.io/official_releases/qt/5.15/5.15.12/ *