Re: [Mesa-dev] [PATCH 3/5] glsl: Add parameter to .equals() to ignore an IR type.

2014-01-11 Thread Matt Turner
On Thu, Jan 9, 2014 at 11:09 AM, Ian Romanick wrote: > On 01/08/2014 12:43 PM, Matt Turner wrote: >> Only implemented for ir_swizzles currently, but perhaps will be useful > > And ir_texture? Whoops. >> for other IR types in the future. >> --- >> src/glsl/ir.h | 14 +-- >> src/

Re: [Mesa-dev] [PATCH 0/40] Implement GL_ARB_viewport_array

2014-01-11 Thread Kenneth Graunke
On 01/10/2014 05:44 PM, Ian Romanick wrote: > (Sent after the fact... sorry.) > > This represents a medling of GL_ARB_viewport_array code written by > Courtney Goeltzenleuchter (LunarG) and myself over the last couple > months. It implements all of the core Mesa code for the extension and > enabl

Re: [Mesa-dev] [PATCH 10/40] mesa: Update viewport state for viewport_array

2014-01-11 Thread Kenneth Graunke
On 01/10/2014 05:40 PM, Ian Romanick wrote: [snip] > diff --git a/src/mesa/main/get.c b/src/mesa/main/get.c > index e5240b1..99b91d0 100644 > --- a/src/mesa/main/get.c > +++ b/src/mesa/main/get.c > @@ -113,6 +113,7 @@ enum value_type { > TYPE_FLOATN_3, > TYPE_FLOATN_4, > TYPE_DOUBLEN, >

Re: [Mesa-dev] [PATCH 08/40] mesa: Update gl_scissor_attrib to support ARB_viewport_array

2014-01-11 Thread Kenneth Graunke
On 01/10/2014 05:40 PM, Ian Romanick wrote: [snip] > diff --git a/src/mesa/swrast/s_context.c b/src/mesa/swrast/s_context.c > index fdf9b37..9e1faa9 100644 > --- a/src/mesa/swrast/s_context.c > +++ b/src/mesa/swrast/s_context.c > @@ -61,7 +61,7 @@ _swrast_update_rasterflags( struct gl_context *ctx

[Mesa-dev] [Bug 73512] [clover] mesa.icd. should contain full path

2014-01-11 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=73512 Igor Gnatenko changed: What|Removed |Added Attachment #91885|0 |1 is obsolete|

[Mesa-dev] [PATCH] opencl: improved auto-gen .icd

2014-01-11 Thread Igor Gnatenko
>From 5b2bf87f1238e44150492a39f5db0ae90d59459b Mon Sep 17 00:00:00 2001 From: Igor Gnatenko Date: Sun, 12 Jan 2014 02:09:16 +0400 Subject: [PATCH] opencl: improved auto-gen .icd v2: Use @OPENCL_VERSION@:0 for library replace /etc with @sysconfdir@ macros Reported-by: Fabian Deutsch Referenc

[Mesa-dev] [Bug 73512] [clover] mesa.icd. should contain full path

2014-01-11 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=73512 Igor Gnatenko changed: What|Removed |Added Attachment #91884|0 |1 is obsolete|

Re: [Mesa-dev] [PATCH 20/40] mesa: Set all viewports from _mesa_Viewport and _mesa_DepthRange

2014-01-11 Thread Kenneth Graunke
On 01/10/2014 05:40 PM, Ian Romanick wrote: > From: Ian Romanick > > In _mesa_Viewport and _mesa_DepthRange, make sure that > ctx->Driver.Viewport is only called once instead of once per viewport or > depth range. > > Signed-off-by: Ian Romanick > --- > src/mesa/main/viewport.c | 30 ++

Re: [Mesa-dev] [PATCH] i965: Ensure that all necessary state is re-emitted if we run out of aperture.

2014-01-11 Thread Kenneth Graunke
On 01/10/2014 07:34 PM, Paul Berry wrote: > Prior to this patch, if we ran out of aperture space during > brw_try_draw_prims(), we would rewind the batch buffer pointer > (potentially throwing some state that may have been emitted by > brw_upload_state()), flush the batch, and then try again. Howe

[Mesa-dev] [Bug 73512] [clover] mesa.icd. should contain full path

2014-01-11 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=73512 Igor Gnatenko changed: What|Removed |Added CC||i.gnatenko.br...@gmail.com -- You are r

[Mesa-dev] [Bug 73512] [clover] mesa.icd. should contain full path

2014-01-11 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=73512 --- Comment #1 from Igor Gnatenko --- Created attachment 91884 --> https://bugs.freedesktop.org/attachment.cgi?id=91884&action=edit 0001-opencl-improved-auto-gen-.icd.patch I've not checked this patch. Checking. -- You are receiving this mai

Re: [Mesa-dev] [RFC] Code de-duplication across classic mesa/gallium

2014-01-11 Thread Kenneth Graunke
On 01/11/2014 07:39 AM, Emil Velikov wrote: > Hello list, > > As you already know with the inception of gallium a lot of the classic > mesa code was copied over to gallium/auxiliary for multitude of reasons. > > Recently I came across a handful of cases where classic mesa has become > more robust

[Mesa-dev] [Bug 73512] New: [clover] mesa.icd. should contain full path

2014-01-11 Thread bugzilla-daemon
https://bugs.freedesktop.org/show_bug.cgi?id=73512 Priority: medium Bug ID: 73512 Assignee: mesa-dev@lists.freedesktop.org Summary: [clover] mesa.icd. should contain full path Severity: normal Classification: Unclassified OS:

Re: [Mesa-dev] code de-duplication and non-pci support v2

2014-01-11 Thread Rob Clark
On Sat, Jan 11, 2014 at 11:54 AM, Emil Velikov wrote: > This is an updated series of Rob's patches > > * The introduction of the util library is separated from the > de-duplication. > * Each commit targets individual part of mesa and it should > build/work regardless of build system/options. > * H

Re: [Mesa-dev] [RFC] Code de-duplication across classic mesa/gallium

2014-01-11 Thread Marek Olšák
I think it's a great idea. I once suggested this on IRC, but my preferred file location was src/util. Either is okay with me though. Marek On Sat, Jan 11, 2014 at 4:39 PM, Emil Velikov wrote: > Hello list, > > As you already know with the inception of gallium a lot of the classic > mesa code w

Re: [Mesa-dev] Removing exec_list iterators

2014-01-11 Thread Matt Turner
Looks good to me. Reviewed-by: Matt Turner ___ mesa-dev mailing list mesa-dev@lists.freedesktop.org http://lists.freedesktop.org/mailman/listinfo/mesa-dev

[Mesa-dev] [PATCH] gallium/rtasm: add support for SELinux

2014-01-11 Thread Emil Velikov
Implementation is identical to the one used by classic mesa, and prevent driver segfault when mmap() fails. Bugzilla: https://bugs.freedesktop.org/show_bug.cgi?id=73473 Signed-off-by: Emil Velikov Cc: 9.1 9.2 10.0 --- According to #gentoo-hardened people this is not the optimal solution and one

[Mesa-dev] [PATCH 08/10] pci_ids: no not include loader.h

2014-01-11 Thread Emil Velikov
As per original approach by Rob, each user of the loader lib should include loader.h and the pci_id_driver_map.h header will be used exclusively by the loader. Added back the include guard __IS_LOADER and removed no longer needed include folder in the scons build. Signed-off-by: Emil Velikov ---

[Mesa-dev] [PATCH 07/10] egl_dri2: use loader util lib

2014-01-11 Thread Emil Velikov
Signed-off-by: Emil Velikov --- src/egl/drivers/dri2/Android.mk | 4 +- src/egl/drivers/dri2/Makefile.am| 4 +- src/egl/drivers/dri2/common.c | 144 src/egl/drivers/dri2/egl_dri2.h | 5 -- src/egl/drivers/dri2/platform_andro

[Mesa-dev] [PATCH 05/10] st/egl: use loader util lib

2014-01-11 Thread Emil Velikov
Signed-off-by: Emil Velikov --- src/gallium/state_trackers/egl/Makefile.am | 1 + src/gallium/state_trackers/egl/SConscript | 3 ++ src/gallium/state_trackers/egl/drm/native_drm.c | 44 ++--- 3 files changed, 6 insertions(+), 42 deletions(-) diff --git a/src/gall

[Mesa-dev] [PATCH 03/10] gbm: use the loader util lib

2014-01-11 Thread Emil Velikov
Additionally this commit removes the following exported functions _gbm_udev_device_new_from_fd() _gbm_fd_get_device_name() _gbm_log() All three were erroneously marked as exported since their inception. Neither of them has ever been a part of the API thus there should be no users of them

[Mesa-dev] [PATCH 01/10] loader: introduce the loader util lib

2014-01-11 Thread Emil Velikov
All the various window system integration layers duplicate roughly the same code for figuring out device and driver name, pci-id's, etc. Which is sad. So extract it out into a loader util lib. Signed-off-by: Rob Clark v2 (Emil) * Separate the introduction of libloader from the code de-duplicat

[Mesa-dev] [PATCH 04/10] egl-static: use loader util lib

2014-01-11 Thread Emil Velikov
Signed-off-by: Emil Velikov --- Dare I say it Android builds are fun, when everyone else builds egl-static as separate library android shoves it back into libEGL --- src/egl/main/Android.mk| 1 + src/gallium/targets/egl-static/Makefile.am | 1 + src/gallium/targets/egl-s

[Mesa-dev] [PATCH 09/10] pipe-loader: add support for non-pci (platform) devices

2014-01-11 Thread Emil Velikov
Culled out of the "loader: refactor duplicated code into loader util lib" patch by Rob Clark. Signed-off-by: Emil Velikov --- src/gallium/auxiliary/pipe-loader/pipe_loader.h | 1 + src/gallium/auxiliary/pipe-loader/pipe_loader_drm.c | 2 ++ src/gallium/state_trackers/clover/core/device.cpp

[Mesa-dev] [PATCH 10/10] loader: fallback to drmGetVersion() for non-pci devices

2014-01-11 Thread Emil Velikov
From: Rob Clark Use the kernel driver name are returned by drmGetVersion() for non-pci(platform) devices. Signed-off-by: Rob Clark v2 (Emil): Rebased and weaked commit message. --- src/loader/loader.c | 16 ++-- 1 file changed, 14 insertions(+), 2 deletions(-) diff --git a/src/lo

[Mesa-dev] [PATCH 02/10] glx: use the loader util lib

2014-01-11 Thread Emil Velikov
Signed-off-by: Emil Velikov --- src/glx/Makefile.am | 5 +- src/glx/SConscript| 2 +- src/glx/dri3_common.c | 146 -- src/glx/dri3_glx.c| 3 +- src/glx/dri3_priv.h | 3 -- 5 files changed, 6 insertions(+), 153 deletions(-) delet

[Mesa-dev] code de-duplication and non-pci support v2

2014-01-11 Thread Emil Velikov
This is an updated series of Rob's patches * The introduction of the util library is separated from the de-duplication. * Each commit targets individual part of mesa and it should build/work regardless of build system/options. * Handles a couple more cases of de-duplication. * Hides the loader fun

[Mesa-dev] [PATCH 06/10] pipe-loader: use loader util lib

2014-01-11 Thread Emil Velikov
Signed-off-by: Emil Velikov --- src/gallium/auxiliary/pipe-loader/Makefile.am | 7 +- .../auxiliary/pipe-loader/pipe_loader_drm.c| 88 ++ 2 files changed, 14 insertions(+), 81 deletions(-) diff --git a/src/gallium/auxiliary/pipe-loader/Makefile.am b/src/gallium

[Mesa-dev] [RFC] Build testing, wine style

2014-01-11 Thread Emil Velikov
Hello list, While going though mesa's build systems I was wondering what it would take to improve the overall experience of build testing. The only thing I can think of is a more centralised solution similar to the one used by wine [1]. Having buildbots test every patch what is send to the ML [2]

[Mesa-dev] [RFC] Code de-duplication across classic mesa/gallium

2014-01-11 Thread Emil Velikov
Hello list, As you already know with the inception of gallium a lot of the classic mesa code was copied over to gallium/auxiliary for multitude of reasons. Recently I came across a handful of cases where classic mesa has become more robust while gallium is still in the mist (and vice versa). Con

Re: [Mesa-dev] Naming everything in src/gallium/drivers/radeonsi si_*

2014-01-11 Thread Andreas Hartmetz
Continuing here because the threads had diverged... I've updated the patch series under the same URL and applied all the suggested improvements. The variable renames are still in, but at the very end so they are trivial to omit. On Tuesday 07 January 2014 17:27:56 Andreas Hartmetz wrote: > We hav

Re: [Mesa-dev] /usr/lib/libglapi.la: No such file or directory

2014-01-11 Thread YuGiOhJCJ Mailing-List
On Sat, 11 Jan 2014 14:01:21 + Emil Velikov wrote: > On 11/01/14 13:44, YuGiOhJCJ Mailing-List wrote: > > On Thu, 09 Jan 2014 17:27:06 -0500 > > Trevor Woerner wrote: > > > >> On 01/09/14 12:56, YuGiOhJCJ Mailing-List wrote: > >>> So, I see /usr/lib/libglapi.la is missing. > >>> I recompile

Re: [Mesa-dev] [PATCH] i965: Ensure that all necessary state is re-emitted if we run out of aperture.

2014-01-11 Thread Eric Anholt
Paul Berry writes: > Prior to this patch, if we ran out of aperture space during > brw_try_draw_prims(), we would rewind the batch buffer pointer > (potentially throwing some state that may have been emitted by > brw_upload_state()), flush the batch, and then try again. However, we > wouldn't re

Re: [Mesa-dev] /usr/lib/libglapi.la: No such file or directory

2014-01-11 Thread Emil Velikov
On 11/01/14 13:44, YuGiOhJCJ Mailing-List wrote: > On Thu, 09 Jan 2014 17:27:06 -0500 > Trevor Woerner wrote: > >> On 01/09/14 12:56, YuGiOhJCJ Mailing-List wrote: >>> So, I see /usr/lib/libglapi.la is missing. >>> I recompile MesaLib-8.0.4 like this: >> >> 8.0.4 is from July 10, 2012. Would it b

Re: [Mesa-dev] /usr/lib/libglapi.la: No such file or directory

2014-01-11 Thread YuGiOhJCJ Mailing-List
On Thu, 09 Jan 2014 17:27:06 -0500 Trevor Woerner wrote: > On 01/09/14 12:56, YuGiOhJCJ Mailing-List wrote: > > So, I see /usr/lib/libglapi.la is missing. > > I recompile MesaLib-8.0.4 like this: > > 8.0.4 is from July 10, 2012. Would it be possible to try something newer? I have compiled mesa

Re: [Mesa-dev] [PATCH 1/3] radeon: Move gfx/dma cs cleanup to r600_common_context_cleanup

2014-01-11 Thread Marek Olšák
Reviewed-by: Marek Olšák Marek On Sat, Jan 11, 2014 at 1:45 AM, Aaron Watry wrote: > The radeonsi code was not cleaning up either of these items leading to > leaked memory. > > v2: Move cleanup to r600_common_context_cleanup instead of duplicating > the logic for SI > > CC: "10.0" > --- >

[Mesa-dev] [PATCH 4/8] glsl: Cast ir_call parameters to ir_rvalue, not ir_instruction.

2014-01-11 Thread Kenneth Graunke
A function call's parameters are always rvalues. ir_rvalue may not always be a subclass of ir_instruction in the future, so we should use the right one. Signed-off-by: Kenneth Graunke --- src/glsl/ir_print_visitor.cpp | 4 ++-- src/glsl/opt_copy_propagation.cpp | 2 +- src

[Mesa-dev] [PATCH 1/8] glsl: Convert piles of foreach_iter to the newer foreach_list macro.

2014-01-11 Thread Kenneth Graunke
foreach_iter and exec_list_iterators have been deprecated for some time now; we just hadn't ever bothered to convert code to the newer foreach_list and foreach_list_safe macros. In these cases, we aren't editing the list, so we can use foreach_list rather than foreach_list_safe. Signed-off-by: Ke

[Mesa-dev] [PATCH 5/8] glsl: Statically cast parameter exec_node to ir_variable.

2014-01-11 Thread Kenneth Graunke
Formal function parameters are always ir_variable objects, not an arbitrary ir_instruction. So there's no need to dynamically cast here. Signed-off-by: Kenneth Graunke --- src/glsl/builtin_functions.cpp | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/src/glsl/builtin_functio

[Mesa-dev] [PATCH 2/8] glsl: Convert piles of foreach_iter to foreach_list_safe.

2014-01-11 Thread Kenneth Graunke
In these cases, we edit the list (or at least might be), so we use the foreach_list_safe variant. Signed-off-by: Kenneth Graunke --- src/glsl/ir.cpp | 4 ++-- src/glsl/ir_rvalue_visitor.cpp | 4 ++-- src/glsl/lower_vec_index_to_cond_assign.cpp | 4 ++--

[Mesa-dev] Removing exec_list iterators

2014-01-11 Thread Kenneth Graunke
Hello, Here's a long overdue cleanup: removing exec_list_iterator and such. Should be fairly easy to review. I ran Piglit on i965, swrast (which uses ir_to_mesa), and softpipe (which uses st_glsl_to_tgsi). Nothing changed. --Ken ___ mesa-dev mailing

[Mesa-dev] [PATCH 6/8] glsl: Use a new foreach_list2 macro for walking two lists at once.

2014-01-11 Thread Kenneth Graunke
When handling function calls, we often want to walk through the list of formal parameters and list of actual parameters at the same time. (Both are guaranteed to be the same length.) Previously, we used a pattern of: exec_list_iterator 1st_iter = <1st list>.iterator(); foreach_iter(exec_lis

[Mesa-dev] [PATCH 8/8] glsl: Remove exec_list iterators now that nothing uses them.

2014-01-11 Thread Kenneth Graunke
Signed-off-by: Kenneth Graunke --- src/glsl/ir.h | 24 -- src/glsl/list.h | 64 - 2 files changed, 88 deletions(-) diff --git a/src/glsl/ir.h b/src/glsl/ir.h index aff6798..2ae8513 100644 --- a/src/glsl/ir.h +++ b/src/

[Mesa-dev] [PATCH 7/8] glsl: Replace iterators in ir_reader.cpp with ad-hoc list walking.

2014-01-11 Thread Kenneth Graunke
These can't use foreach_list since they want to skip over the first few list elements. Just doing the ad-hoc list walking isn't too bad. Signed-off-by: Kenneth Graunke --- src/glsl/ir_reader.cpp | 18 ++ 1 file changed, 10 insertions(+), 8 deletions(-) diff --git a/src/glsl/ir_

[Mesa-dev] [PATCH 3/8] glsl: Replace foreach_iter and iter.remove() with foreach_list_safe.

2014-01-11 Thread Kenneth Graunke
foreach_list_safe allows you to safely remove the current node. Signed-off-by: Kenneth Graunke --- src/mesa/state_tracker/st_glsl_to_tgsi.cpp | 12 ++-- 1 file changed, 6 insertions(+), 6 deletions(-) diff --git a/src/mesa/state_tracker/st_glsl_to_tgsi.cpp b/src/mesa/state_tracker/st_g