Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Dean Glazeski
On Sat, Dec 12, 2009 at 11:36 PM, David Brownell wrote: > On Saturday 12 December 2009, Marek Vasut wrote: > > > Also, can you restructure it so that you don't just add a bit > > > "if (there's a custom erase_page) { ... }"? That's the sort > > > of thing which is easier to just require. > > > >

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Dean Glazeski wrote: > > > > Also, can you restructure it so that you don't just add a bit > > "if (there's a custom erase_page) { ... }"? That's the sort > > of thing which is easier to just require. > > > > So, does this mean we restructure the entire NAND core to

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Marek Vasut wrote: > > Also, can you restructure it so that you don't just add a bit > > "if (there's a custom erase_page) { ... }"?  That's the sort > > of thing which is easier to just require. > > Require? Why? No other driver probably needs it/will find it useful.

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Marek Vasut
Dne Ne 13. prosince 2009 05:21:36 Dean Glazeski napsal(a): > > Also, can you restructure it so that you don't just add a bit > > "if (there's a custom erase_page) { ... }"? That's the sort > > of thing which is easier to just require. > > So, does this mean we restructure the entire NAND core to

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Dean Glazeski
> > Also, can you restructure it so that you don't just add a bit > "if (there's a custom erase_page) { ... }"? That's the sort > of thing which is easier to just require. > So, does this mean we restructure the entire NAND core to get rid of if (nand->function) {nand->function()} blocks for just

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Marek Vasut
Dne Ne 13. prosince 2009 03:25:07 David Brownell napsal(a): > On Saturday 12 December 2009, Marek Vasut wrote: > > > I was wondering why to merge something that doesn't have any > > > users ... :) > > > > I have pxa3xx nand driver ready that will need this, preparing ground to > > deploy it. > > M

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Marek Vasut wrote: > > > I was wondering why to merge something that doesn't have any > > users ... :) > > I have pxa3xx nand driver ready that will need this, preparing ground to > deploy > it. Mmkay... > > And was also curious what's wrong with the standard er

Re: [Openocd-development] Cross Platform Debugger

2009-12-12 Thread Michel Catudal
Carsten Breuer a écrit : Hi Michael, is there any other GDB then insight or the EclipsePlugin under windows? command line gdb Not really ;-) There is setedit that uses gdb. I haven't tried the one on windows but it works nicely on Mandriva an

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Marek Vasut
Dne So 12. prosince 2009 22:39:43 David Brownell napsal(a): > On Saturday 12 December 2009, Marek Vasut wrote: > > Dne So 12. prosince 2009 00:41:48 Marek Vasut napsal(a): > > > included is a patch that adds possibility to supply erase_page function > > > in a driver, overriding the default behavio

Re: [Openocd-development] Cross Platform Debugger

2009-12-12 Thread Carsten Breuer
Hi Michael, >> is there any other GDB then insight or the EclipsePlugin under >> windows? > command line gdb Not really ;-) > Insight and Eclipse are just applications using gdb. > > You could write your own if you dislike those. Aside from that there Yep, that's perhaps the way to go. I have t

Re: [Openocd-development] FIXED: register 'r13_svc' not found

2009-12-12 Thread Carsten Breuer
Hi David, >> Error: 500 35843 armv4_5.c:1102 armv4_5_run_algorithm_inner(): >> BUG: register 'r13_svc' not found. > The register name is now "sp_svc". I just checked in a bugfix for > that. Works perfect now, thanks a lot!!! Best Regards, Carsten __

Re: [Openocd-development] Cross Platform Debugger

2009-12-12 Thread Michel Catudal
Carsten Breuer a écrit : > Hi Guys, > > > is there any other GDB then insight or the EclipsePlugin under windows? > > > Best Regards, > > > > Carsten > > command line gdb Insight and Eclipse are just applications using gdb. You could write your own if you dislike those. Aside from that there a

Re: [Openocd-development] OpenOCD broken

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Carsten Breuer wrote: > "treat warning as errors" (-wall) is a fine thing but sometimes breaks > the build.. In my last git pull i get an error in > src/flash/nor/stellaris.c, line 644: > > LOG_DEBUG("FMPPE%d = %#8.8x (status %d)", i, lockbits, status); Should have b

Re: [Openocd-development] register 'r13_svc' not found

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Carsten Breuer wrote: > Hi all, > > > i have got during the last weeks some snapshots > from git and get always the same error message: > > Error: 500 35843 armv4_5.c:1102 armv4_5_run_algorithm_inner(): BUG: > register 'r13_svc' not found. The register name is now

[Openocd-development] [patch] ARM11: start using opcode macros

2009-12-12 Thread David Brownell
The current code is using lots of magic numbers. Improve code readability/maintainability by doing less of that. Switch one opcode over to a conventional NOP so it's more clear what's going on (and comment that, too). Minor status returning cleanup: return one code which was wrongly dropped, re

[Openocd-development] Cross Platform Debugger

2009-12-12 Thread Carsten Breuer
Hi Guys, is there any other GDB then insight or the EclipsePlugin under windows? Best Regards, Carsten ___ Openocd-development mailing list Openocd-development@lists.berlios.de https://lists.berlios.de/mailman/listinfo/openocd-development

[Openocd-development] OpenOCD broken

2009-12-12 Thread Carsten Breuer
Hi all, "treat warning as errors" (-wall) is a fine thing but sometimes breaks the build.. In my last git pull i get an error in src/flash/nor/stellaris.c, line 644: LOG_DEBUG("FMPPE%d = %#8.8x (status %d)", i, lockbits, status); This is the same with the official download snapshot i have downl

[Openocd-development] register 'r13_svc' not found

2009-12-12 Thread Carsten Breuer
Hi all, i have got during the last weeks some snapshots from git and get always the same error message: Error: 500 35843 armv4_5.c:1102 armv4_5_run_algorithm_inner(): BUG: register 'r13_svc' not found. I wonder here that the file name is armv4_5.c, because i use the configuration file of a arm7

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread David Brownell
On Saturday 12 December 2009, Marek Vasut wrote: > Dne So 12. prosince 2009 00:41:48 Marek Vasut napsal(a): > > > > included is a patch that adds possibility to supply erase_page function in > > a driver, overriding the default behaviour of core.c > > Hi, any updates ? Thanks I was wondering why

Re: [Openocd-development] NAND: add erase_page callback

2009-12-12 Thread Marek Vasut
Dne So 12. prosince 2009 00:41:48 Marek Vasut napsal(a): > Hi, > > included is a patch that adds possibility to supply erase_page function in > a driver, overriding the default behaviour of core.c > Hi, any updates ? Thanks ___ Openocd-development mail