On w64, setjmp is implemented by _setjmp which needs a second parameter.
This parameter should be NULL to allow using longjump from generated code.
This patch replaces all usages of setjmp.h with new header files which
replaces setjmp with _setjmp function on win64 platform.
Signed-off-by: Pavel D
On 2015/2/9 15:02, Michael S. Tsirkin wrote:
On Mon, Feb 09, 2015 at 03:01:15PM +0800, Chen, Tiejun wrote:
On 2015/2/8 18:48, Michael S. Tsirkin wrote:
On Fri, Feb 06, 2015 at 01:14:46PM +0100, Cornelia Huck wrote:
On Fri, 6 Feb 2015 13:41:26 +0800
Tiejun Chen wrote:
Actually we define the
On Mon, Feb 09, 2015 at 03:01:15PM +0800, Chen, Tiejun wrote:
> On 2015/2/8 18:48, Michael S. Tsirkin wrote:
> >On Fri, Feb 06, 2015 at 01:14:46PM +0100, Cornelia Huck wrote:
> >>On Fri, 6 Feb 2015 13:41:26 +0800
> >>Tiejun Chen wrote:
> >>
> >>>Actually we define these device IDs in virtio stand
On 2015/2/8 18:48, Michael S. Tsirkin wrote:
On Fri, Feb 06, 2015 at 01:14:46PM +0100, Cornelia Huck wrote:
On Fri, 6 Feb 2015 13:41:26 +0800
Tiejun Chen wrote:
Actually we define these device IDs in virtio standard, so
we'd better put them into one common place to manage conveniently.
Here
On 2015/2/7 0:28, Stefan Hajnoczi wrote:
On Fri, Feb 06, 2015 at 01:41:26PM +0800, Tiejun Chen wrote:
Actually we define these device IDs in virtio standard, so
we'd better put them into one common place to manage conveniently.
Here I also add VIRTIO_ID_RESERVE according to virtio spec.
Signed-
On 2015/2/6 20:14, Cornelia Huck wrote:
On Fri, 6 Feb 2015 13:41:26 +0800
Tiejun Chen wrote:
Actually we define these device IDs in virtio standard, so
we'd better put them into one common place to manage conveniently.
Here I also add VIRTIO_ID_RESERVE according to virtio spec.
Signed-off-by
From: Bin Wu
We tested VMs migration with their disk images by drive_mirror. With
migration, two VMs copyed large files between each other. During the
test, a segfault occured. The stack was as follow:
(gdb) bt
qemu-coroutine-lock.c:66
to=0x7fa5a1798648) at qemu-coroutine.c:97
request=0x7fa28c2f
sorry, there is a mistake in this patch: the "ret" variable is not
defined :<
I will send a new patch to fix this problem.
On 2015/2/9 12:09, Bin Wu wrote:
> From: Bin Wu
>
> The error scenario is as follow: coroutine C1 enters C2, C2 yields
> back to C1, then C1 ternimates and the related coro
On 2015/2/6 9:01, Chen, Tiejun wrote:
On 2015/2/5 17:52, Ian Campbell wrote:
On Thu, 2015-02-05 at 09:22 +0800, Chen, Tiejun wrote:
Indeed this is not something workaround, and I think in any type of VGA
devices, we'd like to diminish this sort of thing gradually, right?
This mightn't come tru
On Sun, Feb 8, 2015 at 6:51 PM, Michael S. Tsirkin
wrote:
On Fri, Feb 06, 2015 at 03:54:10PM +0800, Jason Wang wrote:
Recent linux kernel supports up to 256 tap queues. Increase the
limit
to 513 (256 * 2 + 1(ctrl vq)).
Signed-off-by: Jason Wang
We have a bunch of loops over all poss
On Fri, Feb 6, 2015 at 7:54 PM, Cornelia Huck
wrote:
On Fri, 6 Feb 2015 15:54:09 +0800
Jason Wang wrote:
VIRTIO_PCI_QUEUE_MAX was not specific to pci, so rename it to
VIRTIO_QUEUE_MAX.
Cc: Amit Shah
Cc: Anthony Liguori
Cc: Michael S. Tsirkin
Cc: Alexander Graf
Cc: Richard Hen
From: Bin Wu
We tested VMs migration with their disk images by drive_mirror. With
migration, two VMs copyed large files between each other. During the
test, a segfault occured. The stack was as follow:
(gdb) bt
#0 0x7fa5a0c63fc5 in qemu_co_queue_run_restart (co=0x7fa5a1798648) at
qemu-coro
From: Bin Wu
The error scenario is as follow: coroutine C1 enters C2, C2 yields
back to C1, then C1 ternimates and the related coroutine memory
becomes invalid. After a while, the C2 coroutine is entered again.
At this point, C1 is used as a parameter passed to
qemu_co_queue_run_restart. Therefor
On Fri, Feb 06, 2015 at 04:57:55PM +0900, Teruaki Ishizaki wrote:
> (2015/02/06 11:18), Liu Yuan wrote:
> >On Wed, Feb 04, 2015 at 01:54:19PM +0900, Teruaki Ishizaki wrote:
> >>(2015/02/02 15:52), Liu Yuan wrote:
> >>>On Tue, Jan 27, 2015 at 05:35:27PM +0900, Teruaki Ishizaki wrote:
> Previousl
On 2015-2-8 18:10, Paolo Bonzini wrote:
>
>
> On 07/02/2015 12:26, Wangting (Kathy) wrote:
>> OK, Thank you very much for your detailed explanation.
>>
>> But I have another question about the big change from qemu-1.5.3 to
>> qemu-1.6.0-rc0.
>>
>> When I use ramdisk for IO performance testing,
On 2015/1/31 15:27, Gonglei (Arei) wrote:
> From: Gonglei
>
>
> Gonglei (2):
> xen-pt: fix Negative array index read
> xen-pt: fix Out-of-bounds read
>
> hw/xen/xen_pt_config_init.c | 11 +++
> 1 file changed, 7 insertions(+), 4 deletions(-)
>
Ping...
Regards,
-Gonglei
On 02/03/2015 07:01 PM, Paolo Bonzini wrote:
>
>
> On 03/02/2015 10:22, Kevin Wolf wrote:
>> Paolo, I think it's rather surprising that iov_send_recv() modifies its
>> iov. The modification is undone at the end, so you seem to have
>> considered that a caller might be reusing it after and you can
On 09.02.15 01:37, David Gibson wrote:
> On Fri, 06 Feb 2015 08:56:32 +0100
> Alexander Graf wrote:
>
>>
>>
>> On 06.02.15 03:54, David Gibson wrote:
>>> On Thu, Feb 05, 2015 at 12:55:45PM +0100, Alexander Graf wrote:
On 05.02.15 12:30, David Gibson wrote:
> On Thu, Feb 05, 2
On Fri, 02/06 11:23, Fam Zheng wrote:
> On Thu, 02/05 15:29, massimo buscato wrote:
> > Hi all!
> >
> > About virtio-scsi driver:
> > There are many problem to use it on windows 2012 cluster service.
> >
> > Every time you try to validate a Virtio disk under W2012 cluster tool,
> > you have this
Hi
I would like to do GSOC this summer. The project i have in mind is to
implement a set of facilities to make implementing Hardware
transactional memory (HTM) easier in QEMU.
HTM has become available in many architecture supported by QEMU, e.g.
i386, PowerPC, etc. Currently, necessary memory tra
On 08/02/2015 13:14, Borislav Petkov wrote:
> On Sun, Feb 08, 2015 at 11:09:24AM +0100, Paolo Bonzini wrote:
>> Cc: qemu-triv...@nongnu.org
>
> Thanks.
>
> But, there's more b0rked with this error message so you might wanna take
> the patch below instead.
>
> Btw, what are the vim settings whe
On 02/07/2015 08:38 AM, Jan Kiszka wrote:
> This addresses the review comments on the previews two patches to add
> qAttached support. No longer trivial, so maybe you can pick it up,
> Peter.
Excellent, thanks for doing this Jan. Looks good to me.
Thanks,
Pedro Alves
On 08/02/2015 18:22, Alex Williamson wrote:
> Ok, I went back to 83761b9244ad, applied 3a4dbe6aa934 to get the
> object_unparent() fix, then applied this series. Everything seems to
> work ok. Then I manually applied and bisected the commits that came in
> via d5fbb4c9ed52. I land on 374f2981d
Not all sysemu.h users need the NUMA declarations, and keeping them in a
separate file makes easier to see what are the interfaces provided by
numa.c.
Signed-off-by: Eduardo Habkost
---
hw/i386/pc.c| 1 +
hw/mem/pc-dimm.c| 1 +
hw/ppc/spapr.c | 1 +
include/sysemu
This function does some initialization that needs to be done after
machine init. The function may be eventually removed if we move the
CPUState.numa_node initialization to the CPU init code, but while the
function exists, lets give it a name that makes sense.
Signed-off-by: Eduardo Habkost
---
i
There's no need to zero-initialize globals, they are automatically
initialized to zero.
Signed-off-by: Eduardo Habkost
---
vl.c | 8
1 file changed, 8 deletions(-)
diff --git a/vl.c b/vl.c
index 63ec996..8a32a4b 100644
--- a/vl.c
+++ b/vl.c
@@ -2818,14 +2818,6 @@ int main(int argc, cha
This allows us to make numa_init_func() static.
Signed-off-by: Eduardo Habkost
---
include/sysemu/numa.h | 1 -
numa.c| 9 -
vl.c | 5 -
3 files changed, 8 insertions(+), 7 deletions(-)
diff --git a/include/sysemu/numa.h b/include/sysemu/numa.h
index
Renaming set_numa_nodes() and numa_init_func() to parse_numa_opts() and
parse_numa() makes the purpose of those functions clearer.
Signed-off-by: Eduardo Habkost
---
include/sysemu/numa.h | 2 +-
numa.c| 6 +++---
vl.c | 2 +-
3 files changed, 5 insertions(+), 5
Signed-off-by: Eduardo Habkost
---
numa.c | 3 +++
vl.c | 4
2 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/numa.c b/numa.c
index 40f3d36..61531db 100644
--- a/numa.c
+++ b/numa.c
@@ -45,6 +45,9 @@ QemuOptsList qemu_numa_opts = {
};
static int have_memdevs = -1;
+int nb
Now the only code that uses the variable is inside numa.c.
Signed-off-by: Eduardo Habkost
---
include/sysemu/numa.h | 3 ---
numa.c| 4 +++-
2 files changed, 3 insertions(+), 4 deletions(-)
diff --git a/include/sysemu/numa.h b/include/sysemu/numa.h
index 514914f..eae881e 100644
This cleans up some of the NUMA code: moves declarations to numa.h, rename some
functions, and remove some existing code that was inside main().
Eduardo Habkost (7):
numa: Move NUMA declarations from sysemu.h to numa.h
vl.c: Remove unnecessary zero-initialization of NUMA globals
numa: Move N
On Sat, 2015-02-07 at 21:00 +0100, Paolo Bonzini wrote:
>
> On 07/02/2015 02:39, Alex Williamson wrote:
> > I'm not sure where it's coming from yet, but I did extensive testing for
> > my last pull request based on ec6f25e because if I updated to d5fbb4c
> > vfio hotplug broke immediately. I'll k
Fix this warning:
hmp.c:414:38: warning: Using plain integer as NULL pointer
qmp_query_block expects a pointer argument, so passing false is wrong.
Cc: Luiz Capitulino
Signed-off-by: Stefan Weil
---
hmp.c |2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/hmp.c b/hmp.c
inde
Casting to a union type is a gcc (and clang) extension. Other compilers
might not support it. This is not a problem today, but the type casts
can be removed easily. Smatch now no longer complains like before:
linux-user/syscall.c:3190:18: warning: cast to non-scalar
linux-user/syscall.c:7348:44: w
On Wed, Nov 26, 2014 at 11:57 PM, Stefan Hajnoczi
wrote:
> On Thu, Nov 06, 2014 at 10:43:50PM +0800, Xiaodong Gong wrote:
> > Now qemu only supports vhd type VHD_FIXED and VHD_DYNAMIC, so qemu
> > can't read snapshot volume of vhd, and can't support other storage
> > features of vhd file.
> >
> >
Now qemu only supports vhd type VHD_FIXED and VHD_DYNAMIC, so qemu
can't read snapshot volume of vhd, and can't support other storage
features of vhd file.
This patch add read parent information in function "vpc_open", read
bitmap in "vpc_read", and change bitmap in "vpc_write".
Signed-off-by: Xi
When open the vpc snapshot based FIXED format, its backing file,
this FIXED vpc image, could be probed as a raw image, because that
the find_image_format just checkout the first sector.
Add a re-probe for the last sector to FIXED base vpc image,when get
a NULL or raw driver in first sector probe.
On Wed, Nov 26, 2014 at 11:32 PM, Stefan Hajnoczi
wrote:
> On Thu, Nov 06, 2014 at 10:43:50PM +0800, Xiaodong Gong wrote:
> > +} else if (platform == PLATFORM_W2RU) {
> > +/* Must be UTF16-LE to ASCII */
> > +char *out, *optr;
> > +int j;
> > +
> > +
On Sun, Feb 08, 2015 at 11:09:24AM +0100, Paolo Bonzini wrote:
> Cc: qemu-triv...@nongnu.org
Thanks.
But, there's more b0rked with this error message so you might wanna take
the patch below instead.
Btw, what are the vim settings when doing patches for qemu, this must be
documented somewhere as
On Fri, 6 Feb 2015, Maciej W. Rozycki wrote:
> > >> I think this means that:
> > >> (1) we want to put handling of silencing the signaling NaNs
> > >> into the NaN conversion functions themselves (since it's
> > >> too late to do it correctly once the commonNaNtoFloat16
> > >> function has thr
On 02/04/2015 11:01 AM, Igor Mammedov wrote:
Linker and RSDP tables are build only once, so if later
during rebuild sizes of other ACPI tables change
pointers will be patched incorrectly due to wrong
offsets in RSDP and linker.
To fix it rebuild linker and RSDP tables along with
the rest of ACPI
04.02.2015 13:26, Markus Armbruster wrote:
> I'm routing these patches through qemu-trivial, even though some of
> them touch actively maintained code, and could go through the
> respective tree instead:
>
> * PATCH 1 block (Kevin, Stefan)
>
> * PATCH 3 KVM (Paolo)
>
> * PATCH 4 migration (Juan,
On Fri, Feb 06, 2015 at 03:54:10PM +0800, Jason Wang wrote:
> Recent linux kernel supports up to 256 tap queues. Increase the limit
> to 513 (256 * 2 + 1(ctrl vq)).
>
> Signed-off-by: Jason Wang
We have a bunch of loops over all possible VQ numbers in virtio pci.
Doing this for 1000 VQs when mos
07.02.2015 00:43, Stefan Weil wrote:
> All warnings were reported by the Sparse static analysis tool.
>
> [PATCH 01/10] disas/cris: Fix warning caused by missing 'static'
> [PATCH 02/10] disas/sh4: Fix warning caused by missing 'static'
> [PATCH 03/10] migration: Fix warning caused by missing decl
On Fri, Feb 06, 2015 at 01:14:46PM +0100, Cornelia Huck wrote:
> On Fri, 6 Feb 2015 13:41:26 +0800
> Tiejun Chen wrote:
>
> > Actually we define these device IDs in virtio standard, so
> > we'd better put them into one common place to manage conveniently.
> > Here I also add VIRTIO_ID_RESERVE ac
On 07/02/2015 12:26, Wangting (Kathy) wrote:
> OK, Thank you very much for your detailed explanation.
>
> But I have another question about the big change from qemu-1.5.3 to
> qemu-1.6.0-rc0.
>
> When I use ramdisk for IO performance testing, the result is as follows.
>
> [fio-test]
Cc: qemu-triv...@nongnu.org
On 07/02/2015 21:29, Borislav Petkov wrote:
> From: Borislav Petkov
>
> Add the missing space to separate address from "specified".
>
> Cc: Anthony Liguori
> Cc: Paolo Bonzini
> Signed-off-by: Borislav Petkov
> ---
> cpus.c | 2 +-
> 1 file changed, 1 insertion(+
47 matches
Mail list logo