Re: Review Request 70217: Implemented the remain functionalities for v0 `VolumeManager`.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70217/#review213744 --- FAIL: Some of the unit tests failed. Please check the relevant

Review Request 70215: Implemented volume attachment and publishment for v0 `VolumeManager`.

2019-03-14 Thread Chun-Hung Hsiao
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70215/ --- Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht. Bugs:

Review Request 70217: Implemented the remain functionalities for v0 `VolumeManager`.

2019-03-14 Thread Chun-Hung Hsiao
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70217/ --- Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht. Bugs:

Review Request 70216: Implemented the recovery logic for v0 `VolumeManager`.

2019-03-14 Thread Chun-Hung Hsiao
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70216/ --- Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht. Bugs:

Review Request 70214: Added skeleton code for v0 `VolumeManager`.

2019-03-14 Thread Chun-Hung Hsiao
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70214/ --- Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht. Bugs:

Review Request 70213: Added the `VolumeManager` interface to manage CSI volumes.

2019-03-14 Thread Chun-Hung Hsiao
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70213/ --- Review request for mesos, Benjamin Bannier, Jie Yu, and Jan Schlicht. Bugs:

Re: Review Request 70211: PoC: Prefix filtering for the metrics endpoint.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70211/#review213743 --- FAIL: Some of the unit tests failed. Please check the relevant

Re: Review Request 70084: Avoid dereferencing removed executors and launching containers for them.

2019-03-14 Thread Meng Zhu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70084/#review213740 --- Fix it, then Ship it! Thanks for the cleanup! A test to guard

Re: Review Request 70211: PoC: Prefix filtering for the metrics endpoint.

2019-03-14 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70211/#review213742 --- Bad review! Reviews applied: [] Error: No reviewers specified.

Review Request 70211: PoC: Prefix filtering for the metrics endpoint.

2019-03-14 Thread Benno Evers
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70211/ --- Review request for mesos. Repository: mesos Description --- This patch

Review Request 70210: Fixed http handler lookup for process root route.

2019-03-14 Thread Benno Evers
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70210/ --- Review request for mesos. Bugs: MESOS-9652

Re: Review Request 70063: Added test for `ResourceQuantities` arithmetic operations.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70063/#review213741 --- PASS: Mesos patch 70063 was successfully built and tested.

Re: Review Request 70201: Added a method to check `ResourceLimits::contains(ResourceQuantities)`.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70201/#review213739 --- FAIL: Some of the unit tests failed. Please check the relevant

Re: Review Request 70203: Updated a test for `UPDATE_QUOTA` call validation.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70203/#review213737 --- FAIL: Some of the unit tests failed. Please check the relevant

Re: Review Request 70151: Added `class ResourceLimits`.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 12:12 p.m., Benjamin Mahler wrote: > > src/common/resource_quantities.cpp > > Lines 398 (patched) > > > > > > Ah, this is indeed a little more concrete than saying "items" like > > above, but

Re: Review Request 70203: Updated a test for `UPDATE_QUOTA` call validation.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 12:29 p.m., Benjamin Mahler wrote: > > src/tests/master_validation_tests.cpp > > Lines 307-308 (original), 164-165 (patched) > > > > > > Do we want the extra spaces after { and before }? It is

Re: Review Request 70202: Added call handler for `UPDATE_QUOTA`.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 12:54 p.m., Benjamin Mahler wrote: > > src/master/master.hpp > > Lines 1169 (patched) > > > > > > Hm.. what does "available" mean here? Is this expressing an intention > > to only use it for

Re: Review Request 70116: Added metrics for offer operation feedback.

2019-03-14 Thread Greg Mann
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70116/#review213734 --- src/master/metrics.hpp Lines 82-84 (patched)

Re: Review Request 70161: Added validation for `QuotaConfig`.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 12:23 p.m., Benjamin Mahler wrote: > > src/master/quota.cpp > > Lines 323-349 (patched) > > > > > > At first I thought there was a missing closing / opening single quotes > > on these, maybe we

Re: Review Request 70198: Added validation method for input scalar values.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 11:15 a.m., Benjamin Mahler wrote: > > src/common/validation.hpp > > Lines 74 (patched) > > > > > > s/const// > > > > Was expecting this to take a Value::Scalar, might be worth a comment

Re: Review Request 70201: Added a method to check `ResourceLimits::contains(ResourceQuantities)`.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 12:37 p.m., Benjamin Mahler wrote: > > src/common/resource_quantities.cpp > > Lines 406-418 (patched) > > > > > > This is very clean and readable! I guess we're ok with the re-scanning > >

Re: Review Request 70150: Replaced a constructor in `ResourceQuantities`.

2019-03-14 Thread Meng Zhu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70150/ --- (Updated March 14, 2019, 4:57 p.m.) Review request for mesos and Benjamin

Re: Review Request 70117: Added unit tests for offer operation feedback metrics.

2019-03-14 Thread Greg Mann
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70117/#review213732 --- Could you also update a test to verify that metrics transition

Re: Review Request 70149: Added a `contains` method in `ResourceQuantities`.

2019-03-14 Thread Meng Zhu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70149/ --- (Updated March 14, 2019, 4:56 p.m.) Review request for mesos and Benjamin

Re: Review Request 70062: Refactored and augmented `class ResourceQuantities`.

2019-03-14 Thread Meng Zhu
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70062/ --- (Updated March 14, 2019, 4:53 p.m.) Review request for mesos and Benjamin

Re: Review Request 70062: Refactored and augmented `class ResourceQuantities`.

2019-03-14 Thread Meng Zhu
> On March 13, 2019, 11:55 a.m., Benjamin Mahler wrote: > > src/common/resource_quantities.hpp > > Line 122 (original), 114 (patched) > > > > > > I'm curious why the rename, `get` still seems like a more readable

Re: Review Request 70185: Renamed Master::sendBulkOperationFeedback() function.

2019-03-14 Thread Greg Mann
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70185/#review213728 --- Fix it, then Ship it! src/master/master.hpp Line 940

Re: Review Request 70116: Added metrics for offer operation feedback.

2019-03-14 Thread Greg Mann
> On March 12, 2019, 10:56 p.m., Joseph Wu wrote: > > src/master/master.cpp > > Lines 11361-11385 (original), 11378-11402 (patched) > > > > > > I'm curious what would be the proper way to handle operation > >

Re: Review Request 70208: Added test for reconciliation of multiple operations.

2019-03-14 Thread Mesos Reviewbot Windows
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70208/#review213724 --- PASS: Mesos patch 70208 was successfully built and tested.

Re: Review Request 70208: Added test for reconciliation of multiple operations.

2019-03-14 Thread Mesos Reviewbot
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70208/#review213723 --- Patch looks great! Reviews applied: [70200, 70208] Passed

Re: Review Request 70200: Changed operation reconciliation to send updates on the event stream.

2019-03-14 Thread Greg Mann
--- This is an automatically generated e-mail. To reply, visit: https://reviews.apache.org/r/70200/ --- (Updated March 14, 2019, 5:24 p.m.) Review request for mesos, Benjamin

Re: Review Request 70116: Added metrics for offer operation feedback.

2019-03-14 Thread Joseph Wu
> On March 12, 2019, 3:56 p.m., Joseph Wu wrote: > > src/master/master.cpp > > Lines 11361-11385 (original), 11378-11402 (patched) > > > > > > I'm curious what would be the proper way to handle operation > >

Re: Review Request 70116: Added metrics for offer operation feedback.

2019-03-14 Thread Benno Evers
> On March 12, 2019, 10:56 p.m., Joseph Wu wrote: > > src/master/master.cpp > > Lines 11361-11385 (original), 11378-11402 (patched) > > > > > > I'm curious what would be the proper way to handle operation > >